Skip navigation
This discussion is archived

Syslogd makes high CPU Load and standby mode doesn´t work.

23294 Views 98 Replies Latest reply: Dec 27, 2008 5:57 AM by CT RSS
  • Matthew Post Calculating status...
    Excellent! That was my problem exactly. My powerpc process was "privoxy", and for some reason it was causing launchd to consume 1.5 GB of RAM, bringing my system to a crawl. Killing privoxy (the only powerpc program) fixed it.
    Mac OS X (10.5.4)
  • kanny Calculating status...
    So I am the latest victim to syslogd terror

    Here is my repeating log

    ----
    Oct 4 16:55:00 Macintosh ScreenSaverEngine[491]: * <QCView: 0x13bbd0>: Render failed at time 5.133353s
    Oct 4 16:55:00 Macintosh ScreenSaverEngine[491]: * Message from <QCJavaScript = 0x04DBA8F0 "JavaScript_2">:\nExecution failed at time 5.167
    Oct 4 16:55:00 Macintosh ScreenSaverEngine[491]: * Message from <QCPatch = 0x04D8DE20 "Patch_8">:\nExecution failed at time 5.167
    Oct 4 16:55:00 Macintosh ScreenSaverEngine[491]: * Message from <QCPatch = 0x044D6AC0 "(null)">:\nExecution failed at time 5.167
    -----

    And this happens when i try to change a screen saver in system preferences or when stopping the screen saver after it came into effect. And it all used to work fine upto two days ago when i got my disk full and had to hard-shutdown. May be the latest java update ? whatever.

    Here is the crashreporter log for the screensaver :

    ----
    Thread 0 Crashed:
    0 com.apple.JavaScriptCore 0x94539bdc KJS::Heap::registerThread() + 28
    1 com.apple.JavaScriptCore 0x945307b4 JSContextGetGlobalObject + 36
    2 ...QuartzComposer.ExtraPatches 0x04380a2c 0x4375000 + 47660
    3 com.apple.QuartzComposer 0x92664254 -[QCPatch(Private) _cleanup] + 264
    4 com.apple.QuartzComposer 0x9265958c -[GFList makeObjectsPerformSelector:] + 96
    5 com.apple.QuartzComposer 0x926641a8 -[QCPatch(Private) _cleanup] + 92
    6 com.apple.QuartzComposer 0x9265958c -[GFList makeObjectsPerformSelector:] + 96
    7 com.apple.QuartzComposer 0x926641a8 -[QCPatch(Private) _cleanup] + 92
    8 com.apple.QuartzComposer 0x9265958c -[GFList makeObjectsPerformSelector:] + 96
    9 com.apple.QuartzComposer 0x926641a8 -[QCPatch(Private) _cleanup] + 92
    10 com.apple.QuartzComposer 0x92664070 -[QCContext stopRenderingPatch:] + 132
    11 com.apple.QuartzComposer 0x92663fd4 -[QCGraphicsContext stopRenderingPatch:] + 80
    -----

    So who is the culprit - JavaScript, a specific ScreenSaver, ScreenSaverEngine, SystemPreferences App, syslogd or Leopard ? My guess is that it is caused by one app in this case ScreenSaverEngine but that in turn is due to JavaScript rendering issue only.

    Here is my suggestion (not a fix) :
    1. use terminal to stop the syslogd and remove the log files asl.log and system.log and restart syslogd - it helps mostly except sometimes it resumes cpu usage (simply changing the error-reporting-level from 5 to 4 doesn't help)
    2. repair disk permissions and clean up system caches - this has helped me so far : no cpu eating by syslogd
    3. update the app in question or avoid using it : i have still to do it
    4. archive and install - this should be the last resort.
    PowerBook G4 15", Mac OS X (10.5.5), 1.5GHz/512MB/80GB
  • kanny Level 1 Level 1 (25 points)
    It turned out that the real culprit was a specific Screen Saver and not the ScreenSaverEngine.app

    But the problem was i couldn't even change the screensaver as it crashed and syslogged enormously. Finally i had to pull out the com.apple.screensaver.12345678abcd.plist from my backup and replaced the corrupted one. And huh, the problem is gone.

    So syslogd is not the root cause of high cpu usage but a corrupt app and its pref file are. Despite of this finding, i would have wished a more decent behaviour from syslogd in terms of not logging the same message repeatedly more than a certain no of times.
    PowerBook G4 15", Mac OS X (10.5.5), 1.5GHz/512MB/80GB
  • Alexander Grove Level 1 Level 1 (15 points)
    I've had this problem ever since installing Leopard. My issue seems to be related to using a Huawei Mobile Broadband dongle. It sends the system crazy. I used every fix I could find and had everything working fine until the latest security update from Apple (2008-007). Now, having a nightmare. Had to kill spotlight as mds is going nuts and syslog too. APPLE, WHAT THE F*!!!!!!! Clearly not enough of us are having these problems to warrant a proper fix. Jeesh
    12" Powerbook G4, Mac OS X (10.5.5)
  • dohrayme72 Calculating status...
    I see that same problem - upgraded from Tiger to Leopard 10.5.5 and whenever the HUAWEI Mobile appliation is open the mds process takes huge amounts of CPU. Note I don't even have to be connected to the mobile network, just having the app open causes it.

    Is it because the app is quite verbose in logging to system.log? If so, how can I stop it causing mds going crazy.
    Macbook 2GHZ, Mac OS X (10.5.5)
  • Larspa Calculating status...
    Have begun having the same syslogd hogging resources problem. One recommendation was to check for runaway apps or apps writing excessively. Another had to do with memory hogs. Don't see any of the above. However, I have the following from the system crash reporter ---

    syslogd2008-11-10-111824Bodo.crash
    syslogd2008-11-10-145620Bodo.crash
    syslogd2008-11-10-145622Bodo.crash
    syslogd2008-11-10-145632Bodo.crash
    syslogd2008-11-10-152004Bodo.crash
    syslogd2008-11-12-011600Bodo.crash
    syslogd2008-11-14-064615Bodo.crash

    Since it sounds like most of us have never run into this before, it sure seems as though its got to be an OS-X bug. Has Apple weighed in at all on this (no, i didn't read through all 7 pages of messages.)

    te
    Mini Mac e/w 1.25 GB, Mac OS X (10.5)
  • DDdaviking Level 1 Level 1 (0 points)
    Got the same problem on my Macbook.... (Leopard 10.5.5).
    Apple! Wake up and at least comment on this??
    MacBook, Powerbook G4 & iMac, Mac OS X (10.4.7)
  • MMWattle Calculating status...
    I downloaded Maintidgit, (http://mac.softpedia.com/get/Dashboard-Widgets/Status-Info/Maintidget.shtml) ran the scripts and seem to have solved the problem. My problem appears to have started on the same day as I downloaded the 10.5.6 update
    MacBook 1,1, Mac OS X (10.5.6)
  • CT Level 6 Level 6 (14,995 points)
    DDdaviking wrote:
    Got the same problem on my Macbook.... (Leopard 10.5.5).
    Apple! Wake up and at least comment on this??


    No comment.
    MacBookPro5,1, Titanium Powerbook,, Mac OS X (10.5.6)
1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.