Skip navigation
This discussion is archived

DISABLING OPTICAL AUDIO OUT IN OS X

26294 Views 17 Replies Latest reply: Jun 17, 2009 1:00 AM by FlashGen RSS
1 2 Previous Next
rvcasrfr Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 13, 2008 4:21 AM
You know what, I've been a devout Apple fan for a VERY long time... but in the past 2 months my Macbook Pro has been falling apart and it is just out of warranty. It took me 2 days to install Leopard and get Boot Camp working... Whatever... this isn't a rant.. I need help with my digital audio out.

You would think Apple would have something as simple as a DEVICE MANAGER to disable particular hardware you're having problems with or don't want to use. But no, no such thing in OS X (are you kidding me)?

My digital audio out first was on all the time. I stuck a toothpick in there and fixed that... but guess what now? Whenever I plug in a pair of **** headphones, THE DIGITAL AUDIO COMES ON. NOTHING that I can do will fix it. I am constantly on business trips on trains, planes, etc.. and I NEED to be able to use my headphone jack.

This could be EASILY fixed by disabling the digital audio out, but of course Apple doesn't have an interface to easily disable/enable hardware.

I have about had it up to here with my Macbook Pro. I love the thing and it has been one of the greatest computers I ever had, but I'm about to give Apple the finger and go back to the PC world.

Someone please give me a fix for this because I am racking my brain, have a flight tomorrow, and as most of you can tell I am frustrated. <Edited by Moderator>

Thanks.
Macbook, Mac OS X (10.5.2)
  • Floydius Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2008 7:49 PM (in response to rvcasrfr)
    I've been searching to a solution to this for some time, and so far the only plausible one is to have the logic board replaced. My macbook started having the "optical audio on all the time" thing (red light shining out of audio port) just after the warranty was out. Tried the toothpick thing, but no dice. So the only way I can use audio is either a) plug in headphones or b) running linux on the thing where the optical audio isn't recognized. And, as you say, having a driver disable feature for the optical audio would be VERY helpful.
    Macbook, 13" Core 2 Duo, White, Mac OS X (10.4.11), 2 GB Corsair Ram
  • chethan Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 20, 2008 5:55 AM (in response to rvcasrfr)
    Same problem. It's becoming /increasingly/ inconvenient. Not what I expected, otherwise I love my macbook. A device manager or something similar would be quite helpful here.
    macbook (original), Mac OS X (10.5.2)
  • ATVFrenzy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 2, 2008 1:32 PM (in response to chethan)
    I'm having the same problem, intermittently (which is even more annoying, if possible).

    All I want is a checkbox under System Preferences --> Sound that says "Ignore the poorly designed switch in the headphone port?". That isn't so much to ask, is it?

    I'd gladly settle for a command from the command line, or editing a configuration file somewhere. That is much easier than a soldering iron, which is the option I'm about down to.
    MacBook, Mac OS X (10.5.3), 2 GB RAM, 200 GB 7200 HD
  • MikeinAustin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2008 9:56 PM (in response to ATVFrenzy)
    Same problem, no soloution other than using an outboard Firewire Audio I/O box like the M Audio or Berihnger units. Cumbersome and a power drain if you're on battery, and you can also sometimes hear a delay, but it works.

    Why is there A) no way to just replace the faulty jack without doing the entire logic board and B) no software solution to just disable the jack so at least the internal speakers will work.

    Way to go, Apple.
    MacBook, Mac OS X (10.4.11)
  • PauldeHs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 31, 2008 1:00 AM (in response to rvcasrfr)
    I'm having the same problem: when I first start up my MacBook, audio works fine. After using headphones or external speaker via the audio-out jack, the optical audio comes on and my internal speakers are disabled. Sometimes putting the jack back in and pulling it out in a different way gets the internal speakers back to work, but sometimes it doesn't.

    I never ever use the optical audio, so disabling it would be a perfect solution for me. I don't realy want to take it in for service, because I work with it every day...

    Apple, please come up with a good solution for this issue...

    Thanks!
    MacBook 2.4 GHz 2GB RAM 250GB HD, Mac OS X (10.5.4)
  • averysmallcreature Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 17, 2008 7:58 AM (in response to PauldeHs)
    Same here. Didn't start happening until the warranty was up.

    Pretty nice trick, eh?

    Shut down. Unplugged headphones. Booted up. Same thing: red optical light on.

    Light disappears after a while but will light up again when I attempt to increase/decrease volume.

    Internal speakers no longer work.

    Ummm... ok. So after I posted this, they're working again. I didn't do anything.

    Message was edited by: averysmallcreature
    MacBook Pro, Mac OS X (10.4.11), 2.4GHz Intel Core 2 Duo 4GB RAM
  • Mikey Holinsky Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 8, 2008 8:52 AM (in response to rvcasrfr)
    Hey guys! To fix mine all I did was put the headphone jack in and out of the headphone jack place (I'm not a computer guy if you can't tell) really fast... like 20 or 30 times and the light turned off and the speakers are now working, but I am scared to put something back in there again. Anyhow that's what I did and it now works.
    MacBook, Mac OS X (10.5.5)
  • smonsma Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2008 7:45 AM (in response to Mikey Holinsky)
    I have the same issue in a Powerbook G4, but no amount of inserting/removing headphones, q-tips, toothpicks, metal rods, etc has had any effect on the stuck switch. I'm going to try a blast of compressed air to see if that will budge it, but don't hold out a lot of hope for that. How about asking the author of Hardware Monitor to dig deeper into the code for disabling it in software?
    PowerBook G4 17", Mac OS X (10.5.5)
  • nonotatall Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2008 11:46 AM (in response to rvcasrfr)
    I also have the problem as described by the original poster, I've tried toothpicks, headphone jacks and I even went and bought an optical cable but no amount of plugging/unplugging or poking around solves the problem.

    The internal speakers work fine upon startup then the red light comes on and the speakers cease to work. Headphones or external speakers work fine.

    There MUST be a way to disable the digital out using a software approach as the fact that the speakers work upon startup and the headphones work indicates that it is not a just a mechanical issue.

    Aside from this I'm actually pretty happy with the macbook, unlike the original person, I'd just like to solve this infuriating little problem.

    I'm considering cracking the case open to see if I can fiddle with the jack/switch from that side, anybody any experience with that?
    Macbook, Mac OS X (10.4.10)
  • Pashtet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2008 1:36 PM (in response to rvcasrfr)
    Oh, I really don't know what to do... Paperclip, match, toothpick - nothing worked for me!
    I thought everything made by Apple is perfect, but such stupid things make me really frustrated.
    So, Apple, you should save your reputation by enabling an option to disable optical out in System Prefs. Considering this should be fixed in 10.5.6 update. I know, it's not so hard work for you, Apple! Just do it!
    MacBook Black, Mac OS X (10.5.5)
  • Pashtet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2008 1:55 PM (in response to rvcasrfr)
    By the way, we should act too!
    Anyone, who faced this problem, please, write them a feedback
    http://www.apple.com/feedback/macbook.html

    Apple should hear us!
    MacBook Black, Mac OS X (10.5.5)
  • Marckemil Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2008 10:21 AM (in response to rvcasrfr)
    Hi! Having the same problem here... Happened just after updating to 10.5.6... don't know if it's related. Of course, i'm out of warranty.
    macbook, Mac OS X (10.5.6)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.