1 2 Previous Next 24 Replies Latest reply: Dec 17, 2008 5:35 PM by Marc Blitstein Go to original post
  • 15. Re: Go Daddy & iPhone
    Evtide Level 1 Level 1 (0 points)
    I too am having this exact problem (can rx email on a godaddy account but can't tx). Godaddy support is firm that if the settings work on my pc or mac, they should work on the Iphone as well. I'll follow this thread in case there's a breakthough, but for now I'm using the Godaddy webmail page on the iphone but it's just a bad workaround.

    Oh, the joys of technology.
  • 16. Re: Go Daddy & iPhone
    heartsnatcher Level 1 Level 1 (15 points)
    My GoDaddy account works without any problems. Ironically, my wife's phone is getting all sent mail bounced back as invalid address or whatever EXCEPT for my GoDaddy account.

    Make sure your user name is your full email address, not just the first part. And, odd as it sounds, check your spelling in all the settings. I hope it works for you soon.
  • 17. Re: Go Daddy & iPhone
    Evtide Level 1 Level 1 (0 points)
    For anyone following this thread, here's what I did to solve the problem:

    - Select the email account in question, in my case it is a Godaddy-hosted account.
    - Scroll down to the 'Outgoing Mail Server' tab.
    - Select the AT&T SMTP server, switch to 'on'.
    - Make sure all 'other' smtp servers are in the OFF position.

    Should be good to go!
  • 18. Re: Go Daddy & iPhone
    alamp Level 1 Level 1 (0 points)
    Wow, thank you for sharing this solution Evtide. It worked for me! Hopefully it will continue to work on wi-fi, 3G and EDGE...
  • 19. Re: Go Daddy & iPhone
    suesmac Level 1 Level 1 (5 points)
    Just got my iphone and was having problems as well...I tried all of these suggestions...then deleted and re-entered with the default settings...All I changed was this

    "In order to set godaddy email accounts up on the new 3G iPhone, you MUST append the port to the end of the SMTP address - so when entering, use the following:

    smtpout.secureserver.net:465"

    I got this information from this link: http://bandelierdesign.wordpress.com/2008/07/31/the-battle-djour/

    Bingo! It worked!
  • 20. Re: Go Daddy & iPhone
    mdiehl Level 1 Level 1 (0 points)
    All,

    I just picked up the G3 and experienced the same problem. After some time on the phone with support, here's the solution:

    Manually set up the godaddy information
    pop.secureserver.net
    user name (full Email)
    password

    smtp.secureserver.net
    user name (full Email)
    password.

    Make sure POP is selected instead of IMAP and then click "save"

    It will then try to connect, and you'll probably get a message saying it can't connect via SSL.

    Click "no" when asked if you want to try without SSL.

    Click save. you'll probably get some sort of message asking if you're sure.

    Now that the account is saved, go into settings, then mail settings. Click on the account you just created. Scroll down to SMTL and click on it. Choose on the AT&T SMTP Server. Save and then exit. Your email should pop up right away....Mine did without having to add any specific ports or non SSL settings.

    I hope this works for all of you as well!!!!! If so, please pass this info along, as many people are experiencing similar problems.
  • 21. Re: Go Daddy & iPhone
    sclemente Level 1 Level 1 (0 points)
    I tried all of the other options and this is the only one that allows me to now send mail. So frustrating. I have spent hours on this. Thanks for the post.
  • 22. Re: Go Daddy & iPhone
    jessicaMjordan Level 1 Level 1 (0 points)
    Thanks so much! This problem has been bugging me for weeks! My account is working perfectly now and I hope it stays that way!
  • 23. Re: Go Daddy & iPhone
    gmillerx Level 1 Level 1 (0 points)
    Same problems, but my solution was simple. (Iphone3g, ATT carrier, itunes sync from PC, godaddy email, not using wifi). The first-sync settings worked for read, but i kept getting the 'one of the "one of the recipient addresses was invalid" message no matter what i tried. [Note; this message applies if you used iTunes to bring godaddy email accounts over from your PC/MAC... it would be more detailed if you set it up from scratch).

    Solution was easy:
    1.Home
    2. Settings
    3. Mail, Contacts, Calendars
    4. (select account)
    5. flick down to SMTP (under 'Outgoing Mail Server") and tap it
    6. tap the name under "Primary Server" (should be 'smtpout.secureserver.net' for Godaddy)
    7. put the correct username (emailaddress for uname) and your password into the slots (they had been left blank--like ALL the syncd up passwords--during the sync).
    8. [double check that the iTunes sync had placed the 3535 into the Server port number)

    that's all-- it was (in the case of MY error "one of the recipients..." ) just that my usernames and passwords had not all come accross from iTunes).

    i have NOT tried this with WIFI through my local ISP yet, but it works fine on the EDGE network i am in from ATT.
  • 24. Re: Go Daddy & iPhone
    Marc Blitstein Level 1 Level 1 (0 points)
    Thank god for the discussion board! My iphone was KILLING me by not sending from my GD email account. using the AT&T server did the trick.

    Now...is anyone out there experiencing the same or similar issues using mac mail from your home computer?
1 2 Previous Next