1 2 3 Previous Next 145 Replies Latest reply: Apr 30, 2010 6:26 AM by oliau
Acmee Level 1 Level 1 (0 points)
I have just received my Mini Displayport to Dual Link DVI Adapter. The good: After I cancelled my initial order, because it delayed my notebook, I reordered last week and got it within 5 days or so (despite the store displaying 2-3 weeks). I was positively surprised to see it featuring a USB repeater. I plugged it in and it seemed to work instantly I also encountered no jumpy mouse whatsoever. I tried with a Dell 30" screen (3007WFP).

The Bad: The dvi connector is pretty bad and unstable, you can also not use the screws on the dvi cable to the monitor to fix the plug to the adapter. They also didn't recreate the analog video signals on the dvi connector, so no luck in trying to use the adapter with an old dvi to vga adapter (I was sort of expecting that, but given they have all kinds of circuitry in the box anyway, there was a tiny quantum of hope).

The Ugly: A few minutes later the problem surfaced: The picture became somehow distorted, it looks as if the Dual Link connection is losing a link, meaning that every second pixel or so is missing on screen. But the symptoms can also include shadows etc. I tried a few things:

* Cycling the monitor power has no effect
* It makes no difference if the adapter gets power via the Macbook Pro USB ports, a powered hub, a usb ac adapter etc.
* It makes no difference if there is something plugged into the adapter USB repeater or not.
* The problem seems to be occuring later if the main display is folded down and only the 30" screen is connected
* Re-plugging the connection DVI side fixes the problems sometimes.
* Re-plugging the Mini Displayport side connection either fixes the problem, or kills the connection forever, requiring complete adapter removal and redetection of the main display (sleep, function key etc.).

Over time, the problem surfaces 100%, typically after a few minutes. Funny enough, sometimes it vanishes by itself.

Does anyone have a similar problem? Or is my adapter defective? Any suggestions towards a fix? Any help is appreciated. I am cursing the day someone decided to replace the old dvi connector.

Regards,
TB

Macbook Pro, Mac OS X (10.5.6)
  • 1. Re: Mini Displayport to Dual-Link DVI not working?
    krypttic Level 2 Level 2 (465 points)
    Acmee,

    I sometimes have screen distortion on my 30" Cinema Displays (one at work and one at home) requiring me to unplug the DVI cable and then plug it back in (sometimes a few times).

    Regarding your mouse cursor: Have you tried slowly moving it in a circle at a consistent rate to see if it "jumps" after a few seconds? Also, do you have the repeating entries in system.log? See this thread for reference: http://discussions.apple.com/thread.jspa?threadID=1830794&tstart=0
  • 2. Re: Mini Displayport to Dual-Link DVI not working?
    Acmee Level 1 Level 1 (0 points)
    If this (the distortion problem) happens with your Cinema Displays as well, it is probably not my adapter - I guess I will give it some time to see if there will be a software fix.
    Regarding the mouse cursor: I have tried moving it in circles and there was no visible effect / delay. That part of it seems to work.
  • 3. Re: Mini Displayport to Dual-Link DVI not working?
    Sluue Level 1 Level 1 (5 points)
    Ive got a Dell 30" connected to this new adapter.

    Every hour or so (sometimes more frequently) the screen distorts.

    Power cyclign the monitor does not fix.

    Unplugging the USB cable from the adapter to the usb port on the computer waiting for the machien to think there is no second display, then plugging the usb cable back in seems to reset the adapter and the display then looks normal.

    Ugh. looking forward to a long call with apple support tomorrow.

    Wonder if the delay in shippping was them not getting this doohickey working right most of the time.
  • 4. Re: Mini Displayport to Dual-Link DVI not working?
    joet3ch Level 1 Level 1 (0 points)
    I am having the exact same issues with this adapter and my Dell 30" display. Very frustrating trying to get anyone from Apple support to understand and/or accept this issue. Hoping for a software fix!!
  • 5. Re: Mini Displayport to Dual-Link DVI not working?
    Acmee Level 1 Level 1 (0 points)
    The one thing that manifests itself to at least get the screen usable for me is this:

    While running the MBP in High Performance mode(!) and NOT in clamshell mode, meaning with the Internal Display folded up (and obviously not in Mirror mode) running as main screen, as soon as the distortion strikes the first time (which in my case is a few minutes max) reconnect the Mini Displayport plug. If the Adapter crashes (no spicture on external display) you also need to reconnect the USB plug and most likely try again. Once the screen is back up, the screen will remain stable from now on...

    The next Apple adapter shipped will probably require small animals to be sacrificed at full moon in order to work...
  • 6. Re: Mini Displayport to Dual-Link DVI not working?
    Linda Custer Level 2 Level 2 (315 points)
    Count me among those with this problem.

    My setup: MacBook Pro Late 2008 (CTO 2.8/320@7200), AMDPTDLDVIA (with both MDP and USB connectors plugged into the MBP), connected to Belkin PureAV DualLink DVI cable, connected to Dell 3007 wide-screen display. The Belkin cable and Dell display worked flawlessly for the whole almost-three years that I had it attached to an early-2006 MBP (Intel Core2 Duo 2.0).

    I have checked that all connections are tight, and have no other USB items plugged in anywhere.

    As described by others, the Dell display will work fine for a while but then will suddenly drop half its pixels, leaving everything looking fuzzy and strange.

    I'm on the line with AppleCare now, and they are speaking with engineering about what to do next I've been clear that I am patient, but I do not want another faulty unit shipped.

    I'm guessing this was the reason for the long delay on this adapter box. Mini display port sounds good, but apparently is not as easy to tweak into older standards as one might hope.
  • 7. Re: Mini Displayport to Dual-Link DVI not working?
    Linda Custer Level 2 Level 2 (315 points)
    Called Apple; took about two hours. Spoke with five people and no one knew what the adapter was. They were all picturing the little gizmos Apple threw in the box with some laptops for VGA, etc. None was picturing the large box and connecting cables.

    They know there's a problem, and they're arranging for an exchange, but they have no information on when they may have units to ship that will work.

    This could be a while....
  • 8. Re: Mini Displayport to Dual-Link DVI not working?
    programr Level 1 Level 1 (5 points)
    Cross posted to the other similar thread:
    http://discussions.apple.com/thread.jspa?messageID=8713836#8713836

    Another data point. I'm having the same issues:
    1) Heat does not seem to be related. A cold machine is just a likely for me to get the 'Fuzz of Death' as I'm now calling it.
    2) The mouse jitteriness does not occur in parallel with the 'Fuzz of Death'
    3) The mouse, even when not jittery, is FAR less responsive than with just the built-in LCD in use (Dual Link DVI unplugged)
    4) I have a Dell 30" Model 3007WP
  • 9. Re: Mini Displayport to Dual-Link DVI not working?
    jim edwards Level 1 Level 1 (0 points)
    in spite of having a complex set-up, the Mini Displayport to Dual Link DVI is working fine for me.

    I am using a MBAir, a Dr Bott 4 port Dual-link KVM, and the Apple USB ethernet adapter. I did have to try two USB hubs, but a Targus non-powered 4 port hub did the trick. I have plugged the hub into the laptop, the USB ethernet adapter, the Dual-link USB male plug, and the KVM USB male plug into the hub, and then the DVI-DL cable only into the adapter "box"
  • 10. Re: Mini Displayport to Dual-Link DVI not working?
    Acmee Level 1 Level 1 (0 points)
    Maybe Macbook Airs do not show the problem. I have read a couple of messages by MBAir Users who have no difficulties.

    A couple of new findings:

    This will indeed happen much less if the USB port further away from the Mini Displayport is used to power the Dual Link Kit and if there is no load on the other USB port (using Bluetooth equipment) nor the Adapter USB repeater.
    In case of the Dell 3007 screen, using one of the internal hubs USB ports to power the Dual Link Adapter does work and will reduce the frequency of this happening as well - using an Iphone Charger instead showed no improvement.
    In both configurations a single sleep/wake cycle after the first occurrence of the distortion brings me a few hours of stable screen. At least now I can survive until a final solution for the problem is presented, hence I will mark the question as answered.
  • 11. Re: Mini Displayport to Dual-Link DVI not working?
    jim edwards Level 1 Level 1 (0 points)
    I seem to have spoken to early - I noticed a few times yesterday when switching back to the Mac the "fuzzy" screen others have noted

    A sleep/wake cycle restores normal function
  • 12. Re: Mini Displayport to Dual-Link DVI not working?
    Linda Custer Level 2 Level 2 (315 points)
    Interesting observation.

    It was my belief -- before your post -- that the AMDPDLDVIA only drew power from the USB, so as long as there was sufficient power, the actual video signal should go over the MDP without being affected by what was going on in the USB part of the cable.

    So --

    -- the USB is doing some signalling, or

    -- the AMDPDLDVIA is WAY TOO sensitive to power changes in the USB hub, or

    -- the graphics circuit (NVIDIA chip and MDP circuit are sensitive to what's going on in the USB hub.

    Anyone care to comment? Is there a fourth possibility I'm missing?

    My AMDPDLDVIA went back to Apple yesterday. We'll see if the item they send in exchange behaves any differently.
  • 13. Re: Mini Displayport to Dual-Link DVI not working?
    natethelen Level 1 Level 1 (0 points)
    Same is happening with me. Same monitor. Maybe it is an incompatibility with this specific Dell monitor? Unplugging both plugs from laptop, waiting a sufficient amount of time, then plugging back in eventually works to fix the problem
  • 14. Re: Mini Displayport to Dual-Link DVI not working?
    tsumuji Level 1 Level 1 (0 points)
    I am having the same problems (sort of). I use a Dell 30 " monitor which was fine with my last one year old MBP. With the new MBP and the new mini dual link DVI I sometimes cannot read any characters anywhere on the screen.The look like double print or half grey. This happens. I restart and it works for a while and then suddenly returns.
    Restart seems to work. But only for a little while.
    I have zapped the pram. Have all the new updates and firmware. I have no idea what to do as it seems erratic. In the reviews of the adaptor I see that it happens on several makers monitors not just Dell.
1 2 3 Previous Next