Skip navigation

MacBook Pro screen blinks

354493 Views 1,620 Replies Latest reply: Mar 18, 2014 11:48 PM by accessd RSS Branched to a new discussion.
  • steinzeug Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 4, 2008 10:58 PM (in response to PHOTOlink.net)
    This problem really needs to be adressed by apple.
    Macbook Pro (late 2008 unibody), Mac OS X (10.5.5)
  • kurt@kurtarrigo.com Calculating status...
    Currently Being Moderated
    Dec 5, 2008 6:33 AM (in response to munchnstuf)
    Yeah I am also experiencing the same flickering problem.... This is extremely frustrating !!!
    Apple, please can you sort this one out .... !!!
    MacBook Pro W88411S21GA, Mac OS X (10.5.5), other Mac laptops
  • andrew Bobyn Calculating status...
    Currently Being Moderated
    Dec 5, 2008 10:11 AM (in response to munchnstuf)
    I too am getting a blinking screen, while using the GeForce 9400M unit. So far it seems to come up every couple of days.

    More problematic is that sometimes when waking from sleep with a larger monitor plugged in - the larger monitor frequently doesn't come on until I remove & re-plug in the MiniDisplay port adapter to sort of wake the card up. Sometimes the larger just turns off and on again numerous times until I remove & re-plug the adapter in. That seems to help.

    My (replaced) powerbook never had this problem.
    Macbook Pro 2.4 (late 08), Mac OS X (10.5.5)
  • Robert Derelanko Calculating status...
    Currently Being Moderated
    Dec 20, 2008 6:29 AM (in response to PHOTOlink.net)
    I also had this problem only on the 9400 chip.. Although mine is very rare.. maybe once a day or two.

    Haven't used the 9400 much since my last logic board replacement so I can't comment if the newer chips are doing it as well.
    Late 2008 Macbook Pro 2.53, Mac OS X (10.5.5)
  • sammiemo Calculating status...
    Currently Being Moderated
    Dec 21, 2008 7:14 PM (in response to munchnstuf)
    It sounds like I had the same problem. Called Apple Support and sent it in for repair. A couple days later I got it back. I think this is a production issue with some of the NVIDIA chipsets.
    Late 2008 MBP, Mac OS X (10.5.6)
  • Raphael Brand Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2008 1:35 AM (in response to PHOTOlink.net)
    My Mac Book Pro, 2.8 Intel Core Duo, also blinks, that is the screen, when using the slower graphic processor flashes really quickly, maybe every 10 minutes orso.
    i have tried playing around with different display settings like one site suggested but that didnt do anything, also resetting PRAM (option plus p and r, restarts) , i have not tried yet.
    i also noticed that sometimes when it has a few programs open and i worked on Aperture, something a computer with this speed should handle easily!! the computer frooze and the hd started to sping fast and faster, and the cpu got really hot till i just had to restart with power button.
    I love the machine but something isnt quite working the way it should....
    r
    Mac Book Pro, 2.8 Intel Core Duo, Mac OS X (10.5.6)
  • Raphael Brand Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2008 5:26 AM (in response to munchnstuf)
    after running the mac for a longer a period of time the flashes/blinks start to happen with shorter intervals, cannot put a timer on it but now it seems to happen every 4 minutes...its a bit frustrating and i hope Apple will come with an explanation on this site soon,
    r
    Mac Book Pro, 2.8 Intel Core Duo, Mac OS X (10.5.6)
  • marco21 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2008 5:45 PM (in response to Raphael Brand)
    I've extact the same problem with my late 2008 MBP. Sometimes, the upper area auf die display flashes for a millisecond a black bar. And sometimes, the entire display flashes black for a millisecond. It's absolute randomly.
    All these issues happens, when the 9400M is activated.


    I hope, it's a software-issue.....,but did the late08 Macbook's have the same 9400M-display-issue??

    Here is a pic of my OS X-desktop, when the black bar appears (it's photoshoped, because i can't know, when the next "blankbar" appears, to make a photo or video with my digicam:
    http://img201.imageshack.us/img201/4922/bild1vm1.jpg

    Message was edited by: marco21
    MBP 2,5GHz ALU, Mac OS X (10.5.6), 4GB of RAM, 320GB HDD, 512MB 9400m and 9600M GT
  • jsqhoward Calculating status...
    Currently Being Moderated
    Dec 31, 2008 12:45 AM (in response to munchnstuf)
    My new MBP (late 2008) also blinks intermittently when using the 9400 chip. Every minute or so. I contacted Apple and he took me through a bunch of stuff, but the problem is still there. I would hate to have to send the laptop back since I am overseas, and hope that this is a software problem that can be fixed through an update. Anyone know if a solution is on its way?
    Macbook Pro, Mac OS X (10.5.6), 2.4ghz 15.4
  • Christmas Eve Calculating status...
    Currently Being Moderated
    Dec 31, 2008 5:34 PM (in response to munchnstuf)
    You can add me to the list of random quick screen flashes. This only happens when using the 9400M graphics. Not sure what's causing the problem but I hope it's a software issue and not a hardware one. Fingers crossed...
    Macbook Pro - 2.53 GHz (Late 2008), Mac OS X (10.5.6)
  • pierocampanelli Calculating status...
    Currently Being Moderated
    Jan 1, 2009 2:48 PM (in response to munchnstuf)
    I am experiencing the same problem not only when scrolling:

    Randomly top section of LCD flicker for 1/20 second
    Sometimes it happens every 5 minutes. Sometimes every 50 minutes. Sometimes never happens
    It happens only with 9400 chipset at whatever level of brightness I put and with auto brightness enabled or disabled
    It seems to happen more frequently after a wakeup and with an external monitor connected through DVI cable
    It is terribly annoying !!

    I went to the local apple store (where i bought the computer) to obtain a DOA (Defect on Arrival) but the problem didn't happen ....

    What can I do?
    Did you find a method to reproduce it to demonstrate the problem?
    Macbook PRO Late 2008, Mac OS X (10.5.6)
  • marco21 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 2, 2009 6:53 AM (in response to pierocampanelli)
    I've noticed, when a video on Youtube is playing, the flicker appears sometimes often.
    I think it's a software issue on the relativ neu 9400m chipset-graphic. It's new to Apple.
    iMac C2D, Mac OS X (10.5.4)
  • pierocampanelli Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 2, 2009 11:16 AM (in response to marco21)
    I did the following experiment. I logged in after a wakeup. I put dim to low level and I observed the screen for 20 minutes doing nothing. Fault happened 3 / 4 times. It is a very fast blink on the upper section of the LCD.

    I confirm that it seems to happen only with 9400 chipset and it happens on a cold start (so I exclude heating problems).

    I think is an hardware issue with the combination LCD revision / chipset revision.

    Here is my hardware version:

    Chipset Model: NVIDIA GeForce 9400M
    Type: Display
    Bus: PCI
    VRAM (Total): 256 MB
    Vendor: NVIDIA (0x10de)
    Device ID: 0x0863
    Revision ID: 0x00b1
    ROM Revision: 3343
    gMux Version: 1.7.3
    Macbook PRO Late 2008, Mac OS X (10.5.6)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (27)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.