Skip navigation
This discussion is archived

internet sharing glitch - any ideas?

2000 Views 4 Replies Latest reply: Jan 5, 2009 2:58 PM by BDAqua RSS
drankf Calculating status...
Currently Being Moderated
Jan 4, 2009 7:20 PM
Basically: I am using an old iMac FP 800 as a file server and wireless router (through the airport card, i.e., as a "software base station.") The iMac is connected to a cable modem via ethernet, and shares its internet connection with a powerbook g4 and and an intel macbook through its airport card.

It has always worked great under 10.3.9. Under 10.4, however, internet functionality drops out at random points. That is the iMac stays connected but other computers sharing its internet connection just get "bumped off." They are connected to the airport network, but the internet is non-functional for those machines. My macbook will be connected, and then the connection will suddenly drop, like it is timed out or something. Sometimes, toggling the firewall on the iMac off and on will restore internet sharing. Sometimes it is necessary to turn internet sharing off, then on again. Once the connection is restored, keeping the iMac's firewall off seems to prevent the dropout but if I turn it on again, the drop out inevitably occurs within the hour.

I gather from this that it is an issue with the firewall. Short of just leaving the firewall switched off, can anybody suggest anything I can do to prevent this problem? It is very annoying.

(I posted about this problem previously and I never managed to resolve it: http://discussions.apple.com/thread.jspa?threadID=1661730&start=0&tstart=0

At the time, the only reason I needed to use 10.4 was to synch up an iPod -- of the generation that won't work with any 10.3 computers -- thanks Apple.) I would just boot into 10.4 to synch the iPod, then back into 10.3 for everything else.

Now, however, the disk from which I was running 10.3.9 has failed, and I'd prefer to get 10.4's internet sharing to function if possible so I can just use that rather than trying to re-install 10.3.9 solely for the internet sharing functionality.)

It seems to me it should be possible to make this work. There must be something I'm missing. Any ideas?
macbook, Mac OS X (10.4.11)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.