Skip navigation
This discussion is archived

Leopard still won't auto sleep!

3905 Views 17 Replies Latest reply: Jan 11, 2009 10:57 AM by bruegge RSS
1 2 Previous Next
scheckler21 Calculating status...
Currently Being Moderated
Jun 5, 2008 4:52 PM
Alrighty,

First, I have a 2.0ghz CD Macbook with 1GB RAM. I recently did an erase and install update to Leopard. Since then, I have not been able to get the computer to put itself to sleep. I can manually tell it to sleep or shut the lid and that works, but it won't auto sleep.

I have tried:
-deleting all HP files
-Resetting SMC
-Disc utility stuff

Nothing has fixed the problem so far.

Here is the weird part:

If I restart the computer with the ethernet cable unplugged, the computer will sleep fine. If, at any time, I plug in the ethernet cable, the computer will not sleep...even if I then unplug the ethernet cable. I really don't feel like making a launch daemon to solve the problem and I don't feel like downloading third party software to fix the problem.

Basically I'm just afraid that the hard drive is getting unnecessary wear and my battery life is terrible if the laptop is left open and not charging. I'd be perfectly happy to hear that this is an OS problem and will be fixed next update.

Please help! Thanks!
Macbook, Mac OS X (10.5.3)
  • Michael Kay Calculating status...
    Currently Being Moderated
    Jun 6, 2008 9:40 AM (in response to scheckler21)
    I have had a problem with auto sleep, which stopped working under 10.5.2. The computer will manually sleep whenever I want it to, but it won't auto sleep at all.

    I was expecting the 10.5.3 update to fix this (it is fairly evidently a problem affecting several users from the various forums which mention it), but it hasn't.

    Can anyone help please?
    iMac 24" 2.8 GHz, 2GB RAM, 750 GB HDD, Mac OS X (10.5.3), Apple Wireless Mighty Mouse and Wired Aluminium Keyboard
  • Todd in Savannah Calculating status...
    Currently Being Moderated
    Jun 6, 2008 7:17 PM (in response to Michael Kay)
    Having the same problem. Just happened since 5.2. 5.3 did not fix it.
    Macbook Pro, Mac OS X (10.5.1)
  • George Coghill Level 2 Level 2 (475 points)
    Currently Being Moderated
    Jun 12, 2008 11:16 PM (in response to Michael Kay)
    No auto-sleep here (other sleep methods working fine). 10.5.3 has been running on the MacBook (and the MacPro, also experiencing the no auto-sleep issue) since purchasing.

    With both of my machines having the same problem, it's either some software I am running on both, or OS X itself. Find it hard to believe I bought two computers with hardware issues that are exactly the same on two different types of machines. Other than sleep issues, both seem to be working great.
    MacPro Dual-Quad 2.8, MacBook 2.1, Mac OS X (10.5.3), Dual Monitors : Wacom Intuos3 Tablet
  • Dave Z Level 1 Level 1 (60 points)
    Currently Being Moderated
    Jun 12, 2008 11:29 PM (in response to George Coghill)
    Ditto here. No auto sleep.

    I think my issue started when I switched from Apple wireless Mighty Mouse to a M$ bluetooth mouse.
    MacBook Pro, 2.16GHz, 3GB RAM, Mac OS X (10.5.3), 8GB iPhone, 40GB Apple TV, 30GB iPod w/Video, 2GB iPod Nano
  • George Coghill Level 2 Level 2 (475 points)
    Currently Being Moderated
    Jun 13, 2008 12:19 AM (in response to Dave Z)
    I'm all Apple here, wired mouse. And the MacBook shows the same issues with no peripherals attached.
    MacPro Dual-Quad 2.8, MacBook 2.1, Mac OS X (10.5.3), Dual Monitors : Wacom Intuos3 Tablet
  • Thierry de Villeneuve Level 1 Level 1 (115 points)
    Currently Being Moderated
    Jun 13, 2008 1:11 AM (in response to scheckler21)
    It's both situations with my MBP. Sometimes goes in auto-sleep (set to 1.5h on Power) when I leave my desk for a long period. But last night, I started the "publish" new thingy of Delicious Library 2 and went to bed. On the morning, the MBP was still up.

    I guess there are some applications that keep "on" some functions that make the auto-sleep feature believe the Mac requires to stay up and thus cancels auto-sleep. I don't know the specs for this part. Someone here can get you with additional details if required.


    --> Anyways, to the attention of 'scheckler': Don't be afraid letting your Mac on all the time. It's a machine, not a hurdles runner.

    A machine, like a hard-drive, is getting more wear by the warm-cool-warm cycles than staying up and warm all day long. The HD protects itself, by parking during long periods of inctivity.

    Your Mac won't get super-hot during the night because nearly nothing happens besides the daily cron'ed jobs (launchd now).

    I personally put my MBP to sleep only to carry it around. My other non-portable machines are up 24/7 (and on UPS).

    Rgds,
    Thierry
    MacBook Pro 15" 2.6GHz Merom 4Gb 250Gb, Mac OS X (10.5.3), 14h/day in front of a Mac, and still having a life
  • Chetpot Calculating status...
    Currently Being Moderated
    Jun 13, 2008 12:12 PM (in response to scheckler21)
    Has anyone had any issues with the sleep function when the power adapter is not plugged in? Since I upgraded to Leopard when ever my macbook is on battery power after about 30 min or at around 50-60% power the macbook abruptly shuts off as if it was a desktop having the power cable unplugged. Prior to leopard the macbook would just automatically put it's self to sleep at about 5% power.
    Macbook, Mac OS X (10.5.3)
  • George Coghill Level 2 Level 2 (475 points)
    Currently Being Moderated
    Jun 13, 2008 1:13 PM (in response to Chetpot)
    I had a similar issue with my original MacBook. Have you tried conditioning the battery? Not sure about exact steps, but I believe you let it run down on battery, then charge to full capacity and then some for a set amount of time.

    I ended up getting a replacement battery from Apple under warranty though. Problem went away after that.
    MacPro Dual-Quad 2.8, MacBook 2.1, Mac OS X (10.5.3), Dual Monitors : Wacom Intuos3 Tablet
  • George Coghill Level 2 Level 2 (475 points)
    Currently Being Moderated
    Jun 21, 2008 5:33 PM (in response to scheckler21)
    I have discovered that the outgoing network activity monitoring utility Little Snitch was the cause of my problems. Once I disabled it, the MacBook went to sleep normally under Energy Saver settings.

    I dropped a line to the developer on this, but have yet to hear back.
    MacPro Dual-Quad 2.8, MacBook 2.1, Mac OS X (10.5.3), Dual Monitors : Wacom Intuos3 Tablet
  • George Coghill Level 2 Level 2 (475 points)
    MacPro Dual-Quad 2.8, MacBook 2.1, Mac OS X (10.5.3), Dual Monitors : Wacom Intuos3 Tablet
  • pujo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 22, 2008 2:10 AM (in response to Todd in Savannah)
    I have the exact problem.
    no auto sleep
    macbook pro MB 133ZP/A, Mac OS X (10.5.5), Bootcamp 2.0
  • Michael Zischeck1 Level 1 Level 1 (55 points)
    Currently Being Moderated
    Oct 22, 2008 10:06 PM (in response to scheckler21)
    check if the firewall logging is enabled, it was on mine, now, turned off the firewall logging, my machine sleeps like a baby
    iMac Flatscreen, Mac OS X (10.4.4)
  • bruegge Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 6, 2009 2:19 PM (in response to Michael Zischeck1)
    I just want to warm this thread up again.

    During my iMac & Leopard career I randomly recognized various auto sleep problems.
    With start of 2009 the problems begin to get bigger. The auto sleep mode only works very randomly now.

    I already looked for disturbing processes, reinstalled the 10.5.6 Combo Update, checked the console messages. But still I have no real solution.

    As many other users I am also able to start the sleep mode manulally but the auto sleep mode seems to be not very reproducable.
    iMac 24" (early 2007), MBP (early 2008), Mac OS X (10.5.6)
  • mactechconsulting Level 4 Level 4 (2,775 points)
    Currently Being Moderated
    Jan 7, 2009 7:31 AM (in response to bruegge)
    Solution: *Reinstall OSX on cleaned and initialized disk (or use another disk that is Vanilla install)* must be a clean Install.

    Unhook all USB Firewire except for Keyboard Mouse.

    Sleep should work fine. Start adding back your extras when you Loose sleep you have found the culprit. I stay Vanilla as much as possible . I found I could not install Office 2008 or I would loose sleep! YMMV.

    But I have prefect auto- sleep after all that heartache. Best to you!
    2GhzG5, Logitec5.1, Bluetooth, 9800XT, iPod, Mac OS X (10.5.2), iSight, FW Drives, PowerMate
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.