Skip navigation
This discussion is archived

iBook G3 won't connect through WPA

14451 Views 10 Replies Latest reply: Jul 7, 2010 4:56 PM by M1CH43L RSS
M1CH43L Level 1 Level 1 (5 points)
Currently Being Moderated
Dec 30, 2008 10:41 AM
I have an old blue iBook G3 with an airport card that I use for surfing when I don't want to be tethered to my desktop computer. I recently replaced my Netgear router (that was dropping connections like crazy) with a fancy new Linksys WRT54G2. However, I'm having nothing but problems getting my laptop to connect to it. It works just fine if I make it an open network or if I use WEP. However, if I set it to WPA Personal, it doesn't. That's the protocol I prefer, since it's more secure and the password is easier to remember. I was using it before with the Netgear router, so I don't know why it wouldn't work with the newer router. Suggestions?

BTW: the iBook is running 10.4.11
PowerMac G4 MDD Dual 1GHz, Mac OS X (10.5.6)
  • BDAqua Level 10 Level 10 (114,825 points)
    Currently Being Moderated
    Dec 30, 2008 2:03 PM (in response to M1CH43L)
    Hi M1CH43L, and a warm welcome to the forums!

    Could the new Router be using WPA2?

    The original AP cad only supports WPA on some Routers, but not WPA2...
  • BDAqua Level 10 Level 10 (114,825 points)
    Currently Being Moderated
    Dec 30, 2008 4:23 PM (in response to M1CH43L)
    Try opening Internet Connect click on the 802.1x icon, try setting it up that way.

    Do you know what Authentication protocol it uses?
  • BDAqua Level 10 Level 10 (114,825 points)
    Currently Being Moderated
    Dec 31, 2008 2:11 PM (in response to M1CH43L)

    The original Apple AirPort Card can be updated with firmware and drivers to handle TKIP; Mac OS X 10.3 Panther or later is required, however.

    Though this thread seems to indcate "g" mode is required with Linksys!?
  • Matt Broughton Level 5 Level 5 (4,905 points)
    Currently Being Moderated
    Jan 14, 2009 6:51 PM (in response to M1CH43L)
    M1CH43L wrote:
    In the meantime, I thought that I would look to see if there's a standalone update for the original airport card, but Apple sure hasn't made it easy to find downloads on their site. It seems that all I can do is run a search and it's not turning up anything past the Airport update for OS X 10.3. There also doesn't seem to be any mention of TKIP in the entirety of their knowledgeable. Boo.

    I found this thread while trying to set up a recently acquired iBook G3/500 (Dual USB) with a plain old AirPort card. I have an older Linksys WRT54G wireless router. Using OS X 10.4.11 with Airport Software 4.2.9 or OS X 10.3.9 with Airport Software 4.2.1, I was able to connect with Personal WPA TKIP without much difficulty.

    Don't get hung up on seeing TKIP as a choice under the Internet Connect section. I didn't see it listed on my Mac Mini G4 with OS X 10.4.11 and an Airport Extreme card. I also didn't see Personal WPA2 AES on that machine, but it worked. So Personal WPA TKIP does work in the "b" mode at least with my Linksys router.

    I hope this helps a bit in figuring out your situation.
    Mac Mini G4 and Intel C2D; B&W G3
  • ovidiub Calculating status...
    Currently Being Moderated
    Feb 6, 2009 9:54 AM (in response to M1CH43L)
    Hi guys,

    I have the same issue: older iBook G3 800Mhz (OS X 10.4.11) cannot connect using WPA/WPA2 password to Linksys WRT54GL router using DD-WRT firmware ( The airport was forcing the WEP password requirement though in System Preferences->Network->Airport it's allowed to add WPA/WPA2 password.
    The solution:
    1) in Wireless Basic Settings use:
    Wireless Mode: AP
    Wireless Network Mode: Mixed *
    Sensitivite Range (ACK timming): 0 *

    2) in Wireless Security:
    Security Mode: WPA2 Personal Mixed *
    WPA Algorithms: TKIP + AES

    * - required to get older Airport card connecting to WRT54GL

    I hope it helps.

    iBook, Mac OS X (10.4.11), G3 800Mhz, 640Mb, 80Gb, CD, 12"
  • BDAqua Level 10 Level 10 (114,825 points)
    Currently Being Moderated
    Feb 6, 2009 11:58 AM (in response to ovidiub)
    Hi Ovidiu, and a warm welcome to the forums!

    Great 1st post & tip, thank you!


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.