Skip navigation
This discussion is archived

Endless disconnecting of Bluetooth mobile phone data connection

19560 Views 43 Replies Latest reply: Jul 14, 2009 12:37 AM by pierocampanelli RSS
  • krp1 Calculating status...
    Me too. MacBook Pro, 10.5.6 and Nokia E71.

    Neither Bluetooth nor USB modem seem to work work. I only see the endless disconnecting message (kill -9 does not work either, I must reboot to reset the pppd)...

    With 10.4 it was not this bad: the USB modem worked without problems and the Bluetooth modem connected at least occasionally.

    It seems that the only way I can get my phone to act as an modem with 10.5.6 is to use the JoikuSpot software (which costs 15 euros ).

    This is frustrating - I should not need to by extra software to compensate for buggy Apple/Nokia software...
    MacBook Pro, Mac OS X (10.5.6)
  • awishneusky Calculating status...
    Apple, you seriously need to fix this. Processes that can't be killed is SO Macos 8 :P
    Al Powerbook G4, Mac OS X (10.5.6)
  • MonacoRob Calculating status...
    Hi,

    I see this problem is never going to get fixed. It happened occasionally with 10.4 but with 10.5.6 it really is a joke. I get about 2 mins before the endless disconnecting scroll starts. I'm using an Ericcson P1, but this isn't the fault - its in the mac.

    I'm going to go to the Genius Bar at the Mac centre and make them sort it.

    You really would expect better from Mac.... I might have to downgrade to Windows if this persists.
    MacBook Pro 2.8 GHz, Mac OS X (10.5.6), 4GB DDR3
  • secondthinks Calculating status...
    this situation does completely suck.

    it is undoubtedly ridiculous that you can't kill the process. isn't it as ridiculous that it doesn't connect in the first place?

    a $200 nokia internet tablet has a wizard that walks you thru tethering to your phone that works flawlessly from that point on. you can even configure it to autoswitch to wlans when they are available. on the nokia n800, this has worked without incident with every nokia phone i have tried it with.

    why is this so difficult? i read thru this thread and did some other searches but could not find an official apple response. has there been one?
    backlit aluminum macbook, Mac OS X (10.5.6)
  • John Collaros Calculating status...
    Hi everyone! I have a solution!

    I have felt the same pain. It seemed rediculous to me that this problem requires a reboot. I have tried killing processes and using gdb or dtrace/dtruss, but had no sucess with these methods.

    My background is Linux, and so I was finally thinking, why can't I remove the bluetooth module!

    Here is what I did:

    Saturn:~ root# kextunload -v 6 -p -b com.apple.iokit.IOBluetoothSerialManager
    kextunload: calculating version relationships
    kextunload: unload id com.apple.iokit.IOBluetoothSerialManager succeeded (any personalities not unloaded)

    Once you have done this, pppd will be able to terminate because this removes the cuBluetooth-Modem device pppd seems to be stuck on. However, now you won't be able to reconnect.

    The devices in /dev (/dev/cu.*) will have disappeared.
    Now do the following:

    Saturn:~ root# service com.apple.blued stop
    Saturn:~ root# service com.apple.blued start
    Saturn:~ root# ls -la /dev/cu.*
    cu.Bluetooth-Modem cu.SerialPort-2 cu.SerialPort-7
    cu.Bluetooth-PDA-Sync cu.SerialPort-3 cu.SerialPort-8
    cu.SerialPort-1 cu.SerialPort-4 cu.SerialPort-9
    cu.SerialPort-10 cu.SerialPort-5
    cu.SerialPort-11 cu.SerialPort-6

    Voila! Now you should be right to connect again.

    This method worked for me today when I had a lockup. I havnt had another lockup to verify this, but from my testing, I have been able to verify the removal of the bluetooth device nodes on module unload and then the recreation on restart of blued service.

    Hope this helps others. Please let me know.

    John
    Macbook Pro 4,1, Mac OS X (10.5.6)
  • Redddis Calculating status...
    can you please arrange it as a standalone application till Apple fixes the problem - it'd be much better than launching terminal and doing all this stuff each time the bluetooth module locks.
    MBP, Mac OS X (10.4.11)
  • charltonkao Calculating status...
    Okay, so I opened up terminal and entered the following:

    sudo tcsh (to get into root)
    <root password>
    kextunload -v 6 -p -b com.apple.iokit.IOBluetoothSerialManager
    ps -ef | grep pppd (to get pid)
    kill -HUP <pid>
    service com.apple.blued stop
    service com.apple.blued start

    Nothing happens. The disconnecting is still scrolling across the top. It also doesn't seem like I have a /dev/cu.* directory. What am I missing?
    Macbook, Mac OS X (10.5.6)
  • dairem Calculating status...
    Hi there,

    Thanks very much for the tip. It didn't quite work for me, as the devices in /dev weren't recreated for me after restarting the blued service, but they were when I rebooted and then the problem didn't reappear. Previously it had been reoccurring, even after reboots. It's still super annoying, but at least this seems to make it go away for a while. Thanks!

    Daire.
    macbookpro2,1, Mac OS X (10.5.6)
  • pochwa Calculating status...
    I am running 10.5.6 and connecting using a Nokia E70.

    It happened to me, and nothing seemed to help (no reboot, no kernel module unloading etc.). After about a month of being grumpy about it I removed my phone from the bluetooth devices and added it again. Success!

    Since then it has happened twice again. Each time I could simply delete the phone pairing and add it again to make it work. I did not have to change any settings or even reboot.
    Unibody Macbook, Mac OS X (10.5.6)
  • javy888 Calculating status...
    OK so I had a blackberry curve 8320 and I used on a daily basis to connect to the internet. Last weekend I had to change it because I had some problems and bought a new phone of the same model. The first day it worked fine, but since yesterday the mac wont connect to the phone. When I click to connect to the phone I get the Connecting message for a couple of seconds, then "Disconnecting" appears and never disappears until I reboot. Its incredibly annoying. I just want to know if the problem is with the new phone or with the mac?
    Macbook Aluminum 13.3", Mac OS X (10.5.6)
  • pochwa Level 1 Level 1 (0 points)
    "Bluetooth Preferences": delete the pairing with the phone by using the minus sign at the bottom
    "Set up bluetooth device": pair with the phone again (dial up networking should be selected)

    Now it should work. I have a friend with a similar setup as mine (unibody macbook, s60 nokia phone) and we have both had this problem. Every time the above recipe has worked.
    Unibody Macbook, Mac OS X (10.5.6)
  • javy888 Level 1 Level 1 (0 points)
    I had trying deleting the pairing and adding it again and it never worked. What I did was pair a friend's phone and use it to connect to the internet (another Blackberry Curve) and it worked!!! When I tried with my own phone AFTER connecting through my friend's phone, it connected!!! What I do notice now is that when it says "Connecting, Authenticating, Disconnecting..." it suddendly moves slower and then it speeds up to its normal speed. This happens everytime and like each 5 seconds.
    Macbook Aluminum 13.3", Mac OS X (10.5.6)
  • Bruno Brunic Level 1 Level 1 (0 points)
    If this is your problem, the solution is to change this default so Leopard doesn't require it from the Bluetooth PPP connection with your phone. You can't make the change in the GUI. But if you are comfortable changing plist files, the solution is to go to /Library » Preferences » SystemConfiguration » preferences.plist, and change the CCPEnabled property for the Bluetooth-Modem device from 1 to 0. Then reboot, and it should work.

    (Taken from source: http://www.macosxhints.com/article.php?story=20080911045249289 )
    Macbook Pro, Mac OS X (10.5.6)
  • pierocampanelli Level 1 Level 1 (0 points)
    It happens me too with 10.5.7 and Nokia E71.

    I can experience the problem regularly as I commute with train and connection is intermittent. Tipycally I have to reboot 2 times per 1h travel.

    I remember that some months ago (probably 10.5.1) it worked regularly without any problem.
    Macbook PRO Late 2008, Mac OS X (10.5.7), E71
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.