1 2 3 Previous Next 82 Replies Latest reply: Jun 6, 2010 1:53 PM by Terence Devlin
tak2mark Level 1 Level 1 (0 points)
I have my iPhoto library stored on an external HD on my iMac.
When running iPhoto on the iMac, I get instant access.
When running iPhoto on the Mac book, it takes minutes!!!!! to start.

This is not ok. Normally, it does take a few extra seconds on the Mac book, but this is ridiculous.

What's the problem. Faces and Place is not worth the ramp up every time the software starts.

20" iMac 2.66GHz duo w4GB & MacBook 2.4 w2GB, Mac OS X (10.5.5), Crash Differently
  • 1. Re: iPhoto Network Library = SLOW SLOW SLOW
    Terence Devlin Level 10 Level 10 (123,875 points)
    How are you connecting the MacBook to the Library?

    Regards

    TD
  • 2. Re: iPhoto Network Library = SLOW SLOW SLOW
    tak2mark Level 1 Level 1 (0 points)
    iPhoto 08 worked well under this config.

    Airport Extreme hardwired to iMac.
    External HD plugged into iMac.
    iPhoto library on external HD.

    So, as you could imagine, iPhoto is super fast on the iMac.

    However, I've timed it now, and it takes 3 minutes for iPhoto to start on the MacBook. There are tasks that I expect to be slow over a network but the program shouldn't take 3 minutes to start.

    Symptoms.
    -iPhoto runs perfectly on iMac with library on external HD.
    -iPhoto starts entirely too slow on MacBook accessing the library via network.
    -Network speed should be OK Mac book with AirPort N and Airport Extreme N.

    The only change to the configuration from yesterday to today is the addition of iPhoto.
  • 3. Re: iPhoto Network Library = SLOW SLOW SLOW
    LarryHN Level 9 Level 9 (56,715 points)
    Wireless access is going to be slower - and much less reliaible - than wired access - in fact it is not recommended to use your iPhoto library over a wireless network - many people have had their library corrupted by glitches and no one I've heard of is happy with the speed

    Plug the MB into the router

    LN
  • 4. Re: iPhoto Network Library = SLOW SLOW SLOW
    tak2mark Level 1 Level 1 (0 points)
    I did say that the only change from yesterday to today is iPhoto 09. I had no complaint about the start time yesterday. Please don't patronize me. I know exactly what to expect from network access.
    Don't worry about my library. It'll be just fine.

    Now, .... back to my concern. It takes 3 MINUTES to start iPhoto.

    Does anyone have anything helpful to say.
  • 5. Re: iPhoto Network Library = SLOW SLOW SLOW
    yournotunique Level 1 Level 1 (0 points)
    I've noticed this, too. I have my Library on an external HDD connected directly to the AEBS and I am seeing incredibly long start times and beachball after long beachball while in the app.
  • 6. Re: iPhoto Network Library = SLOW SLOW SLOW
    Edsel Level 1 Level 1 (0 points)
    After an '09 install the program initiates a search for human faces as part of the new face recognition feature of iPhoto 09. I have 18,000 photos so it took a long while and considerable processor time to churn through my photo library. Additionally, my Time Machine decided to start backing up. At that point I said it was time for bed. My iPhoto library is local but now plan to move it to an external drive.

    Everything was good to go this morning.
  • 7. Re: iPhoto Network Library = SLOW SLOW SLOW
    bradhughes Level 1 Level 1 (0 points)
    This is very bad news, and looks like another bug to add to the big list of bugs I've just posted. I've just ordered a MacBook and waiting for it to arrive. Using it to view the photos on my existing IMac was a big reason for buying it! Let us know if you find a solution.
  • 8. Re: iPhoto Network Library = SLOW SLOW SLOW
    eMacDad Level 1 Level 1 (5 points)
    I have the exact same problem after upgrading to iPhoto '09. My iPhoto Library is stored on a 500G Time Capsule. When I was using iPhoto '08, it will take a few seconds to load now it takes at least two minutes. I've also experienced a crash with iPhoto '09 while it was scanning for faces. Not happy.
  • 9. Re: iPhoto Network Library = SLOW SLOW SLOW
    PaulOBrien Level 1 Level 1 (0 points)
    Same problem here, fine on my main mac, but shared over the network to my macbook it's so slow as to be unusable.

    Very disappointing, as this problem aside i'm very happy with iP'09!

    P
  • 10. Re: iPhoto Network Library = SLOW SLOW SLOW
    tak2mark Level 1 Level 1 (0 points)
    Agreed, ... I am also very happy with iPhoto09. This issue of very slow access to a network library needs to be fixed ASAP. I anxiously await an update.
  • 11. Re: iPhoto Network Library = SLOW SLOW SLOW
    Brian S. Campbell Level 1 Level 1 (75 points)
    I'm having the same issue. it's excruciatingly slow. I'm NOT impressed with this "upgrade". I got it for "Faces" and "Places". "Faces" takes F O R E V E R to scan through everything and if you make the mistake of shutting down iPhoto before it's finished it starts all over from scratch next time you start up. "Places" simply hangs my computer the minute I try to type anything in. I have to force quit iPhoto to get out of it.
  • 12. Re: iPhoto Network Library = SLOW SLOW SLOW
    David Schultze Level 2 Level 2 (245 points)
    I have my iPhoto library on an external air disk and agree that the start times are slow and noticibly from iPhoto 08. Useability is also a little hampered over the network but it was also a little slow in 08 too.

    I haven't experienced the instability that others have reported though.
  • 13. Re: iPhoto Network Library = SLOW SLOW SLOW
    Brian S. Campbell Level 1 Level 1 (75 points)
    make sure Apple knows about it...

    http://www.apple.com/feedback/iphoto.html
  • 14. Re: iPhoto Network Library = SLOW SLOW SLOW
    Old Toad Level 10 Level 10 (115,720 points)
    There is a new iPhoto preference that could be a source of slowdown, the Web preference pane. If you have it set, the default, for automatic and you have MMe galleries it would be constantly checking them. Set it to manual.

    Another possible slowdown is the Sharing pref pane. Make sure you have sharing unchecked. That is usually more evident during launch.

    OT
1 2 3 Previous Next