Skip navigation
This discussion is archived

iWeb 09 ftp publishing error - Test works, publish fails

29452 Views 86 Replies Latest reply: Aug 31, 2009 9:03 PM by Mike Connelly RSS
1 2 3 ... 6 Previous Next
planoBob Calculating status...
Currently Being Moderated
Jan 28, 2009 8:17 PM
When I configure a known working ftp/sftp session, the test works, but the publish step fails. I get one of two errors. The first is that the first connection attempt works fine, but subsequent connections (there are many to publish a site) fail because iWeb neglects to include the password. The other issue occurs when I've aligned the stars (by deleting the keychain entry for the ftp service) and got the passwords entering correctly, but the app trys to to a dir/list operation in an intermediate path on the hosting server (which fails due to authentication issues) instead of the full path that I provide.

I can't see how this ever worked in the QA shop??? Something is amiss with the keychain and/or iWeb. This is the first time I've been let down by Apple s/w ... sigh ...

FYI, this is publishing to www.pair.com (Pair Networks' sites) ...

In a few other semi-related posts, others found relief in switching their hosting server from Windows to Linux, which lends some credibility to the keychain issue since I would expect that the keychain entry would need to change for these cases?

Robert
Mac Pro, Mac OS X (10.5.6)
  • Roddy Level 6 Level 6 (17,255 points)
    Its always been recommended to publish to Linux.
    I tested the FTP and it works OK.
    I won't be using it for a few years until it grows up!
    iMac 24, Mac OS X (10.5.6), 4GB Ram
  • David Brimhall1 Calculating status...
    I've always used iWeb for my web projects. I does for me exactly what I need it to do. I upgraded to the 09 version specifically because of two features:
    1. The ability to Publish via FTP
    2. The ability to Publish only those pages that have been changed.
    ALAS, what to do.
    The FTP Client within iWeb just does not work. I've tried 10 different FTP clients and they ALL connect - iWeb will not. It will place the test page on the site but that's about it. Any suggestions (other than wait until it's fixed)
    iMac G5 20, MacBook Pro, Mac OS X (10.5.6)
  • Sidelight Calculating status...
    so does anyone at all have this working?

    My copy is due to arrive today, the only reason I got it was for the updated iWeb!
    Macbook Pro, Mac OS X (10.5.6)
  • Roddy Level 6 Level 6 (17,255 points)
    I have managed to use this pathetic FTP successfully but others seem to have problems at the server end.
    The ability to publish changed files only is useful and can be used with publishing to a folder and uploading with a "real" FTP application.
    I wouldn't get too excited. I upgraded for the improvements in iPhoto.
    Make sure you backup your domain file(s) before installing the new version.
    iMac 24, Mac OS X (10.5.6), 4GB Ram
  • JazzyGB1 Calculating status...
    Hi,
    iWeb 09 is fab, but the FTP is really poorly implemented & i'd recommend publishing your site to a folder & then manually upload it with an FTP client like Cyberduck or fetch.
    The problem with iWeb is it uploads the folder iWeb publishes to - not just its contents.
    So for example if your web address is www.mydemo.com & you upload it via iWeb your home pasge URL would display something like www.mydemo.com/mysitenfolder/home.html instead of just www.mydemo.com/home.html.
    Very annoying.
    I'm sorry this doesn't help you directly, but combined with your other problems it's perhaps another good reason to avoid using this part of an otherwise excellent application.
    17" MacBook Pro Core 2 Duo, Mac OS X (10.5.6)
  • Tom Gewecke Level 9 Level 9 (70,815 points)
    The problem with iWeb is it uploads the folder iWeb publishes to - not just its contents.


    Actually the folder iWeb "publishes to" is bigger than what you are talking about. iWeb always creates a folder which has the name you gave your site inside iWeb, plus an index.html file outside that folder. It is these two items which are "published to a folder" or uploaded to MobileMe and by iWeb's new ftp feature. Some people do not want the site folder, so they remove it manually to get the browser address bar to look the way they want. Doing this breaks any RSS subscribe buttons you have, however.
    iMac Intel/2C2D, eMac G4/700, Mac OS X (10.5), 10.4, 10.3, 9.2
  • Roddy Level 6 Level 6 (17,255 points)
    Would this not be the reason FTP is not working for some.
    Most servers seem to have a Public folder that you upload your files to - not the whole folder.
    On my server I create my own folder which has the same name as the one produced by iWeb. I can only guess that this is why I can publish with the iWeb FTP.
    I don't intend to use this feature.
    The upside of it is that it will publish only the changed files but, for me, this is negated by the fact that my optimizer - Web Site Maestro - does this for me anyway plus makes my sites download faster and viewable in IE.
    iMac 24, Mac OS X (10.5.6), 4GB Ram
  • Tom Gewecke Level 9 Level 9 (70,815 points)
    Would this not be the reason FTP is not working for some.


    I don't think most servers care what sort of structure you upload to the www or webdocs or html_public folder for your account, as long as you have an index.html there. That's what iWeb produces. I use the ftp feature to upload to a webdocs folder at earthlink with no problem (the directory field is left blank in iWeb).
    iMac Intel/2C2D, eMac G4/700, Mac OS X (10.5), 10.4, 10.3, 9.2
  • Roddy Level 6 Level 6 (17,255 points)
    If I leave the Directory/Path field blank it wants to replace the existing folder.
    If I enter the Directory/Path it only wants to replace the index.html.
    I went for the latter.
    Maybe leaving the Directory/Path empty is the way to go for servers with a Public folder.
    The most noticeable difference in the site published by the iWeb FTP is that the page background color is several shades lighter!
    iMac 24, Mac OS X (10.5.6), 4GB Ram
  • Techover Calculating status...
    Same problem. Test successful. But the upload failed. Whats worse is there is no option to publish to a folder and upload it manually.
    Mac Pro, Mac OS X (10.5.6)
  • Techover Level 1 Level 1 (0 points)
    Correction: publishing to a folder is still possible. All is not lost.
    Mac Pro, Mac OS X (10.5.6)
  • mysterioustraveler Calculating status...
    I'm having the same problem (test works, publish fails) trying to upload a site to a host (dot5hosting) I just signed up with.

    Dot5hosting is completely oriented toward PCs -- no mention of Macs, and all the FTP clients they have instructions for are Mac-only. I'm now, of course, very sorry I chose them but am no doubt stuck with them because I licensed my domain name through them.

    I have the Directory/Path field in iWeb blank. If I were to fill it in, what might I put there?
    iMac, Mac OS X (10.5.6)
1 2 3 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.