Skip navigation
This discussion is archived

iMovie '09 will not run

7089 Views 22 Replies Latest reply: Mar 24, 2009 10:35 AM by JFallon RSS
  • Eric Barbosa Level 1 Level 1 (85 points)
    Currently Being Moderated
    Jan 31, 2009 2:12 PM (in response to Anthony Moore4)
    I had a similar problem. It was events stored on an external hard drive, not in iPhoto, though.

    I am not sure if I solved it yet, but I will respond back if it happens again.
    I deleted the iMovie Cache and iMovie Thumbnail from each event. Note that these caches and thumbnails were made with iMovie '08 and I just upgraded to iMovie '09. This process was taking awhile, so I left my MacBook Pro running while I went to get lunch.

    When I came back it was frozen on an event. I closed iMovie, deleted the thumbnail folder (the cache folder has yet to be recreated) and restarted iMovie.

    iMovie crashed after a few minutes of trying to re-create the thumbnail. I then looked closer at this event and found 2 movies with the Final Cut symbol on them. Note that I do make movies in Final Cut and I mostly use iMovie for 2 things: uploading these Final Cut movies to MobileMe and making photo slideshows. Recently I imported 2 and a half hours of old family vacation DV footage to make simple movies in iMovie.

    Anyways, I pressed space in the finder to QuickLook at these 2 movies and they both had blank video, with a song I remember using to make this movie when I wanted to test out iMovie '08. The song was in the final movie and not in the event, so it was odd that it was in the event folder. I deleted both movies, restarted iMovie and it started working correctly.

    Some in this thread have mentioned testing these iPhoto videos on different accounts and getting different results. I bet it is possible that iMovie creates thumbnails for iPhoto videos, and puts them somewhere in the home folder, possibly in the ~/Movies/iMovie Events folder. I would try and find this folder and delete the Cache and Thumbnail folders, and re-import them into iMovie. If that doesn't work, go through each iPhoto movie in the finder using QuickLook and if you find one that looks corrupt (no audio and/or no video, for example), move them aside.
    MBP 17" 2.33GHz 2GB, iMac Core Duo 17" 1.83GHz 1GB, Mac OS X (10.5.5), iPhone 16GB, iPods: classic 80GB, touch 2G 16GB, shuffle 2G 1GB
  • Hubert Carvallo Calculating status...
    Currently Being Moderated
    Feb 1, 2009 6:21 AM (in response to Prolepse)
    Same problem on my computer with iMovie 8.0 (iLife 09) and the older iMovie 7.0. It hangs on startup on my main account (standard account) and starts normally on my second account (admin account). So far all the solutions I found on forums didn't solve this issue.
    MacBook Pro 15 unibody, Mac OS X (10.5.6)
  • Matt Riggins Calculating status...
    Currently Being Moderated
    Feb 2, 2009 9:16 AM (in response to Anthony Moore4)
    My iMovie 09 (version 8.0) would take 30 minutes to startup. I moved my iMovie Events library folder to my desktop, then it started up ok. I imported 5 gigs of video, and then proceeded to edit the video. iMovie 09 crashes upon clicking in the event library window.

    One post said it might be a corrupted thumbnail in a project. Other said he had Perian installed which I do as well. I've moved the pref pane for Perian to the desktop, am gonna restart and see. Just a couple thoughts.
    Mac Pro First Gen, Mac OS X (10.5.6), 8 gigs of ram, 4 1TB drives. iLife 09 iMovie v8.0
  • iphonejunky Level 3 Level 3 (525 points)
    Currently Being Moderated
    Feb 2, 2009 12:43 PM (in response to Anthony Moore4)
    I'm curious, what version of Perian are you running?
    For that matter what other 3rd Party codecs are you running & version #'s?

    This may help others identify your issue.

    Here's an old but interesting thread:
    http://discussions.apple.com/message.jspa?messageID=7377779#7377779
    PowerBook G4, iMac G5, iMac Intel, Mac OS X (10.5.6)
  • JFallon Calculating status...
    Currently Being Moderated
    Mar 24, 2009 10:35 AM (in response to Anthony Moore4)
    I am having a similar issue, I got a new iMac and opened iMovie for the first time last night. Earlier I transferred my iPhoto library from my old machine which included almost 600 movies in .MOV format. So after iMovie processed the thumbnails for my iPhoto movies, I got the beachball after clicking on a thumb. Several force quits later, no dice, beachball every time (including lengthy delay every time just to load the thumbs). I am able to do anything else, like scroll the thumbs using the scrollbar and click into menus, but as soon as i click a thumb it hangs and the CPU spikes to 100%. Tried all the suggested fixes, such as removing Flip4mac plugins, deleting prefs, reinstalling iMovie, etc, no dice.

    So has anyone successfully got iMovie to work with a large library of iPhoto movies, like 500+? Trying to figure out if thats the core issue here, or if I have some corrupt .MOV files or something else.

    Thanks for any help.
    iMac, Mac OS X (10.5.6)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.