Skip navigation
This discussion is archived

deinterlaced output is not deinterlaced

41937 Views 300 Replies Latest reply: Mar 10, 2009 7:52 AM by Nubz N. RSS
  • Winston Churchill Level 10 Level 10 (81,830 points)
    Currently Being Moderated
    Feb 4, 2009 8:33 AM (in response to Steve Mullen)
    Steve Mullen wrote:

    PS: Can you keep 08 when you install 09?


    Yes
    MP 2 x QC Xeon 3 Ghz, 4 GB RAM, Mac OS X (10.5.6)
  • flashfish Calculating status...
    Currently Being Moderated
    Feb 4, 2009 8:37 AM (in response to spyd4r)
    I have just read this discussion and I am convinced that a completely separate problem that I am having is related to this discussion. I have been recording digital video from a digital camcorder using QT Player with QT Pro with the quality setting in recording preferences set to "Best (H.264)." Before upgrading to QT 7.6 these videos were imported as de-interlaced (and looked great). However, since upgrading to QT 7.6 I have not changed any settings and now the videos I import are all interlaced (and look terrible).

    So, it sounds to me like 7.6 is the culprit of many interlacing problems. Any thoughts?
    MacBook Pro, Mac OS X (10.5.6)
  • AppleMan1958 Level 7 Level 7 (27,335 points)
    Currently Being Moderated
    Feb 4, 2009 8:40 AM (in response to Winston Churchill)
    While I am sure you are correct on this, the default is to delete iMovie 08 during the installation process. I would suggest moving 08 to a different folder before installing 09.
    iMac 24 2.8Ghz, iPhone, TV, Mac OS X (10.5.6), Parallels 4.0.3540 with XP, Panasonic HDC-SD5
  • Winston Churchill Level 10 Level 10 (81,830 points)
    Currently Being Moderated
    Feb 4, 2009 9:07 AM (in response to AppleMan1958)
    The installation of im09 moves im08 to the same previous version folder that it moved im6 to when you installed im08.

    Whist off topic for this thread, has anyone tried dropping an im09 export (share to movie/large) into garageband for chaptering, I'm getting strange results and was just wondering if it is me (audio track is different length to movie track)
    MP 2 x QC Xeon 3 Ghz, 4 GB RAM, Mac OS X (10.5.6)
  • Winston Churchill Level 10 Level 10 (81,830 points)
    Currently Being Moderated
    Feb 4, 2009 9:10 AM (in response to Winston Churchill)
    Mmmm,
    Just checked that. It seems it moved it for me on my desktop, but deleted it on my laptop.
    MP 2 x QC Xeon 3 Ghz, 4 GB RAM, Mac OS X (10.5.6)
  • Euisung Lee Level 2 Level 2 (170 points)
    Currently Being Moderated
    Feb 4, 2009 9:59 AM (in response to Winston Churchill)
    Winston Churchill wrote:
    Are you sure about this, it isn't my experience. (I'm assuming you are talking about im09 here)

    Firstly, I see no difference between using the upper and lower setting except that lower is flagged to display as cropped. The upper setting (1920 x 1080 HD) exports with a classic aperture flag, the lower setting (HD 1920 x 1080 16:9) exports with a clean aperture flag, but you can toggle this in QT back to classic and then it should look the same as the upper setting.


    Yes I'm using 09. I believe the lower 1080 setting is broken, in a very subtle way. Like you say the lower setting should only add a flag for clean aperture, but it ends up ruining the interlacing in the process.



    Upper 1080 setting doesn't have clean aperture flag and doesn't show difference.



    Lower 1080 crops frame with clean aperture, but notice the subtle damage to interlaced lines. It shows the resizing effect even though it is full res. My guess is that QT resized 1920x1080 to 1888x1062 and back to 1920x1080. This is clearly a bug.

    Also check to confirm the output is interlaced, I don't believe it is, it just looks like it is. Drop the export into something like Media Info and it reports progressive, check deinterlace or single field in QT properties and it does nothing (as you'd expect with progressive)





    They responds to that settings in QT property so I believe my output is interlaced.

    Can I confirm this was 'export to QT' from im09, when I choose 'export to QT' and set the resolution to 540 from im09 I don't get any such ghosting just combing.

    Are you saying that when you export to movie in im09 you get ghosting (indicating deinterlacing has taken place)


    Yes it was 'export to QT' from im09. 960x540 output from both export options showed the ghosting effect. But I don't think iM09 deinterlaced source. It just happened to be the exact 50% resize that averages two fields and the result looks like deinterlacing.
    MBP 2GHz, Mac Mini coreduo, Mac OS X (10.5.6)
  • Euisung Lee Level 2 Level 2 (170 points)
    Currently Being Moderated
    Feb 4, 2009 10:43 AM (in response to Steve Mullen)
    Steve Mullen wrote:
    This is consistent with their you can't tell the difference between FullHD and QTRHD. Frankly, I think they are going to push their own HD format -- 540p. It will be the HD used on the iPhone and iPod, along with ATV. (Yes, I think Apple will go after Sony and Panasonic with an HD iPhone because for kids this is the perfect camcorder. In fact, for many folks it will be perfect.)


    I feel the same. Apple thinks 540p is good enough for consumers, and I happened almost agree with them. I ingest 960x540 and I don't mind the loss of temporal resolution by dropping one field so it works for me, but I'm not too excited about the fact that Apple is choosing what is good for average consumers without choice. They could've made 1080i work a little smarter in iM08 and 09, but not doing so - combined with new features of 09 - made it a lot worse for 09.

    (And, I really want to shoot 720p60.) My objection to 960x540 is it is not a format supported anywhere but Apple products, So although 09 will work fine for me -- I am getting worried about the way Apple is moving. For example, I'll be soon be working with a JVC camcorder that shoots 720p60. Were JVC to release a consumer version -- I'd be dead in the water with iM.


    Yeah 720p30 would work nicely with iM09 but not 60p. Similarly I love 24p but I have no easy way to use it with iM so I don't bother with it But still I think iM09 has huge benefit over iM08. Precision mode alone makes it a better editor than iM06, IMHO.
    MBP 2GHz, Mac Mini coreduo, Mac OS X (10.5.6)
  • AnotherJonny Calculating status...
    Currently Being Moderated
    Feb 4, 2009 11:02 AM (in response to spyd4r)
    Hello All,

    I've been following this discussion with great interest for the last few days. Thank you to all for your participation & insight. I've learned a great deal from reviewing your posts and I'm truly thankful that such an active and dedicated community exists to help and support others in solving their issues.

    I have a Sony HDR SR12 and I've been experiencing the same Interlacing woes that many here have been describing with exporing HD video using iMovie 09. I've come to realize that unless Apple makes a change to iMovie 09, my only option is to import my content at 960x540 vs my desired 1920x1080 for optimal quality.

    I must admit. I am disappointed that there has been no formal response from Apple. Either to acknowledge the problem as something they are looking into, or to maintain that it is 'working as intended'.

    I don't know if Apple is in the habit of reading & responding to discussions here. But with a post like this one, with 2700+ page views and growing, I think we all deserve some sort of feedback. Either to acknowledge that this is a problem they intend to fix. Or, to admit that this was a known limitation of iMovie 09 that they do not intend to correct it.

    Thanks all,

    Jonathan
    MacBookPro, Mac OS X (10.5.6)
  • sanjeevdas Calculating status...
    Currently Being Moderated
    Feb 4, 2009 12:13 PM (in response to AnotherJonny)
    Doesn't the SR12 support 30p recording? If it does, you should be fine for the future imports.
    Intel Mac Pro 8 Core, Mac OS X (10.5.6)
  • Euisung Lee Level 2 Level 2 (170 points)
    Currently Being Moderated
    Feb 4, 2009 12:18 PM (in response to Winston Churchill)
    Winston Churchill wrote:
    Can I confirm this was 'export to QT' from im09, when I choose 'export to QT' and set the resolution to 540 from im09 I don't get any such ghosting just combing.

    Are you saying that when you export to movie in im09 you get ghosting (indicating deinterlacing has taken place)


    Here is another result. iMovie09 behaves in a truly erratic fashion. After computer reboot, I tried 540 export again and this time I don't see any sign of interlaced source.

    Not ghost, comb, nada.

    Even the cropped and stabilized 60i footage is without any anomalies, which only can mean that iMovie09 did single field from the source and did all the scaling operation on single field basis.

    This is a direct contradict to my previous result, which showed ghosting for 540 output. I tried 540 from both output options (export movie, export to QT) and this time I get nice clean movies. (It did not apply to 720p output, though. 720p still shows the same ugly combing everywhere.)

    It is exactly the same project but after restart of the machine and it behaves differently. I wouldn't be surprised if the 540 output shows combing after next restart. I think there is clearly something broken within iMovie09, otherwise it shouldn't act randomly like this. Or... was it the weather?
    MBP 2GHz, Mac Mini coreduo, Mac OS X (10.5.6)
  • Winston Churchill Level 10 Level 10 (81,830 points)
    Currently Being Moderated
    Feb 4, 2009 12:31 PM (in response to Euisung Lee)
    Euisung.

    Not sure what this means, but I had to show you.

    I wanted to see your clean/classic results for myself.

    Exported from im09 and sure enough I see what you see, a subtle difference between the two.


    Upper (doesn't matter whether set to classic or clean but this classic)


    Lower (classic)

    OK, so I got to wondering if the same was true if the exports were done from QT pro instead of im09, so I did the exports and here are the results.


    Upper (doesn't matter whether set to classic or clean but this classic)


    Lower (classic)

    Now I'm not sure whether you can see any subtle difference, but I can't..

    However take a look at the bottom image, see the black border around it (this is the lower right corner of the full window). This appeared when I changed the setting to classic (This didn't happen yesterday).

    Below is the same clip with a clean setting.



    Really quite weird. I'm going to do a restart and run the tests again.
    MP 2 x QC Xeon 3 Ghz, 4 GB RAM, Mac OS X (10.5.6)
  • Winston Churchill Level 10 Level 10 (81,830 points)
    Currently Being Moderated
    Feb 4, 2009 12:46 PM (in response to AnotherJonny)
    AnotherJonny wrote:
    I have a Sony HDR SR12 and I've been experiencing the same Interlacing woes that many here have been describing with exporing HD video using iMovie 09. I've come to realize that unless Apple makes a change to iMovie 09, my only option is to import my content at 960x540 vs my desired 1920x1080 for optimal quality.


    Welcome to the  Discussion Forums.

    You don't need to compromise in that way Jonny. To avoid any nasties by exporting to anything other than im09's share movie presets. Import at full resolution, edit and export to quicktime/movie to QT movie/AIC, choose compressor preset as other, check interlaced, from size choose HD 1920 x 1080 and export. You now have a full resolution export without issues.

    The nasties only appear when you try to export to a progressive format. If you want a progressive format then use JES deinterlacer to convert your AIC export from im09.

    Message was edited by: Winston Churchill
    MP 2 x QC Xeon 3 Ghz, 4 GB RAM, Mac OS X (10.5.6)
  • flashfish Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 4, 2009 1:19 PM (in response to flashfish)
    Winston,

    flashfish wrote:
    I have just read this discussion and I am convinced that a completely separate problem that I am having is related to this discussion. I have been recording digital video from a digital camcorder using QT Player with QT Pro with the quality setting in recording preferences set to "Best (H.264)." Before upgrading to QT 7.6 these videos were imported as de-interlaced (and looked great). However, since upgrading to QT 7.6 I have not changed any settings and now the videos I import are all interlaced (and look terrible).

    So, it sounds to me like 7.6 is the culprit of many interlacing problems. Any thoughts?


    Do you think this is related to the same deinterlacing problem? After looking at video imported after QT 7.6 the only difference I see is the "Conform Aperture to" checkbox is now checked where before it was not. Any thoughts?
    MacBook Pro, Mac OS X (10.5.6)
  • Winston Churchill Level 10 Level 10 (81,830 points)
    Currently Being Moderated
    Feb 4, 2009 1:54 PM (in response to Euisung Lee)
    Euisung Lee wrote:

    Here is another result. iMovie09 behaves in a truly erratic fashion. After computer reboot, I tried 540 export again and this time I don't see any sign of interlaced source.

    Not ghost, comb, nada.


    OK, so I ran my tests again, first from im09 I exported to a large movie.

    .


    So no surprise there, and that's exactly what I saw yesterday.
    (By the way that isn't ghosting you see, I've just chosen a clip with a very violent camera movement).

    Then I ran the export as im09/export to QT/movie to QT movie and chose h264 at 960 x 540 which yesterday had problems but today doesn't. (No need to show image-it's the same as above). I then tried setting the size to compressor native and current (both 540 anyway) instead of the custom 540 size setting used previously. All the results were the same. (They weren't yesterday)

    However when I export using QT Pro/movie to QT movie/h264/540, well see for yourself.

    .

    Now picking up on something else you said earlier
    Output is the same. I always end up with interlaced fields regardless of codec, as long as I choose upper 1080 setting. I always get ugly sawtooth with 720p.


    I have seen the clips you posted with the single field and deinterlace checkboxes checked and am still puzzled. What codec are you using in that example, the reason I ask are here are my results when using im09 to export using QT/movie to QT movie/h264 with the size set to the upper HD 1920 x 1080.

    . . .
    MP 2 x QC Xeon 3 Ghz, 4 GB RAM, Mac OS X (10.5.6)
  • Winston Churchill Level 10 Level 10 (81,830 points)
    Currently Being Moderated
    Feb 4, 2009 2:02 PM (in response to flashfish)
    flashfish wrote:
    Winston,

    flashfish wrote:
    I have just read this discussion and I am convinced that a completely separate problem that I am having is related to this discussion. I have been recording digital video from a digital camcorder using QT Player with QT Pro with the quality setting in recording preferences set to "Best (H.264)." Before upgrading to QT 7.6 these videos were imported as de-interlaced (and looked great). However, since upgrading to QT 7.6 I have not changed any settings and now the videos I import are all interlaced (and look terrible).

    So, it sounds to me like 7.6 is the culprit of many interlacing problems. Any thoughts?


    Do you think this is related to the same deinterlacing problem? After looking at video imported after QT 7.6 the only difference I see is the "Conform Aperture to" checkbox is now checked where before it was not. Any thoughts?


    It may well be related (although I've seen reports that those with QT 7.5.x are also having issues exporting to 720p from 1080i)

    When you say the aperture setting is now checked, what is it checked to.

    When you say "now the videos I import are all interlaced (and look terrible)." are they interlaced or just messed up (ie do they change when you check the single field or deinterlace box in QT properties.

    What settings do you use to import, what does your camera record in.
    MP 2 x QC Xeon 3 Ghz, 4 GB RAM, Mac OS X (10.5.6)
1 ... 8 9 10 11 12 ... 21 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.