Skip navigation
This discussion is archived

iWeb 09 ftp publishing error - Test works, publish fails

29465 Views 86 Replies Latest reply: Aug 31, 2009 9:03 PM by Mike Connelly RSS
  • RRoman Calculating status...
    Was on the phone with Apple last night and they believe the problem is with Windows servers. They are investigating and will post fix soon.... At least that's what they told me.
    MacBook, Mac OS X (10.5.6)
  • chipmunk6 Calculating status...
    No, the problem isn't with windows servers, it's a bug. I might be to do with how it handles those servers but I doubt it.

    B
    U
    G
    iMac & MacBook, Mac OS X (10.5.6)
  • Roddy Level 6 Level 6 (17,255 points)
    You're not stuck with a hosting company because of a domain name registration. Simply sign up with a new one and get it redirected.
    Although I'm not going to use the built in FTP because of all the downsides, I have tested it and it works on my server whether I fill in the Directory/Path or not.
    This is because Host Excellence allows you to create your own folder on the server and name it the same as the one produced by iWeb. This overcomes the limitations of the way in which the iWeb FTP works.
    iMac 24, Mac OS X (10.5.6), 4GB Ram
  • Viktor.Karlsson Calculating status...
    Regarding "Windows problem" there is a simple way to reply to that lame excuse. Try publishing with sftp to your own OS X. Test works, but when actually publishing the very elaborate "unknown error". I've managed to make iWeb simply crash on me when trying different ways as well. This was the key feature for updating for me, hope a patch is out soon.
    iMac, Mac OS X (10.5.6)
  • Steffen Bendix Level 1 Level 1 (40 points)
    I've just found out that the issue of error 530 "authentication failed" has something to do with the form of the password. If you use other characters than letters and numbers, some servers seem to have problems with it. Try to change your password at your webhoster that it is a combination of letters and numbers.

    Steffen
    MacBook Pro, 15,5'', 2,2 GHz, Mac OS X (10.5.6), RAM: 3 GB
  • William Huisking1 Level 1 Level 1 (15 points)
    I followed this thread and found how how my host needs the form filled in. I tested it and it works!!!!!!
    In the FTP server settings under Directory/Path: I put in the website name only! I did not include www. or ftp:// or http:/ JUST the name of the website. In my case, my website is www.huisking.net and all I put in was huisking.net
    Hopefully this works for you. By the way, Bruce S was great on the 1/2 time show that just ended...
    Skip
    Imac G5 (non Intel) and Macbook Pro, Mac OS X (10.5.1), Leapord on both
  • Deborah Shadovitz Calculating status...
    To be clear for everyone, the ftp part NEVER belongs in path/directory. The FTP part goes in the first field to get to the server. Apple gives you the gray example. The path/directory is ONLY the part after the .com text. You begin with the "/" and list anything up til and including the folder/directory in which you want your site to land.
  • William Huisking1 Level 1 Level 1 (15 points)
    In my case, what I plugged in to the Path/Directory box was my hosted website name which included the .com and what was before the .com. It did work as my test website was published.
    Skip
    Imac G5 (non Intel) and Macbook Pro, Mac OS X (10.5.1), Leapord on both
  • Dav-o Level 1 Level 1 (0 points)
    I had the same problem, generally. Test worked, publish failed. So I tried some of the suggestions listed in this discussion. I changed my ftp password to start with a number, all lower case letters, no special characters. I deleted the keychain listing, and I only listed my domain (in iWeb's ftp setup) as "mydomain.com" - no www, no http://

    It worked.

    One slight hiccup - even though I only changed one or two pages, I had to upload the entire site, so it took a while, but the site works. I am hoping that was only for the first upload using iWeb 09.
    iMac, Mac OS X (10.5.6)
  • Viktor.Karlsson Level 1 Level 1 (0 points)
    Yay, a patch was released. But did it help? Nope. This is getting silly, I can publish fine to a folder, testing (sftp to the very same machine) works fine but "unknown error" when publishing over (s)ftp.

    I guess I'll try to go through the steps (again) in this discussion when I get home but really this 100% reproducible bug should be fixed.
    iMac 3.0Ghz, Mac OS X (10.5.6)
  • kgirls Calculating status...
    Currently Being Moderated
    Feb 5, 2009 12:35 PM (in response to planoBob)
    After reading numerous posts about FTP not working I am posting a screenshot of my settings for FTP '09 which has been working perfectly for me. Perhaps this will help:
    http://www.geistphotography.net/Geist_Photography/iWebFTP.html

    I did not use iWeb '08 because it did not have FTP and used DreamWeaver. From being a DreamWeaver user I have been very impressed at what iWeb '09 can do.
    iMac 24" 3.06, Mac OS X (10.5.4)
1 2 3 4 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.