Skip navigation
This discussion is archived

MacBook not recognizing Bluetooth?

8724 Views 17 Replies Latest reply: May 25, 2009 2:27 PM by debolskaya RSS
1 2 Previous Next
ellasaurus Calculating status...
Currently Being Moderated
Jan 27, 2009 10:26 AM
I have a brand new MacBook (approx 2 months old) that I have successfully paired with my cell phone using the built-in Bluetooth. This is really all that I use the Bluetooth for - sending pictures between my computer and my phone - and I haven't used it much lately. Recently I tried to send a picture from my MacBook to my cell phone and my computer tells me that the "selected communication device does not exist" - basically that I don't have Bluetooth in my computer! What has happened and how do I fix it? How do I get my computer to recognize it's Bluetooth and to connect to it again?

Message was edited by: ellasaurus
MacBook aluminum, Mac OS X (10.5.6)
  • Barry Hemphill Level 7 Level 7 (33,095 points)
    Currently Being Moderated
    Jan 30, 2009 6:41 AM (in response to ellasaurus)
    Hello e:

    WElcome to Apple discussions.

    Try trashing the preference file (com.apple.bluetooth.plist) and restarting.

    Then reset the PRAM:

    http://support.apple.com/kb/HT1379

    Barry
    iMac 20" 2.4 Ghz Intel-based/2 GB, iMac 17" 1.8 Ghz G5/1 GB, DSL, Firewire HDs, Mac OS X (10.5.6)
  • STU9000 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 31, 2009 1:39 PM (in response to Barry Hemphill)
    Don't expect the PRAM reset to solve the problem.

    Which MacBook do you own?

    Check out this thread here:

    http://discussions.apple.com/thread.jspa?threadID=1234817&tstart=0

    It seems to becoming to light that the reason lots of people are having problems with the bluetooth is because of a design flaw in the 2007 model. Someone put the wi-fi transmission line too near to the bluetooth, and they may be cross coupling and causing interference, which is giving rise to a number of problems.
    MacBook, Mac OS X (10.5.6)
  • Barry Hemphill Level 7 Level 7 (33,095 points)
    Currently Being Moderated
    Jan 31, 2009 1:50 PM (in response to ellasaurus)
    Hello e:

    Try what I suggested. It may or may not help, but the other poster apparently has some issue that is based on supposition and rumor.

    Barry
    iMac 20" 2.4 Ghz Intel-based/2 GB, iMac 17" 1.8 Ghz G5/1 GB, DSL, Firewire HDs, Mac OS X (10.5.6)
  • STU9000 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 31, 2009 2:09 PM (in response to Barry Hemphill)
    Supposition and rumour is still a step closer to solving the problem that a lot of people seem to be having with bluetooth. In the absence of any solid explanation from Apple it's better than nothing, and as a microwave engineer myself it does seem plausible that it could be the cause.

    By all means, try the PRAM reset. The problem might go away, but don't be surprised if it comes back again in a few hours/days.
    MacBook, Mac OS X (10.5.6)
  • STU9000 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 31, 2009 2:17 PM (in response to Barry Hemphill)
    If this does turn out to be the cause, least said i will not be very happy that I've been fobbed off with excuse after excuse for the past year. If there has been an oversight in the design Apple should own up to it.

    Message was edited by: STU9000
    MacBook, Mac OS X (10.5.6)
  • Eric Petermann Calculating status...
    Currently Being Moderated
    Feb 8, 2009 2:40 PM (in response to Barry Hemphill)
    Barry, this will sound stupid, but where do I find the preference file you refer to?

    I've been going crazy trying to solve this Bluetooth issue. Took my MacBook into the Madison, WI Apple store, and they found a crack in the case. They replaced the case (very cool), and told me that the Bluetooth was working fine, and they examined it. They "reset" it, apparently, making sure it was seated properly. They had the option of simply charging me for a new Bluetooth antenna, but told me that it was fine, and working, after the did in-store testing...

    So, three weeks after the visit, I'm getting the same problem. The Bluetooth konks out after a few minutes after I turn on. I'm using a wi-fi at home, and a cellular modem at work with this MacBook. It konks out at both locations.

    I'm anxious to try the preference dump, and PRAM restart.... But where do I look?

    Thanks

    Eric
    MacBook, 2 GHz Intel Core Duo, Mac OS X (10.4.8)
  • Barry Hemphill Level 7 Level 7 (33,095 points)
    Currently Being Moderated
    Feb 8, 2009 4:04 PM (in response to Eric Petermann)
    Hello Eric:

    There are no stupid questions - answers, yes, but not questions.

    The Bluetooth preference file is in Macintosh HD>library>preferences.

    Reset the PRAM here:

    http://support.apple.com/kb/HT1379

    Barry

    P.S. If that does not work, take it back to the store.
    iMac 20" 2.4 Ghz Intel-based/2 GB, iMac 17" 1.8 Ghz G5/1 GB, DSL, Firewire HDs, Mac OS X (10.5.6)
  • Eric Petermann Level 1 Level 1 (55 points)
    Currently Being Moderated
    Feb 8, 2009 5:47 PM (in response to Barry Hemphill)
    Worked great.

    Thanks for the tip. The challenge with this has been that it works for a while, then quits. I've done just the PRAM, I've shut the computer off, taken out the battery, then held the power button for 10 seconds, and I've dressed in woman's clothing, put on lipstick, walked backward through doorways, and changed "mea copa," 100 times.

    Only when I trashed the preference file, then did the PRAM reset, did it work right away.

    I'll check back in a week or so, just to let you know.

    Thanks again Barry


    Eric
    MacBook, 2 GHz Intel Core Duo, Mac OS X (10.4.8)
  • Barry Hemphill Level 7 Level 7 (33,095 points)
    Currently Being Moderated
    Feb 8, 2009 9:38 PM (in response to Eric Petermann)
    You are welcome, Eric.

    (I enjoyed your description of your "fixes." You missed one thing that I noticed right away, however. Step two is to throw dried bat wings over your left shoulder in the dark of the moon.)

    I hope things stay OK!

    Barry
    iMac 20" 2.4 Ghz Intel-based/2 GB, iMac 17" 1.8 Ghz G5/1 GB, DSL, Firewire HDs, Mac OS X (10.5.6)
  • STU9000 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 9, 2009 1:29 PM (in response to Eric Petermann)
    What is this about a preference file, I've not tried that.

    Do i trash the whole directory, or just the bluetooth file?
    MacBook, Mac OS X (10.5.6)
  • Barry Hemphill Level 7 Level 7 (33,095 points)
    Currently Being Moderated
    Feb 9, 2009 1:38 PM (in response to STU9000)
    Hello stu:

    The preference file is located as I indicated above. Occasionally (not often, but it happens), preference files become corrupted. When you trash one, OS X rebuilds it after a restart.

    Barry
    iMac 20" 2.4 Ghz Intel-based/2 GB, iMac 17" 1.8 Ghz G5/1 GB, DSL, Firewire HDs, Mac OS X (10.5.6)
  • Dist Calculating status...
    Currently Being Moderated
    Feb 27, 2009 6:42 PM (in response to Barry Hemphill)
    Thank you!

    Trashing Macintosh HD>Library>Preferences>com.apple.bluetooth.plist followed by resetting PRAM (shut down computer; then power up computer with power button while holding down commandoption+PR keys until another restart chime, ref. <http://support.apple.com/kb/HT1379>) worked.

    When my wireless keyboard stopped working on my PowerBook G4, Bluetooth was missing from System Preferences and from System Profiler (Apple menu > About this Mac > More info... > Hardware, USB sections) until i found your solution. I don't know if trashing the preference file (com.apple.bluetooth.plist) would have worked by itself, but a PRAM reset alone did not work. In addition to resetting PRAM, i had already tried multiple shut-downs and restarts, clearing caches, even resetting the CMU to no avail. (I'm stuffing all this in here in hope someoneelse's search will land them here even if they don't have a Macbook
    PowerBook G4, Mac OS X (10.5.6)
  • STU9000 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 2, 2009 1:12 PM (in response to Dist)
    I just looked for that preference file and it's not there. i think I deleted it previously, but it hasn't recreated a new one.

    My button wont scroll up on my mouse anymore. I've tried cleaning it, and I just tried a PRAM reset. Still the same problem.

    It's just one thing after another with my mac, I wish I hadn't bothered going with apple now, complete waste of money...
    MacBook, Mac OS X (10.5.5)
  • m0thr4 Level 1 Level 1 (95 points)
    Currently Being Moderated
    Mar 5, 2009 1:59 AM (in response to Barry Hemphill)
    I did that but, after rebooting, my laptop now has no recognised Bluetooth device. There's no longer a Bluetooth option in Preferences and I get the pop-up message

    "The Bluetooth Tab of Keyboard & Mouse preferences is hidden because you don't have a Bluetooth module installed or attached to your computer."

    This is on a brand new MacBook.

    Thank you for helping me to break it.
    iMac 24" 3.06 GHz Intel Core 2 Duo, Mac OS X (10.5.4), Apple TV, iPhone, Mac Mini, Airport Extreme, Airport Express
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.