Skip navigation
This discussion is archived

"an error occurred while restoring from the backup."

3173 Views 5 Replies Latest reply: Feb 19, 2009 12:22 PM by Scott Radloff RSS
Track400md Calculating status...
Currently Being Moderated
Feb 18, 2009 9:20 PM
I installed the newest OSX update today, and afterwards, my 20" imac started acting up. I figured it was because of the update, so I went to restore from an earlier backup from my time machine drive, a 1 TB WD MyBook.

It lets me start to restore, but when I get 0.7% of the way done, I get the message ""an error occurred while restoring from the backup," and then it restarts the computer. I have tried several different backups, but get the same message at the same spot with all of them. Any suggestions?
Mac OS X (10.5.6)
  • 2point5 Calculating status...
    Welcome to Apple Discussions.

    Did you update the OS via DVD or via the "Software Update" process?

    The other thing that occurred to me is that after you updated to the latest version, from your post I get the impression that your OS version on Time Machine would be different so I am thinking that you would have a conflict in versions. Not sure if that would be the problem with errors. Perhaps someone else might have a comment in that regard.

    Chris
    MacBook Pro 17" 2.33Ghz Duo, Mac OS X (10.5.6), 1Tb OWC Time Machine, iPhone 3G, iPod Nano
  • Scott Radloff Level 6 Level 6 (14,490 points)
    Track400md,

    Where I've seen this happen before has been with TM drives that have a disk error. Boot to the Leopard (or software restore) DVD, and check the external disk with Disk Utility.

    Even if Disk Utility is able to repair the drive, chances are the restoration will fail again. This is because some critical files were probably damaged by the disk error, and they will remain damaged (even though the file system is repaired).

    Of course, another possibility is that the disk error occurred on your internal drive, damaging some files. In this case, the damaged files would have been copied to the TM backup in due course, causing the failure that you are experiencing. This could also explain the problems you have experienced post-update.

    Don't despair, though. If nothing else, you can install directly from the DVD, bring it current with all updates, then restore just your user data from the TM backup. If it comes to this, I have good instructions handy.

    Scott
    17" Macbook Pro (Hi-Res, Muuuulti-touch), Mac OS X (10.5.6)
  • Scott Radloff Level 6 Level 6 (14,490 points)
    Track400md,

    No, the fact that the drive is partitioned is irrelevant. Without doubt, some files have been corrupted by a disk error. Evidently, that error has since been repaired automatically (this usually happens at boot time), but the damaged files will remain damaged.

    So now, your task will be to copy the files that can be copied, while working around whatever files are damaged. In the process, you'll end up identifying the problematic file or files. We'll use Time Machine to do this (not the Migration Assistant), and we'll need to do it from the "root" account. Here are the instructions that I give for using Time Machine to "restore" just a single user account to a new installation:

    First, enable the "root" account, then log in as root. While logged into the root account...

    1) Create an account using the exact same username and short name as an account you would like to restore from the backup. Once the account has been created, look in the "Users" folder, and move the new HOME folder into the trash.

    2) Connect the Time Machine backup drive, then open Time Machine from its Dock icon by Control-Clicking on the icon and choosing the "Browse Another Time Machine Disk..." Find your backup, then navigate one step "back in time" and locate the HOME folder you would like to restore. NOTE: This HOME folder should have the exact same name as the one you moved to the trash.

    3) Restore this HOME folder to your "Users" folder.

    4) When the restoration is complete, exit Time Machine. Open /Applications/Utilities/Terminal. At the prompt, type the following:

    <pre style="overflow:auto; font-family: 'Monaco'; font-size: 10px">chown -R username:staff /Users/username</pre>

    In the command above, you will replace all instances of "username" with the short name for the restored account. If the short name is "fred," for example, you will type the following exactly:

    <pre style="overflow:auto; font-family: 'Monaco'; font-size: 10px">chown -R fred:staff /Users/fred</pre>

    Verify that the command is correct, then press <RETURN>. When you return to the prompt, quit Terminal. Log into the restorred account to test it. If everything works as expected, log back into the root account, empty the trash, then log out of and disable the root account.

    For you, however, I'm going to recommend that you trash and replace only the contents of the HOME folder in question, and one folder at a time (only the "Movies" folder, then the "Documents" folder, etc., etc.). At some point, you'll encounter the same error, but this error will be narrowed down to a single folder.

    Skip the troublesome folder, and continue with the other folders in the HOME folder. When everything else has been successfully restored, go back to the troublesome folder and focus on it. Return the one in the trash to its place, then open it. Trash items inside this folder, one at a time, and attempt to restore same from the Time Machine backup. Continue with this process until you have identified the nested item or folder that is causing the problem.

    Rinse and repeat as necessary. At some point, you will have identified the file or files that are corrupt, and can skip them. Everything else will have been restored. It is likely that the troublesome files are inconsequential; perhaps a cache file. When you reach this point, run the "chown" command in Terminal as detailed above, then log into the account to test it. Don't forget to disable the root account when done.

    Scott
    17" Macbook Pro (Hi-Res, Muuuulti-touch), Mac OS X (10.5.6)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.