Skip navigation
This discussion is archived

IMAC G3 400Mhz

5843 Views 29 Replies Latest reply: Mar 11, 2009 10:25 AM by fall0317 RSS
1 2 Previous Next
fall0317 Calculating status...
Currently Being Moderated
Feb 27, 2009 10:16 PM
so i bought one of these imac g3's for my first mac. it is bondi blue and it has a front loading cd-rom drive. so far i really like it. i am running 9.2.2 on it right now. i know its a LITTLE outdated lol but i have one major complaint... i can't surf the internet very well. most of the web pages are scattered all over the place and i can't view them normally. any suggestions? i tried downloading mozilla but i think i downloaded the binary one, even when it was running, i didn't see a difference. should i upgrade os's? i am not sure how much my little memory can hold! please help!
imac g3, Mac OS 9.2.x
  • Jan Hedlund Level 6 Level 6 (8,880 points)
    Currently Being Moderated
    Feb 28, 2009 12:22 AM (in response to fall0317)
    Mac program files on the Internet are normally encoded MacBinary (.bin) or BinHex (.hqx) for protection. Sometimes they are just compressed (StuffIt = .sit). Use StuffIt Expander for the decoding and/or decompression (drag the file onto the StuffIt Expander icon).

    Unfortunately, the browsers capable of running under Mac OS 9.x are not going to work well with all web pages. iCab could possibly be an alternative worth trying.

    Jan
  • Jan Hedlund Level 6 Level 6 (8,880 points)
    Currently Being Moderated
    Mar 1, 2009 2:37 PM (in response to fall0317)
    i am thinking about upgrading to osx10.4 ...


    It is very important to carry out the appropriate firmware update before attempting to install any Mac OS X version.

    should i add some memory?


    Yes, as much as possible. For example, this article could perhaps be of interest.

    Jan
  • Jan Hedlund Level 6 Level 6 (8,880 points)
    Currently Being Moderated
    Mar 2, 2009 2:46 PM (in response to fall0317)
    Hi,

    The easiest and best way to find the correct memory modules is probably to buy from a supplier specialised in products for Macintosh computers (this company is merely an example, not a recommendation).

    Jan
  • christopher rigby1 Level 4 Level 4 (2,070 points)
    Currently Being Moderated
    Mar 3, 2009 3:40 AM (in response to fall0317)
    Bear these two points in mind :

    If you could find a copy, then OS 10.2 (Jaguar) will run comfortably in your iMac with maxed out RAM. It will seem quite slow compared to OS 9.2.2, but you will be much better off for browsers and email clients.

    OS 10.4 (Tiger) needs a minimum of 256MB RAM but wouldn't comfortably in less than 500MB, and prefers 1GB to feel really smooth.

    Your iMac can "officially" be maxed out to 512MB RAM so could run Tiger. "Unofficially" (unsupported by Apple, but with a machine of that age that is a fact anyway!) it could take two 512MB modules and therefore have 1GB RAM, and would therefore run Tiger comfortably.
    iMac G5 17" 1.5Gb RAM, Mac OS X (10.4.11)
  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Mar 3, 2009 5:24 PM (in response to fall0317)
    Yes, you must do the firmware updates before attempting to run Mac OS X or even boot the OS X CD.

    10.1 has issues, and very few here will be able to help you with it. It will introduce you to Mac OS X, but 10.2 is probably the oldest Mac OS X worth owning.
    Beige G3,G3 B+W,G4/867,G4/dual 1.25 MDD, Mac OS 8.6 or Earlier, and 9.2, 10.4 and Server - LW IIg, LW 4/600, ATalk ImageWriter LQ
  • christopher rigby1 Level 4 Level 4 (2,070 points)
    Currently Being Moderated
    Mar 4, 2009 5:09 AM (in response to fall0317)
    When you install 10.2, make sure you run the Software Update to bring it up to 10.2.8 - you need that upgrade for most software that still runs in 10.2, plus that last upgrade introduced Security to OS X, which didn't exist before.
    iMac G5 17" 1.5Gb RAM, Mac OS X (10.4.11)
  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Mar 4, 2009 7:46 AM (in response to fall0317)
    Start here, and follow the links for your iMac. I think yours may be a slot loading CD (as opposed to the original tray-loading CD).

    HT1935- Mac OS X: Available firmware updates

    It is a wise move to PRINT OUT the step-by-step directions when you actually go to update the firmware. The procedure seems straightforward at first reading, but is just a little bit tricky.
    Beige G3,G3 B+W,G4/867,G4/dual 1.25 MDD, Mac OS 8.6 or Earlier, and 9.2, 10.4 and Server - LW IIg, LW 4/600, ATalk ImageWriter LQ
  • dadsfav Calculating status...
    Currently Being Moderated
    Mar 5, 2009 6:04 PM (in response to fall0317)
    Did you get anywhere near a solution to your problem? I myself have an iMac
    G3 400 which I added 512 more memory to...but alas that didn't seem to help
    the fact that I really need a new browser since the Explorer 5 that came
    with my Indigo mac hasn't been supported since 2005. Anybody know what
    browser would be a good replacement: Also, how do I install? I tried upgrading
    to OS X, but ran into a wall here because my CD front-loader slot (single)
    couldn't do the necessary job. Any suggestions from anybody out there?
    Can't afford new computer just yet and trying to get all I can out of this
    one.

    Thx
    imac G3, Mac OS 9.1.x, added 512 memory
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.