Skip navigation
This discussion is archived

10.5.6 causing terribly slow Internet access

9671 Views 90 Replies Latest reply: Aug 26, 2009 1:12 AM by James Snook RSS
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Mar 12, 2009 4:21 AM (in response to James Snook)
    James

    I wish I knew the answer to this and several other Mac performance issues. I can only say what I have tried and found to work.

    I am unclear why you say: "It is not an option I can actually try".

    Not all Macs use the same code.

    Since you have tried so many things and are still unhappy I think it would be in your best interests to get Apple involved via the guarantee. After all it is their hardware and software which is at fault.

    On a probably unrelated point I have recently been investigating the considerable variation in permissions repair times. It occurs to me that this could be related to the combination of Apple not removing redundant items from the database (ie it grows with installation history) and a change in default operation between sqlite2 and sqlite3 requiring more disk cycles for every item in the database. Sqlite is being used more and more and I would expect this to affect at least Firefox 3 and Safari as well as permissions repair. In theory this exceptionally slow behaviour can be modified with sqlite pragma statements but I have not yet found a way that users can get these pragmas to persist. To date the only practical workarounds I have found are to turn off browser 'fraudulent sites' and do a clean reinstall followed by the latest manual combo update. These workarounds work independently, ie you can get the benefit of one without doing the other.

    Can I assume that you have already followed my advice to turn off fraudulent sites in Firefox 3 and Safari?
    Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.6)
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Mar 12, 2009 4:49 AM (in response to James Snook)
    I suspect that providing a DNS server in the Mac network settings will result in the router DNS being ignored. As I said earlier you can still do this with DHCP.
    Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.6)
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Mar 14, 2009 8:15 AM (in response to James Snook)
    Am I correct in thinking that your problem relates only to the following combination?

    1 - 2.66 GHz Intel iMac

    2 - OS X 10.5.6

    3 - Use of the FRITZ!Box SL DNS rather than putting a DNS in your Mac network settings.

    Can I assume that the problem goes away if you change any one of these three? In particular does it go away if you put any external DNS in your network settings?

    Where is the evidence that 10.5.6 makes SO MANY DNS servers useless? Could it be that the incompatibility is only with the FRITZ!Box SL DNS?
    Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.6)
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Mar 14, 2009 9:31 AM (in response to James Snook)
    I can see little consistency in other reports about 10.5.6 being slow.

    As I said before you will not be using two external DNSs - it will pick the first one in the list as long as it works.

    It would appear that any external DNS will work for you, ie it is only your local DNS which is incompatible with your iMacs.

    Why can't you retain DHCP with a DNS in your network options?

    There are several reports on Linux forums about these symptoms being cause by IPv6. Are you sure you have turned IPv6 off as I advised earlier?
    Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.6)
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Mar 14, 2009 10:45 AM (in response to James Snook)
    I assume that we have been discussing a home based iMac and not a university based one. University networks have a series of quite different issues.

    My experience of most university staff is that, in general, they use Apple default settings. Are you sure you have turned off IPv6?

    Have you tested your theory about DHCP overriding a external DNS specified in your network settings?

    As a matter of interest does your router have an external DNS server setting?

    Have you or any software you use modified your hosts file? Since all DNS lookups start with this file changes to it can have unexpected consequences.

    There are many Macs which do not have the difficulties you have reported with 10.5.6.
    Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.6)
  • unclemiltie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 14, 2009 7:35 PM (in response to Neville Hillyer)
    Neville

    I think I've been pretty clear about my situation with 10.5.6 being extremely slow.

    1: Everything was cool on my iMac on 10.5.5, when I upgraded to 10.5.6 all internet traffic came to a screeching slowdown.

    2: this is not just internet browsing, but also email traffic and anything else that goes to the internet

    3: I have tried the OpenDNS servers, no changes

    4: IPv6 is off

    5: When I have my MacBook sitting right next to my iMac using the same network connection with the same configuration and the same DNS servers (but with IPv6 on) I have no issues

    6: I have done the repair permissions, and other suggestions here and other posts. I've run the scanners to see if my traffic is being hijacked and it is not.

    7: No other machines in the house (iMac G4 10.5.6, MacBookPro 10.5.6 and a couple of Windoze PC's) have any issues, nor does my Yamaha receiver that has internet radio or my Dish ViP622 that has access to on-demand movies from the network.

    8: If I turn the airport off and then back on, network performance is good for a few minutes, then back to a crawl.


    It's this one stupid machine.

    BTW, MacBook Pro started out as Leopard and has been upgraded to 10.5.6, the iMac started as Panther and has been upgraded a number of times. That's really the only difference that I can see.

    I'm still suffering from horrible net performance.


    The configuration again is an iMac Intel 20" (plastic/white) 2.16Ghz, 2.5GB RAM. The internet connection is a cable modem connected to an Airport Extreme, connected wirelessly to my iMac.
    iMac Intel 20", Mac OS X (10.5.6)
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Mar 15, 2009 3:35 PM (in response to unclemiltie)
    This is interesting. I must admit that I had previously concentrated mainly on James' reports.

    Could this be a wireless issue? Have you tried an ethernet cable? If this does not work I don't know what you can try except a clean install.

    Experiments by myself and others indicate that such a long upgrade history results in very slow permissions repair on some models and this may be an indication that the OS would benefit from a cleaner install. I am not sure this would help your reported difficulties but it is probably worth trying.

    My approach would be to:

    1 - Back up all data especially all user folders, bookmarks mail etc

    2 - Reformat disk - this will destroy everything !

    3 - Install Leopard from DVD

    4 - Install latest combo update

    5 - Install everything from software update - it took 2 attempts last week

    6 - Reinstall applications

    7 - Carefully replace user data (not libraries) as required


    Notes:

    It may be difficult/impossible to get iPhoto to work properly after this - consult other iPhoto users before you start if this is important to you.

    I am not sure if iTunes will be affected - also consult before you start if this is critical.

    If you have sufficient disk space I would also advise using Carbon Copy Cloner to clone your whole disk before you do anything else so that you could, if necessary, reinstall your existing OS, data and software - this will take some time but it is an excellent insurance and you can always use the backup later to extract individual data items.
    Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.6)
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Mar 16, 2009 5:58 AM (in response to Neville Hillyer)
    There may be a few easier things you could try if you have not already done so such as:

    1 - use a local fixed IP rather than DHCP

    2 - regularly dump your DNS cache

    3 - run AppleJack in auto mode

    4 - manually reinstall the last combo update - it appears to do no harm and it may overcome the partial update reported by several people.
    Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.6)
  • fora wang Calculating status...
    Currently Being Moderated
    Mar 20, 2009 6:02 AM (in response to James Snook)
    hi ,i think i have the same problem as you describle ,however, it`s not because of network problem, but becaurse of some disk problem ,
    after you reboot your computer ,open the terminal ,type :top ,then wait the crash time come ,keep you eye on the terminal ,if a process named "mount_msdo" apears ,then it`s the same problem as i encounter , the solition is here :

    http://discussions.apple.com/thread.jspa?messageID=6579012&#6579012


    if is it`s not as same problem as i describle ,google the process name (which use 100% of cpu) on the terminal

    Message was edited by: fora wang
    macbook, Mac OS X (10.5.6)
1 2 3 4 5 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.