Skip navigation
This discussion is archived

Bug in Safari/Mobileconfig on Iphone

12733 Views 7 Replies Latest reply: Jun 22, 2009 2:36 AM by LennonNZ RSS
LennonNZ Calculating status...
Currently Being Moderated
Jan 2, 2009 6:10 PM
I am writing an offline APN Changer Webapp.. (an update from my online APN Changer ( which 10000+ people have actually used but I found a problem.

I have rewritten the APN Config program in javascript .

To send the *mobileconfig file to the phone I am send it a link to:



Which the phone returns back
"Cannot Install Profile"
Safari could not install a profile due to an unknown error.

I can send html gif etc in data: format ok.. just the mobile config don't work. (safari supports the data: format ok)

I use a javascipt form get the values and then run to _self

configfile hasthe actual config file in base64 format.

the format of the file is correct as if I run it say on a mac and save the file and then transfer the file to a webserver and open it from the iphone it works fine.

If someone wants to see the full webapp please let me know so they can debug the problem and fix the iphone's software (unless someone wants to tell me its not a bug)
HP, Windows Vista, Linux
  • Craig Baron Level 3 Level 3 (680 points)
    Currently Being Moderated
    Jan 2, 2009 6:25 PM (in response to LennonNZ)
    This is a user forum.
  • LenH Level 2 Level 2 (390 points)
    Currently Being Moderated
    Jan 4, 2009 11:08 AM (in response to LennonNZ)
    There may be a good venue for your question, but I would assume that only registered developers would know how to access it.
    Mac OS X (10.5.4), iPhone 3G
  • LoghouseJD Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 17, 2009 3:27 PM (in response to LennonNZ)
    My problem may be similar. I created a .mobileconfig for enterprise configuration of VPN and Security settings. When I email it to an iPhone it installs fine, but when I posted it as a file to my iWeb account on the safari browser on the same iPhone responds --"Safari cannot download this file." Could it be that the servers are not configured to use mime type application/x-apple-aspen-config for mobileconfig file types as required by the iPhone Configuration Utility documentation ? How can I get this file type added ?
    MacBook, Mac OS X (10.5.6)
  • LoghouseJD Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 18, 2009 9:55 AM (in response to LoghouseJD)
    I moved this question to the iWeb09 discussion group.
    MacBook, Mac OS X (10.5.6), iPhone
  • LoghouseJD Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 12, 2009 11:52 AM (in response to LennonNZ)
    Have you had any luck or found any other forums? I believe this is a bug in the simulator. I can install a mobileconfig file from my mac (running an apache server with the AddType mobileconfig) to an actual iPhone at the same version V2.2.1 (5H11) over the internet, but the simulator will not load it.
    The simulator on a signed configuration file returns "Invalid Profile. Profile format not reognized." and when clicking on an unsigned profile it returns "Can not install profile. Safari could not install a profile due to an unknown error." Any help would be appreciated... Thanks... John
    MacBook, Mac OS X (10.5.6), iPhone


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.