Skip navigation

Wireless keyboard won't turn on after changing battery

219456 Views 263 Replies Latest reply: Mar 30, 2014 3:21 PM by Richard Bird RSS Branched to a new discussion.
  • circa1977 Calculating status...
    After a few failed attempts, this last solution worked great. Make sure you actually make a "spring" out of the bent paperclip.
    MacBook 2.4GHz Core Duo, Mac OS X (10.5.6)
  • Meredith Kirn Level 1 Level 1 (0 points)
    After what seemed like a month, they (Apple) finally concluded that it was my Bluetooth card that quit working, and replaced it with a new one. Now my keyboard works.
    MacBook, Mac OS X (10.5.6)
  • daStevo Calculating status...
    Same problem as many others, got a message that batteries were low, I swopped in a new set and the keyboard would not power on again. Not a pairing issue, it was just deadsville. I spent a good hour poking around and holding in power button and gently tapping (at first) on each side. No good. Then having founf & read most of this thread, I removed the batteries, got a half inch square piece of 'tinfoil' aluminium foil, sqeezed it into a quarter of an inch ball shape, not too solid, dropped it into the tube, put the batteries back in.... bingo! Typing this on the revived keyboard!
    iMac 20", Mac OS X (10.5.6), Macbook Pro, MacSE
  • ChadSch Calculating status...
    Can you please elaborate a bit on how you formed the spring? I have a wireless aluminum apple keyboard, and after about two weeks of it being turned off, it no longer turns on even with fresh batteries.

    Thank you!
    Powerbook G4, Mac OS X (10.5.4)
  • Shadxow Calculating status...
    Hello everyone... I woke up this morning and experienced the same problem with my wireless key board. Then I connected the wired key board that came with my iMac and googled into this topic. Glad to say that the aluminum foil solution that was suggested worked perfectly, so thank you very much for that suggestion.
    iMac, Mac OS X (10.5.6), Aluminum Model
  • ltattan Calculating status...
    Had similar problem like all of you. Tried the aluminum foil suggestion. It works! Must be something to do with the contacts. So I am guessing it must be a design fault. Well done, you folks for fixing the problem D.I.Y style!
    imac, Mac OS X (10.5.6)
  • Andreas Keim Calculating status...
    Same problem here.
    no green light after new batteries.
    put a bit of paper clip between battery and one of the plus contacts, works again.
    thx for the help everybody!
    iMac Core2Duo 20" 2,1 GHZ, Mac OS X (10.5.2)
  • Cruijff Calculating status...
    I have the same problem the cap is stuck hole end, tried removing it with plastic binder and some glue but no joy so far; what did you do?
    macbook pro, Mac OS X (10.5.6)
  • DudeyPaul Calculating status...
    Had my Apple wireless keyboard for only 6 months, whilst this was a fantastic device when it was working, I started seeing the fault above. No little green LED, even with new batteries. Tried a piece of aluminium....and hey presto it worked again. Clearly this is a design defect, and needs to be rectified by Apple.

    Fortunately I'm still under warranty, so I'm taking mine back tomorrow!
    Mini, Mac OS X (10.5.6)
  • dswtan Calculating status...
    +1 on the aluminum foil ball solution for the A1255. Brilliant! I used a ball about the size of a small pea.

    Same original issue for me -- this was the second or third set of replacement batteries over the keyboard's life, with no issues previous. This time, no LED. Nothing appeared wrong. Thanks for this thread and the great solution! Definitely a design problem here.
    iMac, Mac OS X (10.5.6)
  • Dino1956 Calculating status...
    ok. After a week of going absolutely crazy trying to press the keyboard on / off switch, change batteries, go into bluetooth settings, etc...I find this Aluminum Foil post & I decided to try it. Low & behold, it worked. Unbelievable. So basically the Keyboards are manufactured poorly. Apple really does need to get a handle on Product Control. I thank the person who discovered the Aluminum foil trick. You saved the day. Why we should have to "Jimmy Rig" a brand new high tech product, is beyond me ?
    Mac Mini 1.83 Intel Core 2Duo, Mac OS X (10.5.3), One Gig Ram
  • adisor19 Calculating status...
    Oh WOW, this is sad. Just had the same problem happen to me 5 min ago and got here with a little bit of googling. I tried the aluminum ball trick and it worked on the first shot. GG Apple.

    I bought this in 2007 so it's not in warranty anymore.

    MacBook Pro 15" 2.16Ghz 4GB RAM, Mac OS X (10.5.6)
  • Dino1956 Level 1 Level 1 (40 points)
    Quite sad IMO. I cannot believe a brand new Product from Apple could have these type of almost silly issues. And clever Users are coming up with these easy fixes. Something like the Plus Terminal not making contact is just so ridiculous. Especially in a new Product. How does that wear out? I only put Batteries in it ONCE. I guess we have to depend on Creative Users to find fixes for our Apple Products. My problem is, doesn't Apple read this stuff ? If they don't, they should. I got a Tech on the phone about the KB and it took him 20 Minutes to find what KB I was referring to. I kept telling him. Your newest Bluetooth KB. It did not help. He could not find Model Number. True Story !

    On a different note, I just updated iTunes & it wouldn't synch with my Apple TV, Something about Port 3689 needed to be Opened. I did a factory restore & then did the update on the ATV. I hope it works and STAYS working. When you do nothing but an Update, it should make things better, not worse.
    Mac Mini 1.83 Intel Core 2Duo, Mac OS X (10.5.3), One Gig Ram
  • iomatic Calculating status...
    These are symptoms I'm having:

    This seems to be a widespread problem. I get this issue (((((((((wireless keyboard <— those extra parens were from the keyboard dying… ), as well Logitech, Kensington and Mighty Mouse erratic behavior. I've reset PRAM, reset the power manager, changed wireless channels, speeds; ADDED another Airport WDS access point, and yes, even REINSTALLED THE OS. Nothing.

    <Edited by Moderator>
    Mac OS X (10.5.6)
  • twophive Calculating status...
    The tin foil method described above did indeed work!

    macbook alu, Mac OS X (10.5.6)
1 2 3 4 5 ... 18 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (4)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.