Skip navigation

iTunes 8.1 Shared Library

14514 Views 35 Replies Latest reply: Jun 3, 2009 6:34 AM by VistaNoGo RSS
  • bkunrath Calculating status...
    Currently Being Moderated
    Mar 15, 2009 10:20 AM (in response to DomitianX)
    Hi,

    happened to me too. This is happemning on my MAC OSX and on my Vista box consistently - seems the iTunes rel 8.1 wasn't tested against this... it happens with Freenas firefly which worked great before ...

    Ciao, Bernd
    Macbook, Mac OS X (10.5.6)
  • pocopico Calculating status...
    Currently Being Moderated
    Mar 19, 2009 4:03 AM (in response to VistaNoGo)
    I have exactly the same problem, i recently updated to 8.1 in both Vista and Mac OS X and itunes disconnects when i try to access the firefly share ... i sure hope this gets fixed soon.
    Mac Mini, Mac OS X (10.5.6)
  • mwallis Calculating status...
    Currently Being Moderated
    Mar 19, 2009 10:01 AM (in response to VistaNoGo)
    Sadly, I too have had problems with iTunes 8.1 messing up my shared library.

    I have an iMac at home with 4 accounts (me, my wife, my son and my daughter). After upgrading to 8.1 all the music and podcasts went away. I've Added to Library again, but now when I try and update the podcasts I get a permissions problem. Permissions haven't changed.

    * Sigh *

    Maybe I should see if iTunes group needs some QA help.
    2007 iMac, Mac OS X (10.5.6)
  • tphc Calculating status...
    Currently Being Moderated
    Mar 21, 2009 12:54 AM (in response to mwallis)
    yep same problems here trying to access a shared library via freenas / firefly. Great tip from Duncan above, have gone back to 8.0.2 and I have access to my shared library again.
    Macbook Pro 2.4ghz, Mac OS X (10.5.6)
  • audio_n_video Calculating status...
    Currently Being Moderated
    Mar 21, 2009 7:48 AM (in response to VistaNoGo)
    I had the same problem, but I have just succeeded in getting my Firefly media server to work with iTunes 8.1

    It looks like the problem is in Bonjour and not in the DAAP handling.

    To work around the problem I disabled port 3689 handling in my Bonjour server (avahi) reconfigured mt-daap to handle port 3689 and then changed the start up sequence so that mt-daap started well after avahi-daemon and netatalk (because I still want the file shares to be available via Bonjour).

    Net result: a working Firefly media server accessible by iTunes 8.1 and a working AFP file shares.
    MacBook Pro, Mac OS X (10.5.6)
  • cstrouble Calculating status...
    Currently Being Moderated
    Mar 21, 2009 1:10 PM (in response to audio_n_video)
    I also had the same problem with a FreeNAS 0.69 based Firefly server. After analyzing the traffic with tcpdump, I concluded the problem was with Bonjour and not DAAP because no DAAP traffic was initiated.

    The problem appears to be the lack of a TXT record. The built in Firefly mdns code sets one up, which is why using Firefly to advertise the service works. If using Avahi or mDNSResponderPosix (e.g., on FreeNAS), adding a TXT record with "txtvers=1 iTShVersion=131073 Version=196610" is sufficient to get things working. My working mdnsresponder.conf entry for FreeNAS/Firefly is:

    freenas
    daap.tcp. local.
    3689
    txtvers=1 iTShVersion=131073 Version=196610

    Similar changes should work for other NAS or homegrown systems using Firefly with Avahi or mDNSResponderPosix.
    MacBook Pro 15", Mac OS X (10.5.6)
  • audio_n_video Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2009 5:55 PM (in response to cstrouble)
    Confirmed. This works for Avahi too.

    @cstrouble Are you sure that the "txtvers=1 iTShVersion=131073 Version=196610" should be one TXT record and not three? I note that it seems to work both ways.

    In any case, here is my revised avahi service file (/etc/avahi/services/daap.service), which works for me:

    <!DOCTYPE service-group SYSTEM "avahi-service.dtd">
    <!-- See avahi.service(5) for more information about this configuration file -->
    <service-group>
    <name replace-wildcards="yes">Firefly on %h</name>
    <service>
    <type>daap.tcp</type>
    <port>3689</port>
    <txt-record>txtvers=1 iTShVersion=131073 Version=196610</txt-record>
    </service>
    <service>
    <type>rsp.tcp</type>
    <port>3689</port>
    <txt-record>txtvers=1 iTShVersion=131073 Version=196610</txt-record>
    </service>
    </service-group>
    MacBook Pro, Mac OS X (10.5.6)
  • cstrouble Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2009 1:21 AM (in response to audio_n_video)
    @audionvideo I'm not 100% sure, but mDNSResponder doesn't seem to allow for multiple TXT record lines. The tcpdump log shows a real iTunes quoting the TXT record entries, but that doesn't seem to be necessary (although it is in the RFC, so it might be a good idea). Firefly and iTunes both define additional information, which again don't seem necessary. My guess is that iTunes is now looking for the existence of a TXT record, which is a requirement of the Bonjour protocol.

    Firefly includes the TXT record for all served plugins, which may be important for applications other than iTunes. According to http://www.dns-sd.org/ServiceTypes.html, however, DAAP is the only one that needs the record. The RSP entry isn't documented as being standard, and HTTP doesn't use the TXT record fields provided by Firefly.
    MacBook Pro 15", Mac OS X (10.5.6)
  • cstrouble Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2009 2:18 AM (in response to cstrouble)
    A little more info with a correction. According to the RFC (http://files.dns-sd.org/draft-cheshire-dnsext-dns-sd.txt):

    "The format of each constituent string within the DNS TXT record is a single length byte, followed by 0-255 bytes of text data."

    So, the TXT record format I provided is not technically correct, and quotes are not necessary (just an artifact of tcpdump formatting). In mDNSResponder on FreeNAS, as audionvideo points out, there should be multiple lines. This will create the correct TXT record with length bytes. The more correct mdnsresponder.conf entry is

    freenas
    daap.tcp. local.
    3689
    txtvers=1
    iTSh Version=131073
    Version=196610

    (Also note that there's a space between iTSh and Version, which somehow was removed earlier.) While I haven't needed additional key value pairs, iTunes does send out information for Password, Database ID, Machine Name, Machine ID, OSsi (not sure what this is), and Media Kinds Shared (35 from iTunes 8.1).

    Avahi is probably similar, in that multiple txt-record entries should be used.
    MacBook Pro 15", Mac OS X (10.5.6)
  • gbredben Calculating status...
    Currently Being Moderated
    Mar 27, 2009 9:51 AM (in response to VistaNoGo)
    I added the string 'txtvers=1 iTShVersion=131073 Version=196610' to my RendezvousProxy Service Text host entry and the Shared Library loads even faster than it did before. Great fix!
    IBM ThinkPad, Windows XP Pro
  • Sentient Sprocket Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 27, 2009 10:00 AM (in response to Duncan Wright)
    Hi. Does this method maintain your ratings and playlists..?
    MacBook Pro, Mac OS X (10.5.2)
  • sfrossi Level 1 Level 1 (20 points)
    Currently Being Moderated
    Mar 27, 2009 10:06 AM (in response to gbredben)
    Awesome! This fix worked for me. Back in business with RendezvousProxy! Thanks to everyone who contributed.
    Macbook Pro, Mac OS X (10.5.6)
  • smatheson Calculating status...
    Currently Being Moderated
    Mar 28, 2009 2:49 PM (in response to cstrouble)
    How do you get the mdnsresponder.conf file to keep it's settings? I'll edit it via su ssh'd into the machine and then go to restart the mdnsresponder service and the conf file gets overwritten with the default settings.

    Also happens if I restart the Zeroconf or DAAP via the FreeNas GUI.

    Is there another place that it's pulling those settings from?
    MacBook, Mac OS X (10.5.6)
  • smatheson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 28, 2009 3:07 PM (in response to smatheson)
    Found out what the issue was. Fixed in the latest version of FreeNas (nighlies)

    From:
    http://apps.sourceforge.net/phpbb/freenas/viewtopic.php?f=55&t=1492&p=7338&hilit =itunes+8.1&sid=12c0187c0338074c4c31e34bf35479d6#p7338

    ---------------

    Fixed in version 4481.
    But if you don't want to upgrade your system, you can to add the string


    -o "txtvers=1 iTShVersion=131073 Version=196610" -n \


    as here


    -i "count(//daap/enable) > 0" \
    -v "//daap/servername" -n \
    -o "daap.tcp. local." -n \
    -v "//daap/port" -n \
    -o "txtvers=1 iTShVersion=131073 Version=196610" -n \
    -n \
    -v "//daap/servername" -n \
    -o "rsp.tcp. local." -n \
    -v "//daap/port" -n \
    -n \
    -b \


    in file /etc/rc.d/mdnsresponder.

    --------

    Did that and it works!
    Mac OS X (10.4.7)
  • danimaltron Calculating status...
    Currently Being Moderated
    Mar 30, 2009 8:29 PM (in response to smatheson)
    This worked for me with FreeNAS as well. Thanks! Very much appreciated.
    MacBook Pro (early 2008), Mac OS X (10.5.6)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.