Skip navigation
This discussion is archived

Loosing the "Tap to Click" on the trackpad

2277 Views 11 Replies Latest reply: Mar 23, 2009 6:37 PM by Jennifer B. RSS
Peter Wintoft Calculating status...
Currently Being Moderated
Jan 15, 2009 12:16 AM
I have the "Tap to Click" option enabled, but sometimes it stops working. I then have to go back to the "System Preferences" -> "Trackpad" to first deselect "Tap to Click" (with ordinary clicking on the trackpad) and then select it again. Then it works. Anyone have similar problems or knows a solution?

I have installed both the latest software and firmware.

/ Peter

Message was edited by: Peter Wintoft
MacBook Pro 15 inch (latest model), Mac OS X (10.5.6)
  • Travis A. Level 6 Level 6 (14,970 points)
    Currently Being Moderated
    Jan 15, 2009 3:37 PM (in response to Peter Wintoft)
    Quite strange I would say... There is another post on this forum that says that enabling "Dragging" in System Preferences may help in this regard. You're sure that the firmware is updated? Nothing shows in Software Update? I know that solved many issues with the Trackpad a while ago.

    --Travis
    Unibody MBP 2.4Ghz, 2GB, 250GB 7200RPM, Mac OS X (10.5.6), 8GB iPod Touch, Time Capsule, 20" Alu iMac
  • Michael Renwick Level 2 Level 2 (195 points)
    Currently Being Moderated
    Jan 15, 2009 6:27 PM (in response to Peter Wintoft)
    This happened to me as well when I had mine. But to be honest it only happend once and then it didn't do it again...

    How long had this been happening?
    Mac OS X (10.4.1)
  • Klaus Kinski Calculating status...
    Currently Being Moderated
    Jan 20, 2009 5:43 AM (in response to Peter Wintoft)
    I can confirm that exactly the same thing happened to me, but only once so far - and only after using Windows/Bootcamp.

    In my case I was playing Fallout 3 which crashed with the black screen of death forcing me to shut down the mac using the power button. Upon booting up I held down [alt] and chose the Mac partition which then led to a "tapless" trackpad (although 3 and 4 finger gestures were still working).

    Solved as mentioned above by deselecting and reselecting in the preferences.

    (OS and firmware are all up to date).
    MacBook Pro (late 2008), Mac OS X (10.5.5)
  • parry_pb Level 2 Level 2 (290 points)
    Currently Being Moderated
    Jan 20, 2009 9:31 AM (in response to Peter Wintoft)
    It happens to me on early 2008 MBP - when it happens I have a slew of errors in system log - something like USB port has been reset - could anyone having problems check if those errors are present in their logs when the problem happens - you can open the Console.app to check this or simply open Terminal.app and type 'sudo dmesg' without the quotes and look for words "USB" and "reset".

    I am taking it to Apple store later today - seems like something that needs to be looked at.
    MacBook Pro 2.4 Ghz 4Gb, Mac OS X (10.5.5), MacBookPro4,1
  • anarchistic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 29, 2009 7:33 AM (in response to Peter Wintoft)
    This happens almost once every day on my MBP5,1. This also happens regularly on a colleagues MB5,1 - so it's both of the recent notebook releases.

    The "fix" is to disable and re-enable tapping. PITA.
    MacBookPro5,1, Mac OS X (10.5.6)
  • Persilja Calculating status...
    Currently Being Moderated
    Feb 11, 2009 10:28 PM (in response to anarchistic)
    Hi
    I have the same problem. When rebooting to Mac OSX after using boot camp, "the tap to click" works fine for some time, then stops working. I also have to open the trackpad settings to first disable, then enable it again. So I am always able to get it working again, but it is annoying.

    Somebody who has another way of solving the problem?
    MBP late 2008 2,4 Ghz, Mac OS X (10.5.6)
  • Riffamortis Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2009 9:58 PM (in response to Peter Wintoft)
    I have the same problem with my 4.1. I've got all the updates but this problem happens at least 20 times per day. I get the same errors about the usb resetting as another person mentioned. I used to go to system preferences and do the deselect/reselect thing but I've found a slightly easier workaround that works 90% of the time.

    If you're using Firefox or Safari, put the cursor over a link, put two fingers on the trackpad, and click with the button (basically a right click). A second after the menu appears on screen, the tap to click will once again function. I have no idea why this works, but it does (90% of the time) and it's faster than opening the system preferences. I really wish apple would just fix this though.
    MacBook Pro, Mac OS X (10.5.6), 2.4 GHz Core 2 Duo, 4 GB RAM, 200 GB interal HD, 250 GB LaCie d2 Extreme, 1 TB LaCie Big Disk Extrem
  • Adrian Gauci Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2009 4:41 PM (in response to Peter Wintoft)
    The same is happening to me.

    It is quite rare though...

    Still...it is quite irritating to happen :/
    Macbook Pro 2.53Ghz, Mac OS X (10.5.6)
  • Jennifer B. Level 1 Level 1 (30 points)
    Currently Being Moderated
    Mar 22, 2009 9:56 PM (in response to Peter Wintoft)
    It happens to me ALL THE TIME. I'm getting pretty sick of this! It didn't start happening until maybe a month ago. I'm pretty fed up though!

    And NOW. This is great. Ever since installing iLife 09 my keyboard randomly stops working. Sometimes I can bring it back by closing the display and then opening it again.

    The crazy thing is that these issues are TOTALLY random. I've been on here for hours and nothing has gone wrong. Then out of no where...with no other applications run or doing ANYTHING I haven't been doing for hours...it all starts to go wrong. First it's tap-to-click in this pattern of working-not-working. Then it's the keyboard goes crazy.

    I'm doing a large backup of everything at the moment. Then I plan on running disk utility from the installer disks and see if that helps. If it doesn't I'm uninstalling iLife 09 to start with and after that i don't know what.

    I'm just REALLY tired of this!
    MBP, Mac OS X (10.5.6)
  • Jennifer B. Level 1 Level 1 (30 points)
    Currently Being Moderated
    Mar 23, 2009 6:37 PM (in response to Jennifer B.)
    I contacted Apple Support today and here's what they had me do. Since this is SO random I have no way of knowing for sure if this actually going to resolve the issue. But it's worth a shot for those who still have their machines and the issues.

    1) Ran disk permission repair.

    2) Deleted the "com.apple.systempreferences.plist"
    Found here: Home folder > Library > Preferences > com.apple.systempreferences.plist

    3) If this doesn't work they said to do an Archive and Install.

    4) If that doesn't work then call them back.

    So far I've not had any more trouble TODAY after step #2. I'll report back if I continue to be problem free.

    Jenny
    MBP, Mac OS X (10.5.6)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.