Skip navigation
This discussion is archived

10.5.6 causing terribly slow Internet access

9667 Views 90 Replies Latest reply: Aug 26, 2009 1:12 AM by James Snook RSS
  • roames Calculating status...
    Currently Being Moderated
    Mar 31, 2009 7:55 PM (in response to roames)
    Apple's support is non-responsive and ineffective. I have had a ticket open on this issue now for over a week. Without serious prodding, I get nothing back from a plethora of reps who have been trying to support me on this case.

    It's time for Apple to step up and actually provide SUPPORT. I have sent traces to engineering. They have been sitting in the queue since Thursday or Friday. Clearly nobody cares.

    VERY frustrating indeed.
    iMac Core Duo, Mac OS X (10.4.11), iPod Video 30 GB
  • keggo Calculating status...
    Currently Being Moderated
    Mar 31, 2009 9:27 PM (in response to roames)
    please dont throw rocks at me if i am already saying something that has already been said or tried. the thread is too long and all i did was browse it to see where things were going.
    my understanding is that you have this config:

    AirportX > router "SL" > Modem ==> ISP

    i know you do not feel that it is DNS related but you have said that when clearing the chache on the local machine it seems to have helped; albeit for a minute or so. i will just give some basic troubleshooting and then try to get to the point.

    make sure that only one device is handling the DHCP and DNS. it doesnt have to be the same device but if it is not the same device each device needs to know where the other is.

    (I know your other computers are running fine, but we need to see if there is a relation to your clearing cache and making things better)

    consumer routers do not keep a huge DNS cache they simply learn to where to point to for resolving DNS. some routers / firewalls act as a DNS proxy and that doesnt always play nice with the some ISPs. make sure your router does not have that option, if it does turn it off or make sure you understand what it is doing.

    ping 4.2.2.2 or .1 and see if the echo reply is immediate. it should be, that is a root server.

    on your leopard computer place those two addresses for your DNS servers in network preferences and DISABLE any statically assigned DNS servers on your devices. (just for now)

    see if that makes a difference.

    if it is a DNS issue your results should be consistent on any browser and any mac connected via THE SAME medium (ie. wireless or ethernet)

    if none of this makes any difference then remove your SL router and use your Airport Extreme to connect to your ISP. Again at first let it use your ISP for DNS and then use OpenDNS (my favorite) or better yet the root server (4.2.2.1 and 4.2.2.2) both are solid and will be far more reliable than anything else.

    lastly, (maybe should be firstly) when you open a browser make sure that the process it self is not eating resources and it is functioning properly. use "top" in terminal or "activity monitor"

    i have the same set up leopard 5.6 using Airport Extreme and SnapGear Firewall VPN router then to ISP (Charter cable). i have not had any issues at all. my browsers are Firefox 3.0.8 and Safari 4Beta and both are just lightning fast on a 5mb connection.

    about me: Network systems Engineer MCP,CCNA i work with Linux and MacOSX clients and servers and as well as Windows systems. I believe that there is always a cause to problems and there is always a way to fix them, just not always pretty.
    good luck.
    MacBook pro, Mac OS X (10.5.6), 2GB RAM
  • David Oei Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 31, 2009 9:42 PM (in response to keggo)
    Mine is fixed! Finally! I bought a new router. I had a Netgear G router (WGR614v5) and switched to an Netgear N router(WNR834Bv2). I bought a refurb at newegg for $25 and it saved me from going insane. I can't tell you why or how it works, but my internet connection is flying again on my macbook air. Good luck solving your problem!
    MacBook Pro 2.2, Mac OS X (10.5.6)
  • roames Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 1, 2009 4:27 AM (in response to keggo)
    "Keggo"
    You are a good person to write such a thoughtful and comprehensive reply. I know it sounds like a DNS issue -- it is. I just believe it's an incompatibility that was introduced with the 10.5.6 update and CERTAIN wireless routers. (That's why my router works for everything else connected). If you see David's post below, you'll see he solved the problem by changing out his router.

    If I have time, I'll go through your steps, though I have already done most of them.

    But I want you to know that I deeply appreciate your taking the time to think through this and write a cogent and thoughtful suggestion. If only Apple would take the time to do such things!
    iMac Core Duo, Mac OS X (10.4.11), iPod Video 30 GB
  • roames Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 1, 2009 4:28 AM (in response to David Oei)
    David,
    Thanks. This confirms my suspicion that 10.5.6 introduced something with certain wireless routers. If Apple ever gets around to telling me what they find in my trace, I will post it here. I'm afraid I'm not too hopeful in that regard. They show little desire to help, and no response with any timeliness.
    Macbook Air, Mac OS X (10.5.6)
  • opto Calculating status...
    Currently Being Moderated
    Apr 1, 2009 6:25 AM (in response to roames)
    A new router solved my issue too. Since installing 10.5.6, I had experienced slow internet and connection dropouts, even though system said it was still connected. After experiments, I realized when I bypassed the router straight to my computer, all was well, so I got a new router and everything is fine again.
    G4 Dual, Mac OS X (10.5.6)
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Apr 1, 2009 7:20 AM (in response to roames)
    I am surprised that those affected took so long to discover that this is a wireless issue particularly as I mentioned the possibility on 4 March (via link) and 15 March.
    Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.6)
  • opto Level 1 Level 1 (25 points)
    Currently Being Moderated
    Apr 1, 2009 7:36 AM (in response to James Snook)
    I was using my router wired, not wireless (desktop computer next to it, no laptop)... but nevertheless, a new one (also using wired) fixed issue.
    Mac OS X (10.5.6)
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Apr 1, 2009 10:31 AM (in response to opto)
    Unless there is more than one bug this could point to an OS code issue affecting only some types of Mac. Older Macs (my G4s are OK) and some new ones (my Intel Xserve is OK) appear not to be affected - I rarely use wireless.
    Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.6)
  • roames Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 16, 2009 5:12 AM (in response to opto)
    I have a new router, and the problem was fixed. My last post on this topic was removed for revealing too much dirt. I wanted everyone to know that a newer router does solve this problem.
    Macbook Air, Mac OS X (10.5.6), iPod Video 30 GB
  • Road Hazard Level 2 Level 2 (230 points)
    Currently Being Moderated
    Apr 16, 2009 6:17 AM (in response to roames)
    Hoping everyone who bought new routers did the obvious before laying out the money.

    Reload router firmware and check configuration

    I'm running a 9 year old 4 port switch in front of an Airport Extreme unit. Everything ok here at the moment.
    Pismo 550 G4, Kihei 400 SE, MacBook Pro 15" (2.5 ghz Penryn), Mac OS X (10.4.11), 1024 mb RAM in G3s; 2gb RAM and OS 10.5.6 in Penryn
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Apr 16, 2009 10:15 AM (in response to James Snook)
    I got the following via email but can no longer find it here on either page 1 or page 2. You may wish to report this strange behaviour.




    James Snook posted "Re: 10.5.6 causing terribly slow Internet access" in "10.5.6 causing terribly slow Internet access" on Apr 15, 2009 7:24:05 PM.
    --------------------------------------------------------------
    I have come to the same conclusion really. As stated by someone else earlier, not all DNS servers are of the same quality, and clearly my routers old software is not up to spec. Quite why it was OS Ten point five point six specifically that made this a problem if beyond me though.

    I'll just have to see if I can pick up a better router some point. Annoying as only this one specific revision of this one specific OS is the problem where everything else is fine with it.
    --------------------------------------------------------------
    Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.6)
  • unclemiltie Calculating status...
    Currently Being Moderated
    Apr 16, 2009 10:58 AM (in response to Neville Hillyer)
    The thing that really makes me wonder is this:

    1: I have several Mac's in my house, all of them are 10.5.6. (MacBook Pro, iMac G4 and Intel iMac)

    2: My router is an Apple Airport Extreme

    3: only the Intel iMac is having issues with this


    So, I'm not horribly interested in replacing the router since I have it set up to deal with Time Machine and nothing else out there really does that. (not only that, it's not an inexpensive piece of hardware that Apple should know a thing or two about!)

    Something else is going wrong here with 10.5.6 that causes this issue SOMETIMES on some machines. Apple has been non-responsive on this.

    I'm going to re-install Leopard from scratch on the iMac to see if that fixes it. I've got to do some backups of mail, address book, documents, and web bookmarks first. But in the end, a software change should not require people to buy new routers unless there is a warning up front that says something like "This upgrae enables xyz feature which is incompatible with previous dongles, if you want to continue to use your dongle then you should not install this"

    shame on you apple!
    iMac G4, Mac OS X (10.4.7)
1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.