11 Replies Latest reply: May 1, 2009 6:12 AM by ffuser2001
Briareos200 Level 1 Level 1 (0 points)
We have using the exact same equipment made many projects that have worked just fine. We have one project that when you preview it in iDVD works perfectly. But when you burn it the DVD menu has sound but the movie itself has no sound. I have deleted encoded assets and did a disk image and it did the same thing. I called the apple help line and they had me make a new project with a sample clip from the apple website and that worked fine. When I created a disk image from that simple project it had sound. Anyone else run into this and were you able to fix it without starting over?

Powerbook, Mac OS X (10.4.11), N/A
  • 1. Re: No Sound in burned DVD
    Ziatron Level 4 Level 4 (3,265 points)
    Anyone else run into this and were you able to fix it without starting over?


    Using iMovie 06 with iDVD 09 I had the same thing happen once, I tried many things but nothing worked. I started over and had no problems.
  • 2. Re: No Sound in burned DVD
    teunis1 Level 1 Level 1 (0 points)
    About 30 minutes ago, I realized that I had the same issue (I don't include sound in my menus, so not sure if it's exactly the same). I've burned way more DVDs than I can count and never had this issue before. The IDVD project plays fine. I select "save as disc image" (as I always have). Then, using "disc copy utility.app" (as I always have), I burn the DVD. No sound.
    Most recently I've been doing a lot of basketball games that are similar in length. As far as I know, they've all worked fine (I don't check them all, right away). I do very little editing, just a few chapter points and similar menus. In comparing my problem project and the most recent that I know works fine, this is what I have found:

    Project 1: Length: 59m:31s, IMovie size: 12.88g, IDVD size: 2.51g, Image size: 3.3g
    Project 2: Length: 1h:04m, IMovie size: 13.03g, IDVD size: 2.69g, Image size: 2.74g

    Project 1 works good. Project 2 has no audio. Notice how project 2 is larger in all aspects except for the Image size. It appears that for some reason the audio is not making it to the Image file. I'm not sure what this means, but hopefully, it's a clue that someone can use.
  • 3. Re: No Sound in burned DVD
    Rich839 Level 4 Level 4 (2,370 points)
    If you are able to burn a sample project fine, then the problem is not with iDVD but more likely is project or content related.

    Sometimes improperly placed chapter markers can cause sound probs. If you have chapter markers, make sure that they are not within 2 secs of the beginning or end of your movie, or within a transition, or located too close together.

    You didn't mention whether the sound was embedded or added as a separate track, or what format the sound is in, or what source it was from (iTunes?). Might be that you have incompatible muxed formats or a digital rights protected problem.

    You might run a copy of your movie through the free download app MPEG Streamclip, and demux the sound to aiff, and then see if you can burn it. Or perhaps extract the sound in iMovie and then convert the audio clip to aiff.

    There are more tech expert people than I on this forum, and perhaps they will weigh in here.
  • 4. Re: No Sound in burned DVD
    teunis1 Level 1 Level 1 (0 points)
    OK. I rebooted and went back into IDVD selected project 2 again and then selected "save as disc image". It told me that the file already existed and I chose to replace. It spent very little time on each of the processes except for "processing audio". Now the finished project works fine (including audio) and the size of the image is 3.45g instead of 2.74. I don't have any advice other than to tell you what my experience is. Hope it helps.
  • 5. Re: No Sound in burned DVD
    Rich839 Level 4 Level 4 (2,370 points)
    Amazing how many problems that a simple restart will cure.
  • 6. Re: No Sound in burned DVD
    CdubW Level 1 Level 1 (0 points)
    I am new at iDVD and have various maddening problems getting a decent movie. Sometimes the menu would Play to ... the Menu again (this seems to be when I a few times ordered the movie to endless Loop.

    Now the damned sound is out on the whole movie part, but plays on the menu. The menu now does take me to the actual movie, but it has no sound. Back in iDVD, the preview has sound (though I had to turn it up with that little control panel). Went back to check iMovie, and all the sound lines were checked ON. The thing is on other attempts with iDVD on this movie, the sound was great.

    I wish I hadn't started fooling with the OK version of my movie, cause it was fine, cept I wanted the loop. Now many long detours. I wish I got paid for the time this costs me. Gee only $99 for iLife...is there anywhere in the fine print that you have to give your LIFE to it too?

    Anyway, the only solution seems to be to Restart Mac, so will try that and after a few hours see if it works. ****.
  • 7. Re: No Sound in burned DVD
    CdubW Level 1 Level 1 (0 points)
    oh, just remembered. After encoding the movie line, doesn't iDVD encode the audio. I recall watching the movie part encode and thinking, "oh, just the soundtrack to go." Shortly thereafter, the dvd disc tray popped out and there was a message saying the DVD was finished.
    I'll bet it didn't encode the audio line for some reason. Will try to watch for it on next try. I restarted the Mac.
  • 8. Re: No Sound in burned DVD
    CdubW Level 1 Level 1 (0 points)
    I restarted the Mac and tried again, watching to see if the audio encoding was actually happening. Now the DVD looks fine.

    Oh, I am copying the disk of the video DVD I made on the mac on the PC and it works fine. Just using a Nero program, with COPY DVD. Piece of cake. Will also do a Save Image on the Mac as well. I assumed that would be done automatically, as iMovie saves the program as a .mov file (or whatever other format you chose). So glad to be reminded of Save Image, and will do that to save further headaches on this program.
  • 9. Re: No Sound in burned DVD
    CdubW Level 1 Level 1 (0 points)
    Regarding the Looping "movie" option getting me just a looping menu.

    The looping endlessly of the menu instead of progressing to the movie was cured by inserting a transition effect between the menu and the movie. On the menu page, click on the Play Movie line, then go to Buttons tab and you'll see the transition options. HOWEVER....

    I created an iMovie to iDVD. And when I burned disk, I thought I'd make it an endless loop. So selected the movie icon in the Chart area and added the Endless Loop command. Saved the project and proceeded to burn the disc. When I played it there was sound from menu audio, but nothing on the actual movie, just video. So, I shut off the computer and restarted, and it was fine. So, I guess the moral of this is...if you have any changes in the iDVD project, to shut off the computer and restart before burning to disc, or risk having project encoded with no audio on the movie part. It doesn't make much sense, does it?
  • 10. Re: No Sound in burned DVD
    ffuser2001 Level 1 Level 1 (0 points)
    I've been having similar issues. For the sake of experimentation, I downloaded a movie clip (http://www.apple.com/quicktime/guide/hd/gilmour.html) to the desktop, opened in iDVD '09, saved "as disk image", and then burned to DVD using the disk utility. Video is fine, but no audio (the sound in the DVD menu works fine, though). I've rebooted the machine and created the DVD again from scratch, and the problem persists. If I view the movie in iDVD, it works fine, including sound.
  • 11. Re: No Sound in burned DVD
    ffuser2001 Level 1 Level 1 (0 points)
    Update: Last night I spent some time experimenting some more, and found that other MOV files that I downloaded worked just fine. Using the same process as in my previous post, I burned those clips to DVD and they had sound upon playback.

    Tried the David Gilmour clip again, and still no sound. I then converted the Gilmour clip to MPEG-2 from QT pro, followed the process again, and this time the DVD had sound. The picture quality was dreadfully bad, but at least the sound worked.

    So my only guess at this point, is that the sound encoding (?) (or sampling rates?) used on some movies is different than others, and for whatever reason, iDVD isn't able to convert that encoding to the final format for DVD.

    Anyhow, hopefully this helps.