1 2 3 4 Previous Next 148 Replies Latest reply: Apr 6, 2014 4:18 PM by Mark Scott Go to original post
  • 15. Re: Mac Pro sometimes displays static after displays wake up from sleep
    dfuerpo Level 1 Level 1 (0 points)
    I have been thinking some more about this. Unlike the Windows world where ATI and Nvidia write the universal drivers for a wide range of their GPUs, I remember reading that Apple writes their own drivers for their video systems. Since this problem is occurring with both cards, I wonder if Apple introduced the same bug in the drivers for both of these cards? Again, in the Windows arena a few years ago there were many examples of device drivers (not just video) that had problems with sleep/suspend. How do we bring this issue to Apple's attention? Is there a mechanism in this forum to do that?
  • 16. Re: Mac Pro sometimes displays static after displays wake up from sleep
    erise19 Level 1 Level 1 (0 points)
    A replacement ATI Radeon 4870 graphics card from Apple didn't fix the problem, so I thought of some more tests to do.

    I tried using a DVI -> VGA converter with my 24" monitor, and the static upon sleep problem didn't occur. Then I tried using my old 17" monitor with a DVI cable and the problem didn't occur with it either. Then I ordered a DVI -> HDMI converter with my 24" monitor, and the problem didn't occur with that either.

    So I'm now using my Mac Pro with HDMI on my 24" monitor and am not seeing any static (so far). The DVI static problem is not fixed, but it isn't affecting me anymore at least.
  • 17. Re: Mac Pro sometimes displays static after displays wake up from sleep
    mikepj Level 1 Level 1 (10 points)
    Add me to the list of people seeing this problem. 8x2.26Ghz with a Radeon 4870 card, and 2 monitors hooked up. For me, the static only happens on the monitor that is connected (via a DVI adapter) to the Mini DisplayPort. Tried switching the monitors, and the static switches with it, always on the monitor hooked up to the DisplayPort.

    Seems like a software issue to me... Hopefully Apple is on top of it
  • 18. Re: Mac Pro sometimes displays static after displays wake up from sleep
    Zemanek Level 1 Level 1 (0 points)
    I found this post from Googling. I have the same problem on my Mac Mini using the Mini-DVI -> DVI adapter that came with it.

    It looks like OS X re-locates my monitor after I turn it off then turn it back on. After that, the static goes away and it thinks for a second (there's a blue screen that fades into the GUI) and I am back in business.

    But that doesn't make this problem any less annoying. Apple: get on this!
  • 19. Re: Mac Pro sometimes displays static after displays wake up from sleep
    Zemanek Level 1 Level 1 (0 points)
    Shoot. The site was lagging and my post posted twice! Sorry!
  • 20. Re: Mac Pro sometimes displays static after displays wake up from sleep
    dfuerpo Level 1 Level 1 (0 points)
    OK, here's an update. Interesting, but it doesn't solve the problem. If this has already been reported by someone else above (I don't remember it having been) please ignore this. I was doing a big rsync between two drives and I knew it would take many hours. I didn't want to take a chance on the machine going into sleep mode so I went into system preferences and disabled computer sleep but didn't disable monitor sleep. During this period (going on 8 hours now) I successfully unblanked the screen several times, but just now I got the snow. So, it doesn't look like it is CPU suspend that is required to make this happen, just blanking the display.
  • 21. Re: Mac Pro sometimes displays static after displays wake up from sleep
    freshpageimages Level 1 Level 1 (0 points)
    Add me to the list. New 8-core machine with the ATI video card. I didn't transfer any of my old OS over - did it from scratch in order to clean up all the junk left around after a few years. Only had it since Friday, and the problem just occurred for the first time a few minutes ago. I've confirmed that the problem occurs after the screen has been put to sleep, not necessarily the system itself.
  • 22. Re: Mac Pro sometimes displays static after displays wake up from sleep
    mocsrox Level 1 Level 1 (0 points)
    So I guess the question now is.. does Apple know about this? (e.g. do they monitor these threads) and if not, how do we tell them about this problem that seems to be quite wide spread?
  • 23. Re: Mac Pro sometimes displays static after displays wake up from sleep
    Moonlight Sailor Level 1 Level 1 (0 points)
    I recently also bought a new Mac Pro and having the same problem with the snow screen appearing most of the time when it's waking from sleep. I had computer set to NOT go to sleep and it still does. To resolve it I push the power button once to make it go to sleep and then I wake it again and then I have my desktop back. What is going on? I'm going to take it in very soon if I can't find the fix.
  • 24. Re: Mac Pro sometimes displays static after displays wake up from sleep
    stop.motion Level 1 Level 1 (0 points)
    I get static that usually only last a few seconds, though this morning it wouldn't go away and i had to cycle the monitor.

    I have a 24" dell connected to the base graphics card on a brand new mac pro 2.4 quad core via DVI.

    What's the deal with this? its distressing to throw down this much money and get snow crashed.
  • 25. Re: Mac Pro sometimes displays static after displays wake up from sleep
    Victor Bellehumeur Level 1 Level 1 (45 points)
    I hope all posters realize that this is not the place to inform Apple about anything. You must either send them feedback or get a case started with AppleCare. Also, the drivers for the ATI card have yet to be released. I have both cards in my system (GT120 and ATI 4870) and have had problems but not the same as the OP. There is another thread regarding this issue at http://discussions.apple.com/thread.jspa?threadID=1992819&tstart=0.
  • 26. Re: Mac Pro sometimes displays static after displays wake up from sleep
    Pascal Pfiffner Level 1 Level 1 (25 points)
    Same here, Octocore 2.66 GHz and an Nvidia GT 120. Usually turns off itself after a few seconds, but sometimes last about half a minute. I had this with the vanilla OS and still have it after upgrading to OS X Server.
  • 27. Re: Mac Pro sometimes displays static after displays wake up from sleep
    newjerseydan Level 1 Level 1 (0 points)
    My new Mac Pro Quad 2.6 w/ATI card also exhibits this issue occasionally from waking up from sleep.

    Power cycling the monitor as mentioned above resolved it, so it would seem there is an issue with the DVI link support and identifying the monitor when waking up.
  • 28. Re: Mac Pro sometimes displays static after displays wake up from sleep
    RognaJoshNYC Level 1 Level 1 (0 points)
    I'm glad to find this thread and know I'm not alone. What a weird problem!

    I have a week old Mac Pro w/ dual 2.26 quad core Intel and ATI Radeon HD 4870.

    I use it with a Samsung monitor, which is less than a year old.

    Pretty much every time I wake the computer from sleep, I get the snow screen. I turn the monitor off and on again and it goes away. Occasionally I get a blank BLUE screen, and I turn the monitor off and on yet again, then everything's back to normal.

    It's not the end of the world, but it does bug me to have to do this every time. I hope there's a fix soon.
  • 29. Re: Mac Pro sometimes displays static after displays wake up from sleep
    Rigel007 Level 1 Level 1 (10 points)
    I have the exact same problem ONLY since I upgraded my video card from the original ATI HD 2600 to a new ATI HD 4870 !!! I am using BETA drivers, waiting for Apple to send drivers for the card...

    In my case I don't use logon at boot up. My Dell primary monitor is connected to the mini DP connector via a mini DP to DVI adaptor. It happen a couple of time when i waked up my monitors from sleep. Without any idea what was happening, I figured out my way to fixe this by changing the input on the Dell monitor from DVI to HDMI. After this action the monitor give me an error message saying "No input signal" and revert back to the DVI input with the screen back as normal!

    I have to say that since I upgraded to the ATI HD 4870, using these Beta drivers, I have weird things. For example, my primary display is a Dell 1920x1200 and my secondary display is a Sony Bravia XBR 1920x1080.

    If I turn off the Sony, no problem. But If I turn off the Dell, the drivers seem to detect the loss of the primary monitor and redirect all the windows already opened onto the Sony as the new primary monitor!

    This is bugging me because some of my windows (Final Cut Express, Aperture, etc) are distributed on my two monitors specifically with their own resolution. As a result, when they are moved from the Dell to the Sony, they must stretch to 1920x1080 in order to fit the maximum screen resolution available at that time. When I power back on my Dell monitor, it revert back to the primary monitor with all the windows screwed up!

    My routine was to put the computer to sleep before I goes myself to bed, then as quickly as I can, I have to power off my Dell monitor because when it detect itself that there is no signal, it goes to sleep. But guess what, this action of the monitor "going to sleep" does wake up the Mac Pro!?!? Unless I power off the monitor before it detect the "no signal" event. That was already like this with my other ATI HD 2600 card. But now, with the ATI HD 4870, when I came back in from onf my computer in the morning, all my windows are screwed up

    Can somebody tell me if they have the same problem with the ATI HD 4870 and two monitors?
1 2 3 4 Previous Next