Skip navigation
This discussion is archived

Could not write domain

2563 Views 4 Replies Latest reply: Apr 19, 2009 4:08 AM by westfan RSS
westfan Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 16, 2009 9:29 PM
Hello,

I closed the terminal window that I entered the command into but from what I recall I typed:

chmod 444

I may have put in ~/Library/Preferences or I may not have, I did push enter before finishing the line though

Now when I try to set it back to not showing hidden files I get this:

defaults write com.apple.finder AppleShowAllFiles 0
2009-04-17 13:46:10.507 defaults[8422:10b] Could not write domain com.apple.finder; exiting

**
To add to the description, if it helps to clarify what I have done, Office Word Autorecovery will not work and MultiClutch can not be found in the preferences pane and StuffIt gives an error of permission. I am logged in as the administrator. Any help would be greatly appreciated,

I've tried this command;

canadas-macbook:~ Canada$ sudo chmod 644 ~/Library/Preferences/com.apple.finder.plist
Password:
canadas-macbook:~ Canada$ defaults write com.apple.finder AppleShowAllFiles 0
2009-04-17 15:25:04.938 defaults[9674:10b] Could not write domain com.apple.finder; exiting
canadas-macbook:~ Canada$ sudo chmod 644 ~/Library/Preferences/com.apple.finder.plist
canadas-macbook:~ Canada$ defaults write com.apple.finder AppleShowAllFiles 0
2009-04-17 15:26:05.932 defaults[9685:10b] Could not write domain com.apple.finder; exiting
canadas-macbook:~ Canada$


*
Is it possible that I've made read only the entire library or preferences folder? Done something that would relieve the admin of admin powers even if the login was still logged in?

If anyone knows where I may have gone wrong and how I may remedy it, please let me know. Thanks very much in advance,
MacBook, Mac OS X (10.5.6)
  • Niel Level 10 Level 10 (234,820 points)
    Currently Being Moderated
    Apr 16, 2009 9:46 PM (in response to westfan)
    Run the following:

    chmod 755 ~/Library/Preferences/

    (42674)
    iMac Late 2007 Core 2 Duo, Mac OS X (10.5.6)
  • Niel Level 10 Level 10 (234,820 points)
    Currently Being Moderated
    Apr 17, 2009 10:27 PM (in response to westfan)
    Preface the command with sudo and run it again. In addition, run:

    sudo chown $UID ~/Library/Preferences

    (42698)
    iMac Late 2007 Core 2 Duo, Mac OS X (10.5.6)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.