Skip navigation
This discussion is archived

Greyed wifi

4317 Views 9 Replies Latest reply: Jun 10, 2009 3:25 PM by mnmp RSS
damian Jakobus Calculating status...
Currently Being Moderated
Mar 22, 2009 8:20 AM
I have ipod touch 2nd generation 8gig. I recently upgraded to the latest firmware. I thought the upgrade was complete and successful until I found out that the wifi has been grayed out and it says 'no wifi' on the wifi tab.

It also says that wifi address in n/a in the about section of general setting. I've been resetting the unit several times to fix it but to no avail.

Can anyone help ?
Imac, Mac OS X (10.5.5), 2.4 Ghz Intel
  • Andrew T. Level 4 Level 4 (3,210 points)
    Currently Being Moderated
    Mar 22, 2009 10:07 AM (in response to damian Jakobus)
    Hello, Welcome to Apple Discussions.



    You may wish to try restoring your iPod Touch one last time but restore as new vs using the backup file if this is what you used last time around. If you find you still can not get WiFi working, you may wish to visit your local iPod Touch Support center for further assistance.

    http://www.apple.com/asia/support/ipod/service/faq/
    iMac Intel, iPhone, iPod, Mac Book Pro, Zune, Aspire 6920, Mac OS X (10.5.6), Windows XP Pro SP3, Windows Vista SP1, Windows Vista 64 bit SP1
  • gipper76 Calculating status...
    Currently Being Moderated
    Apr 17, 2009 5:19 AM (in response to Andrew T.)
    You guys need to realize that there is a problem with the lastest update. My IPOD worked fine until I upgraded to the latest version 2.1.1 and now my it says no wifi. GO GOOGLE this and you will find thousands of hits for NO WIFI after the 2.2.1 upgrade.
  • applegenius18 Level 3 Level 3 (890 points)
    Currently Being Moderated
    Apr 17, 2009 5:51 AM (in response to damian Jakobus)
    a restore on itunes is probably your last chance.
    iMac 20" 2.66GHz (early 2008), Mac OS X (10.5.6), iPod Touch 2nd Gen (Firmware 2.2.1)
  • luvlabs Level 4 Level 4 (3,610 points)
    Currently Being Moderated
    Apr 17, 2009 6:59 AM (in response to gipper76)
    gipper76,

    The only comment on this that I have is 2.2.1 had no WiFi fixes/changes in the firmware. An incomplete install or download could leave your iPod with problems, however.

    I deal with a number of WiFi issues on this panel and honestly, we didn't have too many more after the the 2.2.1 upgrade came out. We did have a number of people that needed to reset their iPods to work with their network and had basically forgotten how to do that.
    iMAC, Mac OS X (10.5.6), 2G touch 2.2.1
  • Eltonbean Calculating status...
    Currently Being Moderated
    Apr 19, 2009 12:02 PM (in response to damian Jakobus)
    I have a 32GB iTouch and also since doing the firmware upload, I too have No Wifi Greyed out. There are 1000's of reports on google of this problem.
    Macbook Pro, Mac OS X (10.5.6), Logic Pro 8
  • deggie Level 8 Level 8 (44,930 points)
    Currently Being Moderated
    Apr 19, 2009 12:13 PM (in response to Eltonbean)
    There are thousands of reports on Google on anything.
    MacPro Dual Core 2.66 Ghz, MacBook Pro 15", iPhone 3G, Mac OS X (10.5.6), AEXs, Red 2G Nano, Red Shuffle, 160 GB Classic, White 60GB 5G, Apple TV
  • Steve643 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 25, 2009 12:05 AM (in response to Eltonbean)
    I lost the wifi on my unit and Apple tech support said it was a hardware failure. Shipped under warranty to Apple for diagnosis/replacement and they replied that my unit had been accidentally damaged or misused and that it would be returned without being repaired. They didn't even contact me with an option to have it repaired for a charge. I'd sure like to know what evidence they found that it was damaged or misused, too - they could claim this whenever they want and we're at their mercy.

    When comes back to me in smalltown B.C., I have no idea where to get it fixed, or if it's even possible to get this fixed.

    Anyone out there had their ipod touch wifi radio repaired/replaced? Cost? Where did you send or take it?
    Macbook Pro, Mac OS X (10.5.6)
  • HairlessOne Calculating status...
    Currently Being Moderated
    Apr 25, 2009 12:19 PM (in response to damian Jakobus)
    I, too, have run into this issue. Updated to 2.2.1 on 1g ipod touch; now no wifi. The option is greyed out in any and all menus. I have tried restoring multiple time, resetting network settings, even tried downgrading my firmware. Nothing works (and downgrading is impossible).

    If anyone has any clues as to why this is happening to some people, or how to repair it please let us know. It is pretty crappy to have a fully functioning device get hobbled by an official update.


    Ryan
    iMac, Mac OS X (10.5.6), ipod touch 1g 32gig
  • mnmp Calculating status...
    Currently Being Moderated
    Jun 10, 2009 3:25 PM (in response to Steve643)
    I just sent my iPod Touch 2G 8GB for repair. The wifi was not working well, I would have two ipods (both 8GB touch) side by side and mine would have a weak or no signal, while the other one would have full strength. I did reset the network settings and that worked for a little bit then it went back to it's old self.

    The whole process of sending the ipod in was great, online request, email updates of when the empty box is shipped, the ipod being shipped & received, etc.
    Now I just received an email saying that "it has been subjected to accidental damage or misuse . . . not covered". This ipod has been in portfolio case so I can't imagine what damage it has and it looks brand new other than the fingerprints on it. It would be great if Apple could tell you what the damage is and not have to wait until your ipod returns. They should give you an option to fix it instead of shipping it back and having to ship it back out again for Apple or a third party to fix it. Who better to fix an ipod other than Apple?

    I would be interested to hear from anyone about this particular problem and how it was fixed (if possible). I wish Apple can tell us what the problem is and what the possible solutions are before the product is sent back . . . out of all the ipods that our family has bought (a really old ipod (click wheel?), two nanos, U2 ipod, 30GB Video, 60GB Classic & two 2G 8GB touch) this is the first time I've had a problem with an ipod and had to deal with warranty repair.
    Any help or advice would be appreciated. Thanks!
    G4, Mac OS X (10.5.5)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.