Skip navigation
This discussion is archived

iCal Search Funtion not Working

19951 Views 30 Replies Latest reply: Dec 13, 2009 9:10 AM by joeyconnick RSS
  • Leviathan09 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 17, 2008 1:42 AM (in response to cesargeronimo)
    I don't have this folder as well.
    MacBook with MacOS X 10.5.5
  • Kentwydell Calculating status...
    Currently Being Moderated
    Nov 23, 2008 9:49 AM (in response to Robbie D)
    Quit iCal (if it is running).

    Then, from the Terminal, run the following commands:

    $ cd ~/Library/Application\ Support/iCal/Sources
    $ rm */Index

    Relaunch iCal - it will automatically rebuild the Index for each calendar, re-enabling your search.

    Sorry. I know nothing about terminal
    Is this two separate commands?
    Should they be run at the same time?
    Can you talk me through it

    I have tried a few things but I'm scared of doing harm

    Thanks in anticipation




    Can you talk me through it.
    imac G5, Macbook, Mac OS X (10.5.4)
  • Wesley Young Calculating status...
    Currently Being Moderated
    Dec 31, 2008 7:24 AM (in response to Kentwydell)
    Sorry if this is a little late.

    Ignore the $ sign before the commands. That just indicates each line is a seperate command.

    So you need to enter:

    cd ~/Library/Application\ Support/iCal/Sources

    Then press return.

    rm */Index

    Then press return.

    I'm having the same problem with iCal. This didn't work for me, but it's worth a try anyway.
    MacBook Pro, Mac OS X (10.5.6)
  • Rene Rodriguez Calculating status...
    Currently Being Moderated
    Jan 2, 2009 6:13 PM (in response to Wesley Young)
    I'm a little late to the party, but wondering if you can help me. I'm having the same problem, but none of the aforementioned tactics worked. My directory structure (on 10.5.5) doesn't have an iCal directory in Library/Application Support. Funny thing, though. I was also having a problem with 2 birthdays,so I finally exported those two contacts' vCards, then reimported. That fixed the birthday problem, and I can search for those two people in iCal. So, I exported the entire AddressBook then reimported; no luck.

    I can't search (within iCal) for tasks or events.

    Thoughts?
    PowerBook G4, QuickSilver G4 Dual-Gig, and iMac G4, Mac OS X (10.4.5)
  • kohledfusion Calculating status...
    Currently Being Moderated
    Jan 5, 2009 1:51 PM (in response to Janice Fisher)
    Just got off the phone with Apple & finally have my search working! It's a bit tedious, but it worked for me on 10.5.6

    * back up your iCal in a safe place with File>Back Up iCal

    * pick a calendar to test with & try a search that SHOULD work but doesn't

    * export the calendar with File>Export

    * delete the calendar (Control Click on the calendar in the calendar list, select Delete from pop up)

    * import the calendar with File>Import >Import an iCal File

    * select the export file you just created

    * a pop up window asks you for the name of the calendar to import to. Select the last option in the pull down "New Calendar" & the import should automatically pick up the calendar's original name.

    * try your search again.

    If that works for you repeat the steps for each calendar.

    Message was edited by: kohledfusion
    MacBook Pro, Mac OS X (10.5.6)
  • PaKo07 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 5, 2009 8:08 AM (in response to Janice Fisher)
    These steps worked for me in MacOS 10.5.6:

    1. As a precaution, in iCal select File > Backup to ensure that no data is lost.
    2. Quit iCal.
    3. In Finder, select Finder menu item Go > Home.
    4. Open Library.
    5. Drag Calendar folder to the desktop.
    6. Relaunch iCal.

    In my case this restored the iCal search function, and a new Calendar folder appeared in the Library. I then trashed the old Calendar folder (on the desktop).

    To restore iCal search for another user account on the same Mac, I had to repeat the above steps.
    MacBook Pro, Mac OS X (10.5.6)
  • tigertale Calculating status...
    Currently Being Moderated
    Feb 10, 2009 9:48 PM (in response to PaKo07)
    Thanks for posting this solution. iCal search was not working for me either, but this method worked perfectly to restore it.
    macbook pro, Mac OS X (10.5.6)
  • Claidheamdanns Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 5, 2009 10:08 PM (in response to PaKo07)
    But you lose your all your calendars that way. A better way, which worked for me was simply to backup the iCal file (File>Back Up iCal …) and then restore iCal file (File>Restore iCal …). I didn't even wait for the full restore, since I did not delete the calendars by moving the Calendars folder ... after the spinning bar of death (during the restore) for about half and hour, I just force quit out of iCal (there's no reason why it should take longer to restore than it did to create the backup, IMHO).

    Anyway, when I opened iCal again, everything was there and search works now!
    PowerMac G4, Mac OS X (10.5.6), iPhone 3G 16MB
  • Benet Calculating status...
    Currently Being Moderated
    May 8, 2009 10:34 PM (in response to Janice Fisher)
    This works in Mac OS X 10.5:

    Quit iCal
    delete the file ~/Library/Calendars/Calendar Cache
    and the folder ~/Library/Calendars/Calendar Sync Changes

    ('~' is a reference to your home folder, which is named after the user)

    When you restart iCal, it will say 'upgrading your calendar files', and voila!
    MacBook, Mac OS X (10.5.6)
  • Ert Dredge Calculating status...
    Currently Being Moderated
    Jun 15, 2009 12:16 PM (in response to Benet)
    This looked promising, and after I did it there was an "upgrading iCal" step, but the search still didn't work afterwards. iCal 3.0.6, OS 10.5.6
    MacBook Pro 15", Mac OS X (10.5.7), Also a Mac Mini and a B&W G3
  • Ert Dredge Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 15, 2009 12:21 PM (in response to kohledfusion)
    Oh, that sounds like it'll work but also does sound incredibly tedious. Search isn't working on my wife's iCal, but she has 10 calendars, 5 iCal HTTP subscriptions, and one CalDAV subscription. Exporting all of that and then setting it up again is way over the top, I'll try some of the other options presented here to rebuild indexes first.
    MacBook Pro 15", Mac OS X (10.5.7), Also a Mac Mini, MacBook and a B&W G3 in the family
  • Londinense Calculating status...
    Currently Being Moderated
    Jul 6, 2009 5:49 AM (in response to Janice Fisher)
    I have been having the same problem on OS X 10.5.7 with iCal 3.0.7. None of the above solutions worked but I found one that did on another thread.
    Open Spotlight in System Preferences. Click on the Privacy tab and add your hard disk to it. Wait a while and then remove it. Spotlight will then make a new index — this will take several hours — and voilá!
    MacBook 13", Mac OS X (10.5.7)
  • macmacga Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 10, 2009 8:03 AM (in response to Londinense)
    This technique of indexing spotlight worked for me with OS 10.5.7
    iMac 24" 2.8 GHz Intel Core 2 Duo, 12 " MacBook 13 " black, Mac OS X (10.5.7), 4 GB memory, black MacBook
  • Graham Perrin Calculating status...
    On 6 June, I realised that the presence on disk of even-t <http://www.even-t.com/> caused .calendar directories at
    ~/Library/Calendars
    to be shown, in Finder, as

      even-t Calendar Document

      — not as a directories.

    I removed the even-t application then rebuilt Spotlight indexes.

    The contained .ics files became properly visible in Finder, and Finder treated such files as

      iCal file

    — to be opened by default in iCal

    but AFAIR the original problem (search results always empty in iCal) persisted for a while.

    Some time later, the problem disappeared. Maybe an element of patience was required for something (unknown to me) to occur following removal of even-t.
    Intel and PowerPC desktops and laptops, G4 PowerPC Xserves, Xserve RAIDs, Mac OS X (10.6), Mac OS X 10.5.8 and 10.6, Mac OS X Server 10.5.8
  • cruzin\' along Calculating status...
    Just got off the phone with Apple Tech support. Their fix worked for me. See below steps:

    1) open System Preferences
    2) select Spotlight
    3) select Privacy tab
    4) click "+" to add a folder or disk
    5) in the pop-up menu, select "Macintosh HD"
    6) click "Choose"
    7) upon seeing the Macintosh HD added to the Spotlight locations, then click "-" to remove the disk
    8) close System Preferences
    9) open Spotlight: Command-Spacebar

    At this point, you should see Spotlight reindexing. This took my system about 40 minutes to run. I let it run while doing some other things on my Macbook, occasionally checking Spotlight for the status. The "minutes remaining" often increased. After it finished though, I was able to use Spotlight (find) in iCal again without problems. Good luck!
    MacBook, Mac OS X (10.5.8)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.