Skip navigation
This discussion is archived

10.5.6 Phantom Displays after install

2067 Views 11 Replies Latest reply: May 17, 2009 4:28 PM by rdale RSS
systemsdeveloper Calculating status...
Currently Being Moderated
Dec 16, 2008 7:53 PM
I was hoping to get some advice regarding a strange anomaly after installing the 10.5.6 update.

1. I installed the 10.5.6 update
2. It seemed fine, without incident
3. Upon the system installation reboots the display resolution was 800x600

I clicked the display preferences icon in the toolbar and there are now 8 Displays listed in the dropdown. One which says "Main Display" and the others "Display 1", "Display 2", etc through 7.

If I click detect displays, they are all still there.

I have tried disabling space (shot in the dark)
reset the Pram (using the Optioncommand+PR four times)
researched the forums and google
(attempted to boot to open firmware without success)

So, after this longwinded explanation, the question is:

Is there some other fix I can apply or should I just give up on the update for now and revert back to 10.5.5 from time machine. I have already lost a day on this and would hate to drag it out too much longer.

Thanks for your reply.

Thanks,
KC
mbp, Mac OS X (10.5.6), 17" 2.6Ghz 4G Ram GeForce 8600M GT
  • jeremyschultz Calculating status...
    Currently Being Moderated
    Dec 18, 2008 2:44 PM (in response to systemsdeveloper)
    I installed 10.5.6 just now and immediately had the same problem with the eight bogus displays! And I too have installed SEE2 Xtreme in the past.

    I am finding it impossible to actually download this driver and access it, because the displays are so messed up:

    • My browser's download screen doesn't show up,
    • The file itself is put on the desktop somewhere in never never land,
    • I tried downloading it to a new folder I created, but that folder opens off screen too.

    I will keep trying to reach this **** uninstaller and hopefully I can report back with success.

    Jeremy
    MacBook Pro, Mac OS X (10.5.1)
  • jeremyschultz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 18, 2008 3:50 PM (in response to jeremyschultz)
    I see Apple's forums don't like the use of profanity like **** or **** or **** or ****....

    I had no luck uninstalling the SEE2 Xtreme driver myself—there was no way to access the window with my displays so messed up. I called Tritton's tech support and got a WONDERFUL guy named Aaron who sat with me for 45 minutes. I couldn't access Terminal (couldn't see it) and zapping the PRAM did not work. In the end we had to run Leopard from the install disk, run Terminal there and delete the .kext file. After that everything works great! Thanks Aaron!

    Jeremy
    MacBook Pro, Mac OS X (10.5.1)
  • sKurt Calculating status...
    Currently Being Moderated
    Jan 2, 2009 6:40 PM (in response to systemsdeveloper)
    I also had this issue, the one quick way to get things to normal was to turn ON Mirror mode, that way every monitor ended up on the one main screen. This will allow you to adjust everything to normal 1024x768 (or what you need)

    This was not on my MacBook that already has spanning available, but on my roommates iMac G4 Lamp.
    MacBook, Mac OS X (10.5.6)
  • Plus84 Calculating status...
    Currently Being Moderated
    Jan 20, 2009 11:00 AM (in response to systemsdeveloper)
    I've experienced the same issue. I have a Macbook Pro and after installing the 10.5.6 update, I have an external VGA display that refuses to go away. Detect Display does nothing but the system does seem to recognize displays when I plug them in. It forgets about the VGA display and does what it is supposed to do when a monitor is connected but when the monitor is disconnected, the VGA Display pops back up. I spoke with support but they hadn't heard of it. I've reset PRAM, deleted display prefs, run Tech Tool, repaired permissions, started in safe mode, erased caches, etc. It would be nice to resolve this one. If anyone has any ideas, please post. Thanks.
    MacBook Pro Intel Core 2 Duo, 2.4 GHz, Mac OS X (10.5.6)
  • MNield Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 4, 2009 4:31 AM (in response to systemsdeveloper)
    Just adding weight to this, I have "almost" precisely the same problem. I did once connect an external monitor several months ago, well before 10.5.6, and now I cannot prevent this display from being recognised. I have reset PRAM, Open Firmware and so on and deleted com.apple.preference.displays.001124ce297a.plist as well as searched for references to the phantom monitor incom.apple.windowserver.001124ce297a.plist and deleted them, and finally deleted that file and allowed Leopard to recreate it. All to no avail, I still have a phantom monitor sitting off to my right (or top or bottom or left, depending how I "configure" my phantom) swallowing my mouse cursor.

    It really is the most annoying bug and there has to be a fax.

    Marc
    Powerbook G4 1.67, Mac OS X (10.5.6)
  • MNield Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 4, 2009 5:10 AM (in response to systemsdeveloper)
    Another thought on this. I kept System Profiler up on the Graphics/Displays panel whilst I deleted the two plist files I mentioned in my previous post. Hitting refresh after I deleted them, or restarting System Profiler, changed nothing, the phantom monitor was still displayed.

    This made me think that there must be another file or something that System Profiler is reading its settings from and that the key may lie there.

    Not sure if this helps, but thought I would add it for completeness.

    Marc
    Dell C521, Windows Vista
  • Rudy David Calculating status...
    Currently Being Moderated
    Mar 28, 2009 12:12 PM (in response to systemsdeveloper)
    incredible, same problem with a mac book pro but I don t think the problem comes from the latest update of lepoard.
    I m afraid the problem comes from the hardware of the dvi Maybe it s cause we pluged and unplugged the external displays without turn off the computer which has consequences a confusion in the system.
    It s just a theory and I hope it s a bad theory cause in that case we will back our computer from apple.
    Please all of you. continue to find where does this ghost displays comes from.
    Rudy David
    Mac Book Pro, Mac OS X (10.5.6), 4GO 2.5 17"
  • Antonius Gan Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 28, 2009 6:17 PM (in response to systemsdeveloper)
    Not sure if this is the same problem. In my case, my MacBook Pro discovered only 1 extra VGA Display. This happened after I disconnected an external display and then immediately closed the lid. When the laptop woke up from sleep, the extra display was there.

    I've tried resetting PRAM, trashing com.apple.preference.display*.plist and com.apple.windowserver*.plist to no avail. The most worrisome thing is that the display is there even when I log in as a different user or boot up from the Install CD. This tells me that this may well be a hardware problem.
    MacBook Pro 2.2 GHz, Mac OS X (10.5.6), GeForce 8600GT
  • rdale Calculating status...
    Currently Being Moderated
    May 17, 2009 4:28 PM (in response to systemsdeveloper)
    I also have the same issue with my iMac. The Preference>Display screen currently shows that I have 8 external Display monitors, when I am now actually only running on one display.

    When this issue started, I was running 3 monitors using Matrix TripleHead2Go (2 external monitors). After the first time the "Phantom" Displays appeared, I contacted Matrix and they sent me a script to remove their application. I ran the script, which removed Matrix applications from the drive, but it had no affect on the "Phantom Displays". Even after running their script, the number of displays doubled a short time later.

    After reading this thread, it now appears this issue has to do with the apple upgrades. I still had workarounds with the 8 displays until Parallels came out with version 4.0. Now that Parallels 4.0 is out, I cannot run the application in Coherence Mode. The other "phantom" displays are affecting the application.
    Imac, Mac OS X (10.5.6)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.