Skip navigation
This discussion is archived

10.5.7 Macbook sleeps once, freezes second time

71089 Views 233 Replies Latest reply: Sep 7, 2009 12:36 AM by pgpenc RSS
  • azputerman Calculating status...
    Currently Being Moderated
    May 19, 2009 9:03 PM (in response to Esquared)
    I am trying your solution now, will update if it worked for me on my MacBook Pro.
    MacBook PRO, Mac OS X (10.5.7), Freezing with almost every attempt to sleep... :-(
  • azputerman Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 19, 2009 9:27 PM (in response to azputerman)
    I deleted the preferences files as suggested. Initial tests are that it seems to have worked. I agree that it is probably a problem with the "powermanagement" file, but I went ahead and relocated (copied) the ones that had been modified since April 1 as suggested.

    Thanks for the solution.

    Message was edited by: azputerman
    MacBook PRO, Mac OS X (10.5.7)
  • weisbach Calculating status...
    Currently Being Moderated
    May 20, 2009 3:54 PM (in response to rhentsch)
    Thank you for discovering this. I was running into the same problem and this workaround stops the freezing.
    MacBook Pro, Mac OS X (10.5.6)
  • fjsdofnsjgv Level 1 Level 1 (10 points)
    Thank you Kai, and Norby for describing the process (I'm a Mac noob). This solution worked perfectly for me. I didn't even have to do a restart.
    MacBook Pro 4,1 (2008), Mac OS X (10.5.7)
  • John H Trimble Level 1 Level 1 (15 points)
    Currently Being Moderated
    May 20, 2009 5:53 PM (in response to AJM83)
    Add my name to the list.

    I haven't counted how many times, but it seems to be happening often. Either when I close the lid of my MacBook, or choose sleep from the menu.

    Today, after sleeping my computer (via menu) before going to work, I came home to find the sceeen lit, the fan going like crazy, and no response from clicks, spaces, returns, or force-quits ... had to hard power down. Variations of this (black screen, fan going, no response) have happened several times.

    Jon
    2.2GHz MacBook, 2GB/250GB, Time Capsule, Mac OS X (10.5.2), iPhone 3G (White!) Cinema Display
  • the family cat Calculating status...
    Currently Being Moderated
    May 21, 2009 9:10 AM (in response to AJM83)
    Yes, another one here who suffered the same bug - only noticed it when my MBP became roasting hot instead of sleeping...!

    The "add ethernet port to network config" fix did the trick for me - thanks to this thread.

    Hope Apple make an official fix soon...
    MacBook Pro 15" 2.2GHz/2GB/120GB, Mac OS X (10.5.7)
  • John H Trimble Level 1 Level 1 (15 points)
    Kai's solution worked for me as well ... I had been using a wifi location with no ethernet.

    Added ethernet and no more problems. Slept the Macbook 4 times via Apple menu, woke up with no problems. Slept it 4 times by closing lid, again, it woke up without a hitch. Plugged in my external FW drive and repeated ... no problemo!

    Thanks Kai, and thanks Apple Discussion Forums!
    2.2GHz MacBook, 2GB/250GB, Time Capsule, Mac OS X (10.5.2), iPhone 3G (White!) Cinema Display
  • MMcMinn Calculating status...
    Currently Being Moderated
    May 22, 2009 11:06 AM (in response to AJM83)
    Dear friends

    I updated my Mac Book Pro to 10.5.7 and started to observe problems with the sleep mode. First sleep ok, but the second sleep was a real night mare.

    A year ago, I configured two locations: Office with Aiport and Home with a Wireless Novtel HSUPA Modem. I removed all the other options, including Ethernet ¿a mistake?. Just to mention that I did these modifications before the 10.5.6. update.

    I noticed the first problems using the Novatel Modem (Airport off). I think most of the problems are with Airport activated. At home I only use the Novatel Modem and I was having problems with sleep mode.

    Adding an activated Ethernet connection to my local network options (Home and Office) solved all sleep problems.

    Thanks for the help and kind feedback.

    The best thing about Apple is the great support of the community of users.

    All the best

    Miguel McMinn

    Balearic Islands Spain
    Mac Book Pro, Mac OS X (10.5.7), None
  • p7k Calculating status...
    Currently Being Moderated
    May 23, 2009 3:07 AM (in response to AJM83)
    this has been a day of nightmarish cacophony of swears and cries.
    for the first time, i hated being on a mac.

    i suspected a hardware problem and reset all non-volatile flash : no help.
    i suspected adium and filed an erroneous bug report (d o u c h e).
    i suspected hardware to the point of taking it to a 'genius'.

    NO! a freaking inactive Ethernet port which I've done as part of my configurations for more than a year.

    was this god dam?

    active ethernet interface in the location profile solves the problem - is what i'm trying to say...


    if this isn't fixed in the next week, i will have no words.

    Message was edited by: p7k
    MacBookPro3,1 2.4 GHz, Mac OS X (10.5.7), 4GB RAM, CORSAIR 128GB SSD
  • arjello Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 23, 2009 1:11 PM (in response to AJM83)
    He Kai

    That worked also on my machine. Great, I think even the network is now faster. Before, I had switched off ethernet and only used airport. I had the same symptoms as described here. After I activated ethernet everything is fine again. Thanks.

    cu
    arjello

    Message was edited by: arjello
    MacBook Pro (3.1) 2.4 Ghz Intel Core 2 Duo, 4 GB RAM, Mac OS X (10.5.7), Boot Camp / Parallels / Win XP
  • dennischristopher Calculating status...
    Currently Being Moderated
    May 23, 2009 8:58 PM (in response to donsherio2)
    Hey man,

    I have the same exact problem, it is driving me mad. I also run 10.5.6 and I have been experiencing the same problems. They all started happening after I had my harddisk replaced... (and all my files were transferred...)

    I have lost 20 original compositions this way!

    Any luck yet finding an answer?!
    MacBook Pro 2gHz, Mac OS X (10.5.6)
  • zo934 Calculating status...
    Currently Being Moderated
    May 24, 2009 5:08 PM (in response to AJM83)
    Is there a fix at all to this issue, I updated to 10.5.7, noticed now that macbook freezes when its suppose to go to sleep. When I shut it down holding down the power button, and when I boot it back up, it restarts twice, then during sleep mode it freeezes. I did an archive and install, and reverted back to 10.5.6
    but when I installed 10.5.6,when I restart it , it seems to restart twice
    Help please
    macbook, Mac OS X (10.5.6)
  • Greg Earle Level 1 Level 1 (145 points)
    Currently Being Moderated
    May 24, 2009 5:15 PM (in response to smitty195)
    Update:

    Installed the Combo Updater. No change in behavior.

    Closed the lid last night before bed. Noted the light didn't start pulsing. Noticed the lights on my CardBus 802.11 card didn't go out.

    Woke up this morning, lights still on, fan(s) going like crazy, PowerBook G4 really hot. Just like some others have experienced.

    Fixed Permissions.

    Changed the Network setup to "Automatic", changed the ordering around, made my CardBus card first, Ethernet (disconnected) 2nd, and made Inactive the other 3 (modem, FireWire, BlueTooth).

    Decided to also try removing the prefs files. * Note: I only had 2 of the 5: *

    preferences.plist
    com.apple.network.identification.plist

    Deleted those, immediately re-booted.

    Problem solved!

    I should never have changed 3 things at once (bad debugger, bad!), but I'm glad it's fixed in some way. Given that I had the Ethernet port in Active state already (when it was still not working), my money is on the 2 Preferences files.
    PowerBook G4 17 inch 1 GHz, Mac OS X (10.5.7), 1 GB RAM/60 GB disk
  • Harry R. Calculating status...
    Currently Being Moderated
    May 25, 2009 5:55 AM (in response to Network 23)
    Thank you Kai -

    Enabling the Ethernet port fixed the sleep issue.

    Kinda nuts, isn't it?

    HarryR
    MacBook Pro, Mac OS X (10.5.7), PowerBook Pro
  • doug.c Calculating status...
    Currently Being Moderated
    May 25, 2009 10:08 AM (in response to AJM83)
    Why is this discussion still active? Kigh provided a work-around above, posted on May 14, 2009:

    +*Enable your ethernet port in your network settings.*+

    This has fixed the problem for me and AFAIK for countless others in this discussion.

    So to sum it up... 10.5.7 introduced a bug related to sleeping, when wireless is active and ethernet is not. Enable the ethernet port and get on with your lives. Apple will fix this when they get to it. Until then, the work-around works. This problem doesn't need any more discussion unless your bored and have nothing better to do.

    Thanks again Kigh.
1 ... 8 9 10 11 12 ... 16 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.