Skip navigation
This discussion is archived

Keynote Remote link succeed, but can't find Keynote

19745 Views 31 Replies Latest reply: Jan 6, 2010 4:43 PM by Loren Ryter RSS
  • macfixer Calculating status...
    Currently Being Moderated
    Jan 24, 2009 10:32 PM (in response to macfixer)
    Hello All,

    This does not make any sense, but I can now use the Keynote Remote on my iPhone to control my MacBook.

    Turned off Bluetooth on iPhone, iPhone will not connect with Keynote on MacBook?

    Turned off Bluetooth on MacBook, can connect to Keynote, Keynote Remote works fine from iPhone.

    Turn on Bluetooth on iPhone, Keynote Remote works fine from iPhone.

    Turn on Bluetooth on MacBook Keynote remote works fine?

    What gives?
    Mac Pro 2 by 2.66 GHz Core 2 Duo 7 GB RAM, Mac OS X (10.5.5)
  • Michael Paine Level 2 Level 2 (315 points)
    Currently Being Moderated
    Jan 26, 2009 12:53 AM (in response to macfixer)
    My understanding is that Keynote Remote works through WifFi, not bluetooth. It works on wifi for me. Maybe bluetooth is interfering with the wifi signal?
    iMac Intel, Mac OS X (10.5.5)
  • tree85 Calculating status...
    Currently Being Moderated
    Feb 22, 2009 8:14 AM (in response to jjgod)
    THis one is odd, I got it to work the very first time I used it. Had the presentation setup and working great. I bring the laptop to the presentation site and get on a different wireless network and it does not work. Bring it back to my home network and it doesn't work. Tried removing the link on the MacBook Pro, but discovered there was no way to do the same on the iPhone unless you uninstalled and reinstalled.

    Note to product development: If this has to work over multiple wifi networks that have very specific port requirements, I suggest having the remote use Bluetooth instead. At least that way you can rely on the connection no matter where you are or what wifi network is available.

    my 2 cents. Right now, it is NOT ready for primetime.
    MacBook Pro, Mac OS X (10.5.6)
  • B3ND3R Calculating status...
    Currently Being Moderated
    Feb 26, 2009 10:40 AM (in response to jjgod)
    OK, I have the same problem. It will pair, but will not find Keynote on the laptop. I have tried almost everything I can think of to get this to work - no dice.

    Firewall is open to all connections. I even tried (for kicks) creating a computer-to-computer network between my iPod Touch and my laptop. Even that didn't work as Keynote still creates the same error: "Can't find Keynote..." This leads me to believe that it's not a connection issue, but rather a software one.

    This App is worthless until Apple chooses to fix it. With no way to contact Apple for a fix on the App, I would strongly advise you don't waste your money on this App.
    Mac OS X (10.5.6)
  • John Konopka Calculating status...
    Currently Being Moderated
    Feb 26, 2009 8:43 PM (in response to jjgod)
    Similar story. It works very well at home on my WiFi (timecapsule). When I went to deliver a presentation at a hotel it did not work. Both the laptop and iPhone were on the network and could view web pages but the remote kept saying it couldn't find Keynote. I tried setting up an ad hoc network as well. No dice. Although, I did not wait very long. I'll try that. I stopped at an Apple store and the message was that ad hoc networks won't work. Both devices must be on a network that allows them to talk to each other. Back at home it worked fine.

    I once tested another app that performed similarly (Safari App). It worked at home but not at a remote site. In that case I was able to create an ad hoc network.

    Now that I'm home I tested setting up a network from my laptop. I clicked on the WiFi antenna logo at the top of the screen and selected "Create Network", and selected a password. From the iPhone I selected this network and put in the password. In settings it showed the WiFi antenna as dark indicating a connection but the iPhone main screen still showed the E symbol. I tried running the remote app and it said it couldn't play the slide show. Once I started the slide show from the laptop then everything worked fine.
    17" MacBook Pro, Mac OS X (10.5.6)
  • Kushaharris1 Calculating status...
    Currently Being Moderated
    Apr 5, 2009 6:07 PM (in response to Jasin)
    Hey thanks that worked for me. I was having the same issue but once I went into system preferences and changed my security settings and now it works.

    Macbook Pro, Mac OS X (10.5.6)
  • JHuttinga Calculating status...
    Currently Being Moderated
    Apr 6, 2009 9:23 AM (in response to jjgod)

    Same issue here. Linking works fine, see the button 'play slideshow' on my iPhone but it keep telling me after tapping it that it 'Could not play slideshow. Make sure there is a slideshow playing on your computer'

    I've tried it with .pps file iWork08 & iWork09 .key files but to no avail.

    Any suggestions?
    Of course there is the option to run it with my IR remote but that not why I purchased an iPhone and Keynote remote of course....

    Maybe we should collectively ask for our money back @ the appstore to wake up Apple?
    17" MBP Unibody 2.66 Ghz Core2Duo, Mac OS X (10.5.6), 4GB made in China 2009/08 (no graphics problems)
  • vlridder Calculating status...
    Currently Being Moderated
    Apr 22, 2009 9:17 AM (in response to jjgod)
    I found a fix on my iMac for this problem. I created the ad hoc connection, the computer and iPhone recognized the connection, but I couldn't play the slideshow. I tried all fixes, then went into the inspector for the Keynote presentation and in Document > Presentation I clicked "Normal". I had had it on "Self-playing". When I clicked Normal the iPhone remote worked. Hope this helps.
    iMac, Mac OS X (10.5.6)
  • MysteryShopper Calculating status...
    Currently Being Moderated
    Apr 28, 2009 3:47 AM (in response to vlridder)
    Thanks - that switch to 'Normal' in Keynote Inspector on my MBP worked - for about ten seconds! I saw my presentation in my Touch and swiped through a couple of slides, then went back to the browser to write this and - guess what? This is on my home network, which has a couple of WiFi access points on it. I had exactly the same kind of issues with iTunes Remote a few months ago and just gave up. I can sometimes get it to take a new pairing code, but it never sticks. Maybe my network is not suitable for some reason, but the lack of support from Apple on this is very disappointing.
    MacBook Pro, Mac OS X (10.5.6)
  • RedBrown Level 1 Level 1 (35 points)
    Currently Being Moderated
    May 18, 2009 9:15 PM (in response to jjgod)
    I have the same problem (firewall is set to "allow all incoming connections"). I too bought Keynote 09 for this remote capability and it is really disappointing.
    MacBook 2.2GHz/iMac G5 1.8GHz/iPod touch/iPhone 3G, Mac OS X (10.5.5)
  • Ringerrr Calculating status...
    Currently Being Moderated
    Jun 2, 2009 1:13 AM (in response to jjgod)
    Exact same problem here. Am somewhat surprised that even though people have been complaining about this since January Apple still don't have a workaround or fix!
    MBP, Mac OS X (10.5.7)
  • Mattdaddy058 Calculating status...
    Currently Being Moderated
    Aug 3, 2009 7:38 AM (in response to jjgod)
    OK here's what I did, Created a network (ad hoc - no password) on my macbook, went into settings -> and then switched my iphone to airplane mode-> THEN back to wifi and switch it on wifi -> choose the computer name ... wait for it, wait for it, BAM, there it is, wifi in airplane mode. go to keynote and link per instructions. tested several times and worked at my college for a presentation to my class! very nice...
    Intel Imac 17", Mac OS X (10.5.6), MacBook 13", Apple TV, iPhone 3Gs, Airport Extreme, Ipod Nano
  • RickMarquez Calculating status...
    Currently Being Moderated
    Aug 18, 2009 9:36 PM (in response to jjgod)
    Everything worked for me once I allowed all connections in Lil Snitch for Keynote...
    MacBook Pro, Mac OS X (10.4.11)
  • WiredBob Calculating status...
    This is the tip that worked for me - setting the iPhone to Airplane Mode and then connecting to my Macbook Pro's ad-hoc network. Needs a little more reliability testing but thanks!
    Macbook Pro 2008, Mac OS X (10.5.8)
  • RedBrown Level 1 Level 1 (35 points)
    Mattdaddy058 and WiredBob, that's exactly what I did but what is annoying is that it doesn't always work. With this procedure I was successful may be 1 out of 10 times. Even if it works it is still cumbersome since I have to go back and forth between wifi network and own network to show online materials in my presentation.
    MacBook 2.2GHz/iMac G5 1.8GHz/iPod touch 2.1/iPhone 3G 2.1, Mac OS X (10.5.5)


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.