Skip navigation
This discussion is archived

The Bonjour service has been disabled.

179288 Views 41 Replies Latest reply: Mar 20, 2010 6:51 AM by William Alexander1 RSS
  • Straightbourbon.net Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 28, 2009 7:15 AM (in response to Snoop Dogg)
    I struggled with this problem (or a very similar one) for MONTHS before I stumbled upon a simple solution that worked for me.

    Disable Officescan realtime anti-virus

    Not sure if it was the files that were being scanned in realtime, or if it was the firewall built into the realtime scanner that was causing the problem.

    I did not have this problem before I upgraded to iTunes 8, even though I did have the anti-virus running before that.

    In some cases, I could get iTunes to start without the "The Bonjour service has been disabled. Bonjour is required to share music with others. Please re-enable the service to use this feature." error, and I could connect to my remote speakers.

    Usually, if I started iTunes first thing after a reboot, it would be fine. But then as I loaded other stuff, started my VPN (even stopped the VPN), and then exited iTunes and went back in, I would get the error, and then when I clicked OK, iTunes would start up, without the remote speakers.

    So almost like a "latch". If I can get iTunes to start successfully first thing after a reboot, and I leave it open, then it works fine. But if I do other stuff first, then try and start iTunes, OR if I ever do other stuff and then exit iTunes and try and go back in, I get the dreaded Bonjour error listed above, and then the remote speakers are no longer visible in iTunes.

    Not sure what the "other stuff" was that caused the Bonjour error when subsequently starting iTunes, but I believe it had to do with my VPN connection, which is just an ordinary windows XP network connection. Even if I stopped the VPN before starting iTunes, the damage had already been done, and I would not be able to start iTunes with remote speakers anymore until I did a reboot. (Note that my VPN connection is ordinary windows XP connection, not one of the 3rd party VPNs such as Juniper that is known to have problems with Bonjour.)

    Then one day, my virus scanner was interfering with my web browsing (kept saying legitimate pages were virus risks - this has been happening more lately.) So I got annoyed and disabled the Officescan realtime anti-virus engine.

    I then noticed shortly thereafter that iTunes would ALWAYS start up without the bonjour error, and I can ALWAYS see the remote speakers now!

    So, must be some combination of something the VPN was doing (starting and stopping it, or just starting it), along with what the Officescan realtime anti-virus was doing.

    My circumstances may be somewhat unique, and may not apply to others that are getting this bonjour error, but it just goes to show that turning off the virus scanner can fix this error, at least in SOME cases.

    In the past, I was somewhat dismissive about people blaming the virus scanner for errors - seems like a "typical" excuse. But in my case, it solved the bonjour error! (I see that disabling virus scanner was recommended early on in this thread, and I WISH I had tried it sooner! I did try a bunch of other stuff recommended here, but not that.)

    Going forward, I can play around with trying to get the virus scanner running again and seeing if there are some exceptions I can create for the scanning and for the firewall (BTW, my windows XP firewall is OFF, and I have a linksys router.)

    At least I know what is causing the conflict now.
    Dell Latitude
  • toonz Level 7 Level 7 (22,355 points)
    Currently Being Moderated
    Jun 2, 2009 10:53 AM (in response to Straightbourbon.net)
    Straightbourbon.net

    Did the problem with the iTunes error about Bonjour showing up in error get any better with the version they just released this week, iTunes 8.2?
  • zinfy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 7, 2009 4:53 PM (in response to Pat Kenly)
    Hi i seem to be having the same problem, installed itunes 8.2
    and bonjour is now disabled so cant use apple tv to sync. I unistalled all apple aplications , including safari,mobileme,updater..everything apple . then installed intunes and still nothing bonjour
    still disabled , all other applications like tivo that uses bonjour is up and running, so my guess
    is that its in itunes, anyone have any other recommendations?
    Windows Vista, vista home premium
  • travnewmatic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2009 1:57 AM (in response to Pat Kenly)
    This worked for me

    Start
    Control Panel
    Administrative Tools
    Services

    Look for Bonjour Service

    I'm not exactly sure what order I did this in, but i stopped it, closed itunes, started it, and then opened itunes

    now Remote works

    Hope this helps someone!

    Message was edited by: travnewmatic
    built, Windows XP
  • zinfy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 23, 2009 5:58 AM (in response to travnewmatic)
    hi i actually tried that and nothing, been doing a few other thinngs with apple rep and nothing, so now there having there engineers looking at it.
    maybe they can get me somekind of workaround.
    Windows Vista
  • jackcanrelax Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2009 7:39 PM (in response to zinfy)
    I too have tried this and nothing has worked - does anyone have any idea how this might be fixed. This is driving me nuts...
    Dell Inspiron 700m, Windows XP
  • blohard Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2009 4:39 PM (in response to Snoop Dogg)
    thanks for this solution. ran the script and got response:
    Name now registered and active
    dell PC, Windows XP, service pack 3
  • 19turtle97 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 10, 2009 12:55 PM (in response to james.parke)
    Bonjour apparently stops working,this is weird!
    PC
  • rlarkins Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 28, 2009 7:23 AM (in response to Pat Kenly)
    I tried all of the recommendations I have seen on numerous message threads for itunes share and bonjour disabled including reloading itunes and bonjour in different order several times. I also tried to configure the UDP port and restart Bonjour in Administrative Tools without success.

    The itunes share/bonjour finally worked when I right clicked on the cisco security agent flag and set security to "none". If this is your situation it is recommended that you turn security back on once you are done sharing on the network.
    Dell D630, Windows XP, with Cisco Security Agent Firewall
  • diehl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 4, 2010 8:27 AM (in response to Pat Kenly)
    how to enable bonjour service

    ok i figured out how to make it work ill tell you step by step.
    first go to start,run and type in msconfig then click services tab and then check the box that says bonjour service then click apply then ok then exit without restart. now go to start, control panel/Administrative Tools/services and right click bonjour service and click start. and then bonjour is enabled
    hp, iPhone OS 3.1.2
  • diehl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 4, 2010 8:28 AM (in response to Pat Kenly)
    how to enable bonjour service

    ok i figured out how to make it work ill tell you step by step.
    first go to start,run and type in msconfig then click services tab and then check the box that says bonjour service then click apply then ok then exit without restart. now go to start, control panel/Administrative Tools/services and right click bonjour service and click start. and then bonjour is enabled
    hp, iPhone OS 3.1.2
  • William Alexander1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 20, 2010 6:51 AM (in response to Pat Kenly)
    Ok. Figured this one out. In my case, I had installed another program that uses Bonjour, and installs its own copy. The new app installation (Extensis Suitcase in my case) overwrote the registry entry for the service to point to its own version.

    Go to Control Panel > Administrative Tools > Services.

    Right Click Bonjour Service and select Properties.

    Look for Path to Executable

    If it points anywhere other than "C:\Program Files (x86)\Bonjour\mDNSResponder.exe" then you need to edit the registry entry to point to the above path.

    To Edit the registry entry

    Start > Run > regedit.exe and find the following...

    HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\services\Bonjour Service

    Double-click the "Image Path" entry and change path to the above mentioned path (or wherever it is on your computer. You need to use the one in the Program Files > Bonjour folder.

    Restart the service, and Voila! Fixed. It makes sense that a re-install of iTunes would also fix this as it would overwrite the service path on re-install, but my method keeps you from having to re-install and setup iTunes.
    Windows 7
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.