Skip navigation
This discussion is archived

external disk attached to TC is repeatedly corrupted

904 Views 1 Reply Latest reply: Jun 18, 2009 2:48 AM by jsmilliere RSS
sean.peters Calculating status...
Currently Being Moderated
May 5, 2009 4:55 PM
This is the latest in a long series of issues I've had with my new TC - after resolving problems with the wireless networking, Time Machine backup failures, and Airport Utility connections to the TC, I'm now experiencing problems with the external hard drive I have attached to the TC. One of the reasons I bought the TC in the first place is that I have a 500 GB HFS+ external hard drive that I want to share with the rest of my network. It's an Iomega device, but I forget the model number (I can look it up if people think it's relevant). I've owned the external drive for about 6 months and it worked flawlessly when connected directly to the Mac.

The problem: the attached disk ends up getting corrupted like twice a day. I see this message in the TC log file:

May 05 13:48:54 Severity:4 Volume dk4 on Disk sd0 (Iomega HDD 2.68) needs repair (256).

followed by a similar one informing me that the volume failed to mount. Once this happens, I need to disconnect the drive, connect it to my Mac, and repair it with disk utility. Then, upon plugging it back in, it works... for a while. But within a few hours or so, I'll start seeing the same message in the log files. The amber light on the front of the TC may or may not blink, indicating a disk problem.

Any ideas? This is a real stumper. I really need to get this disk shared... my wife's (Windows) machine is stuffed with files, and she needs to dump them to this network disk.
Powerbook G4, Mac OS X (10.5.4), TC version 7.4.1
  • jsmilliere Calculating status...
    Did you resolve your issue ?
    I've resolved a similar one by removing the USB Hub I was using (two HDD where conencted to my AE).

    Of course, I've only one HDD connect now, but since, everything is working fine.

    Don't know if it can help you.

    Message was edited by: jsmilliere
    iMac - MB White - iPhone - AP Extreme, Mac OS X (10.5.7)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.