Skip navigation

iPhone 3GS Headphones activate Voice Control randomly while listening music

120026 Views 203 Replies Latest reply: Sep 28, 2013 8:32 AM by Shanth0ny RSS
1 2 3 ... 14 Previous Next
Ethank83 Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 25, 2009 9:08 PM

My new iphone 3gs randomly activates Voice Control while I am listening music trough ipod app. I tried playing music without the headphones plugged and everything was normal. However as soon as i plugged in my new headphones, the voice control kept activating itself randomly.

Should I change my headphones? Is it a software issue? Or Am I activating voice control without knowing something?

Thank you,
iphone 3GS 16G, iPhone OS 3.0
  • shadowstorm Level 1 Level 1 (0 points)
    I noticed the exact same issue with my vmoda vibe II duos on my new 3gs (the headphones work perfectly on the 3g), but what I noticed was slightly different: the volume would constantly jump up and down just slightly, and it would look like it was about to go into Voice Control but then stop, resulting in skipping music playback (skipping every few seconds, for about 1 second at a time). Additionally, I couldn't activate voice control at all, the call button on the headphones was completely useless, couldn't even double or triple click it to control which song I was listening to. Any click on it would trigger voice control, but it wouldn't accept any commands (and from the screen it looked like it was hearing lots of feedback/sound from the mic despite not saying anything, as the visual representation of the soundwaves in Voice Control were spiking all over the place).

    I'm still trying to find something definitive about headphone changes on 3gs, but it does support the newer volume controls in the headphones, but the issue was completely resolved when I switched to the Apple In Ear headphones (I just wish they weren't such weak and empty headphones, whereas the vmodas are deep and handle bass really well, despite their manufacturing/production problems).
    MacBook Pro, Mac OS X (10.5.7)
  • TWParker Level 1 Level 1 (10 points)
    I know the 3-button remote works by placing a signal on the mic line (2nd ring of the plug). It sounds to me like a lot of headsets with mics aren't fully compatible with the 3GS because of the remote support. Non-mic headsets should ground the 2nd ring to sleeve, so no problem there.

    Anyone tried the previous-generation iPhone headset w/ the single-button mic? If that headset works OK (minus the volume control) the problem is out-of spec 3rd party headsets. You'll probably have the same issues with new iPod Touch, Shuffle, or Nano, they also support the remote.
    iPhone 3GS, iPhone OS 3.0
  • amdude Level 1 Level 1 (0 points)
    I have the same problem. I use it at the gym and listen to music and voice control will pop up and then close, then music starts playing again. The songs skip around, pause and play. Then I tried to stop and close the ipod music but it coming back up while running on the treadmill. I rebooted and it continued to happen. So I had to power off and finish workout because it wouldn't stop no matter what I did. I guess it looks like it is related to the headset which of course I only wear while working out and is the only time I notice this. They need to fix asap.
    MacBook, iPhone OS 3.0
  • Scott B. Silverman Level 1 Level 1 (65 points)
    I'm using the original iPhone headphones (single button) with a new 3G S and I'm having similar issues. My voice control will activate randomly and often clicking the mic button on the headphones does nothing at all. It will not start/stop my music, skip tracks, or answer incoming calls. It seems there are some major incompatibilities with any headphones other than the stock headphones that come with the 3G S / iPod shuffle. The only other alternative are the Apple in-ear headphones, which also have the same controls as the 3G S phones. Hopefully this is resolved somewhat in a software update...
    Unibody MacBook Pro 2.53GHz Core 2 Duo, Mac OS X (10.5.6), 4GB RAM, 320GB HD
  • jynxthecat Level 1 Level 1 (15 points)
    Having the same problem. Anyone have an answer?
    iPhone 3GS 32GB Black
  • Jmm5149 Level 1 Level 1 (0 points)
    I'm having the same problem with my 32gb 3gs. It only occurs for me when I'm working out and using apple's headphones. It might be from sweat or body heat, but cmon apple! You guys are the ones promoting Nike+!

    Anybody got any ideas? (besides using another brand of headphone)
  • Scott B. Silverman Level 1 Level 1 (65 points)
    I have a feeling this is a "sit and wait" situation. This is almost certainly a software bug that will need to be fixed in a software update from Apple. I can't imagine we'll be waiting too long...
    Unibody MacBook Pro 2.53GHz Core 2 Duo, Mac OS X (10.5.7), 4GB RAM, 320GB HD
  • GGarvin Level 1 Level 1 (0 points)
    I am also having the same problem. Another set of headphones had solved the problem but just the last few runs the same things started happening again. Terriby frustrating! I wish we'd get some kind of confirmation.
    Dell Precision, Windows Vista
  • Scott B. Silverman Level 1 Level 1 (65 points)
    Make sure you submit this as a bug to Apple:
    Unibody MacBook Pro 2.53GHz Core 2 Duo, Mac OS X (10.5.6), 4GB RAM, 320GB HD
  • Vallard Level 1 Level 1 (5 points)
    I just got an e-mail saying they are shipping me new headphones under my warranty.... Has anyone else seen this?
    iPhone 3GS, Windows XP
  • Vallard Level 1 Level 1 (5 points)
    Nevermind... Turns out that someone else did a "Do-It-Yourself repair" and it ended up on my account somehow...
  • CrenDawg Level 1 Level 1 (0 points)
    I am having this same issue with my new 32 gig 3gs. It just started while I was running and I am wondering if it was sweat hitting the mic or something. If it is that is a pretty glaring flaw for a work-out oriented headset?
    MacBook Pro, Mac OS X (10.5)
  • CrenDawg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 11, 2009 9:07 AM (in response to Ethank83)
    I took a cool hairdryer to the clickie portion, where the mic is.. for about 20 seconds and now it seems to be operating correctly.

    My guess is it is sweat from my fingers in the mic shorting it out.
    MacBook Pro, Mac OS X (10.5)
  • LaMoni Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 15, 2009 4:56 AM (in response to CrenDawg)
    I was having the same problem but I don't think it is the sweat. I was using it completely dry and still does it. Has anyone heard anything about a fix. Will be calling support.

    If anyone has any ideas please contact me via email at
    PC - home built, Windows Vista, Intel Quad 6600 2.4ghz
1 2 3 ... 14 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.