8 Replies Latest reply: Jan 4, 2010 8:52 AM by Richard Reeves
dustoff99 Level 1 Level 1 (0 points)
Odd, on my old iPhone, I had one calendar, no matter where I entered in the info. On my me account, my outlook or my phone - all on the same calendar on my iPhone.

Upgraded to the iPhone 3Gs and I have 2 entries, then I noticed that I have "On My iPhone and on my mobile me as 2 seperate calendars.

How can I consolidate so I have just have 1 entry?

Dell 720 XPS, Windows Vista, Q6600 : 4 GB RAM : 8800GT SLI
  • 1. Re: Calendar question - double entries
    ShadyMac Level 4 Level 4 (1,250 points)
    Are there duplicate calendars in Mobile Me when you're viewing the calendar section or just on iPhone? What calendars show?? eg. home outlook entourage etc...
    Have you tried resetting the sync data?
    Are the two calendars showing different events or the same events?
  • 2. Re: Calendar question - double entries
    dustoff99 Level 1 Level 1 (0 points)
    Mobile Me: Just one entry

    Outlook: Just one entry

    iPhone: 2 calendars if I have All calendars checked ("On My iPhone" and "Mobile Me") are the 2 calendars.

    I just upgraded my old iPhone 3G to the 3Gs - I guess I could have hit the wrong button when I sync'd for the first time?
  • 3. Re: Calendar question - double entries
    ShadyMac Level 4 Level 4 (1,250 points)
    You possibly did tell it to merge the two calendars when loading...

    If Mobile Me and Outlook only have one entry then you may try Going to Mobile Me preferences on the synced machine...then first choose reset sync data, then choose between the two options it gives...Replace data on iPhone with data from the cloud...or replace data on the cloud with what's on iPhone...Obviously I;d choose the first to replace the iPhone with what's on the cloud...

    If that doesn't work...then...

    Try removing the Mobile Me account from iPhone and make sure both calendars are gone from iPhone and then add the Mobile Me account back and reset the sync data in Mobile Me preferences...
  • 4. Re: Calendar question - double entries
    ATILANO Level 2 Level 2 (300 points)
    On iPhone: Settings --> Mail, Contacts, Calendars --> Select your MobileMe account --> Turn Calendars off. When it asks you to keep the data or delete it from your iPhone, choose Delete. Wait a couple of minutes and then turn Calendars back on. Choose to Merge Data. You should be good to go.
  • 5. Re: Calendar question - double entries
    dustoff99 Level 1 Level 1 (0 points)
    Thanks ATILANO, that worked !!!

    =]

    Thank you very much.
  • 6. Re: Calendar question - double entries
    vrc54 Level 1 Level 1 (0 points)
    I had the same problem- just got a 3GS and transferred all from my original iPhone- double entries in Calendar and Contacts. This solution did the trick for both.

    Thanks Atilano!
  • 7. Re: Calendar question - double entries
    AppleSam Level 1 Level 1 (0 points)
    Thanks Atilano!!! This has been a problem for me for awhile. I got feed up today. I'm sorry it took me so long to look up the answer. You made my day!!
  • 8. Re: Calendar question - double entries
    Richard Reeves Level 1 Level 1 (0 points)
    I had this problem too!
    Solved!
    I wanted to say thank you!!!!
    Have a great new year!