Skip navigation
This discussion is archived

This accessory is not made to work with IPhone

8628 Views 20 Replies Latest reply: Aug 9, 2009 11:14 PM by minami813 RSS
  • Snowball1979 Calculating status...
    Currently Being Moderated
    Jul 11, 2009 2:48 AM (in response to jstanfield)
    I am getting this EXACT same issue...

    http://discussions.apple.com/thread.jspa?threadID=2077677&tstart=0

    Did you find a solution to your problem?
    Self Build, iPhone OS 3.0, iPhone 3Gs
  • dgebler Calculating status...
    Currently Being Moderated
    Aug 3, 2009 5:05 AM (in response to jstanfield)
    Has anyone found a solution yet?
    MacBook, Mac OS X (10.5.6), using Windows XP via VM Fusion, 500GB TC
  • dgebler Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 3, 2009 5:51 AM (in response to mikevio)
    I just updated to 3.0.1 and I got the sound back and so far...no annoying messages.
    MacBook, Mac OS X (10.5.7), using Windows XP via VM Fusion, 500GB TC
  • Peter Mallamo Level 1 Level 1 (140 points)
    Currently Being Moderated
    Aug 4, 2009 2:32 PM (in response to mikevio)
    My original 8 GB iPhone was doing the exact same thing for several weeks. It started out of the blue with the "Accessory" message, and that would be very random, sometimes it would flash the message as soon as I hit the sleep/wake button then it would go back to sleep instantly, other times it would just flash the message, then it stopped flashing the message but began doing the turning itself on every minute and was draining my battery as well.

    I had at that point not upgraded to 3.0 yet because of all the issues so it is not due to that i don't think.

    I tried cleaning the dock connector with a toothbrush and canned air, restoring the phone, even resorted to banging it on the counter top! I read all the posts on this site trying to see what people have done to fix the issue but very few have been successful. I was very close to getting the new 3Gs but don't want to resort to that yet.

    Then about a week ago I simply plugged and unplugged my original white Apple cable into the dock port about 20 to 30 times in quick succession. It must have cleaned out whatever was in there or re-aligned a pin because since then it has worked just as before. All those problems went away.

    Do you use a dock to charge instead of the cable? Do you have non-Apple speakers or anything that you normally would connect it to? I think it is some pin in the dock port that gets mis-aligned and it makes the phone think something is being plugged in.

    Give it a try. Hope it works for you. I have since upgraded to 3.0 with no issues at all, and even have a longer battery life than before.

    Peter

    Message was edited by: Peter Mallamo
    Mac Pro 2GHz Dual Intel, 6 Gig RAM, FCP 6.0.4, Mac OS X (10.5.6)
  • dgebler Level 1 Level 1 (10 points)
    I went to the Genius Bar today at the local Apple Store and was told that this is a software bug and I will have to wait until OS 3.1. He cleaned out the dock connector and I restored the iPhone as well, but to no avail. I still get the messages.
    MacBook, Mac OS X (10.5.6), using Windows XP via VM Fusion, 500GB TC
  • minami813 Calculating status...
    Currently Being Moderated
    Aug 9, 2009 11:14 PM (in response to HakoneRider)
    Hi, my iphone have a same problem. I tried to cleaned up my phone as advise by the others in here, but it look like not easy to clean it up, especially the connector at the bottom. So, can u pls teach me how to clean it up ?

    Thanks in advance.
    iphone 2G, Windows XP
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.