Skip navigation
This discussion is archived

IOHIDEventQueueEnqueue: Error enqueuing memory. (0xe00002e8)

50327 Views 109 Replies Latest reply: May 5, 2010 3:22 PM by asucaris RSS
  • Palova Calculating status...
    Aug 2 14:13:49 MBP-SW /usr/libexec/hidd[27]: IOHIDEventQueueEnqueue: Error enqueuing memory. (0xe00002e8)

    Apple Hardware Test for Memory both normal and thorough mode do not show any issues.

    Please someone tell me there is a fix for this.
    MackBook Pro Mid 2009, Mac OS X (10.5.7)
  • pendolino Level 1 Level 1 (10 points)
    fyi - i went to the genius bar in london two days ago but they were also unable to explain why my system was hanging. the genius basically told me it did not seem to be a hardware issue. i had also asked if this could be related to the new 500GB hard drives on the new macbook pro 13s (like the one i have) being faulty as i had come across this online (http://www.macsimumnews.com/index.php/archive/secretinternal_apple_document_concerning_problematic_macbook_pro_harddriv/) and they said there was no official or documented issues mentioned by Apple and that was just hearsay.

    My choices are the following:
    - archive and install: i was told that this would fix the problem if it was an OS/system software issue and nothing to do with my apps and preferences (because they would be restored as before).
    - backup to time machine, reformat, and then migrate backup back: this would not really solve anything if it is a software issue i think since all files would be brought back.
    - wait for snow leopard to come out and do a new installation: since its coming out in about a month and i had planned to upgrade immediately (mainly for exchange support in mail), this may be an all-in-one option that would take care of all.

    unless the problem increases in severity i will likely go for the last option. will keep the forum updated though.
    macbook pro 13 unibody, Mac OS X (10.5.7)
  • JGmac Calculating status...
    Pendolino just and fyi....I have this problem on a brand new MBP. It is a 500gb hard drive but is a Hitachi. I will say I do occasionally hear a click from the hard drive....which I have had since first turning it on. I am going to try an archive and install....what the heck I have nothing to loose on that.
  • pendolino Level 1 Level 1 (10 points)
    jgmac - thanks for chiming in and please let us know how the archive and install goes. I've been traveling for the past few days so waiting to get home until trying.

    thanks.
    macbook pro 13 unibody, Mac OS X (10.5.7)
  • pheh Level 1 Level 1 (20 points)
    Experiencing this problem too. Random system stalls and occasional times where my video will suddenly just go to complete garbage (usually when working in iPhoto).

    I am also getting the occasional click/whir from the hard drive. The graphic gliches are rare and seem to occur most often when I am short on memory (4Gigs). But the beach balling stalls are becoming quite unbearable.
    Unibody 17" 2.88 (2.5), Mac OS X (10.5.8)
  • Ryeguy8585 Calculating status...
    I have the same problem. Every so often:
    Error enqueuing memory. (0xe00002e8) over and over again. Machine locks up with spinning beach ball for 5-10 seconds, over and over again until I reboot.

    Grumble Grumble.
    Alot, Mac OS X (10.6)
  • dlethe Calculating status...
    Same problem exactly like previous poster described. HOWEVER .. I sometimes get a lockup where the message does NOT appear. I am in warranty so will log a call. My system is latest generation 17" MBP. If more people log tech support calls who are within warranty then perhaps this will help.
    MBP 17" 2.8Mhz, Mac OS X (10.6.1)
  • Remizor Calculating status...
    I have the same problem. and i think it's related to safari. try to use other browser and it may help.
    MacBook pro, Mac OS X (10.5.6), 2.2Ghz
  • licyeus Calculating status...
    I, too, am encountering this issue. However, I'm running a fresh install of Snow Leopard and am not running Safari. Think the problem exists elsewhere.

    Hope they fix this soon. Quite frustrating.
    MBP 13" unibody (2.26ghz, mid-2009), Mac OS X (10.6.1)
  • Dane Jensen Calculating status...
    I have this as well under Snow Leopard on a 1.5 year old mbp.

    I've been able to faithfully recreate it by trying to mount a drive I have attached to my airport extreme.

    When I try to do that, Finder.app hangs and I see a process called "check_afp" appear in activity monitor and top. top lists its state as "stuck".

    -Dane
  • mattsday Calculating status...
    I am experiencing the same issue on a brand new MacBook Pro 13" (bought it today).

    The only thing I have done is to upgrade the HD to a 500gb Hitachi drive. However, this evening it kept locking up for 3-6 seconds and then resuming over and over again. I checked the syslog, saw the above error and googled it.

    For me, it was fixed by issuing:
    sudo killall hidd

    However, I know nothing about this command or what 'hidd' does! So perhaps it's not a good idea to kill it... but it does solve my issue.
    MacBook Pro 13inch, Mac OS X (10.6.1), MacBook Pro 13inch
  • mattsday Level 1 Level 1 (0 points)
    Update: Still getting the issue. This morning, even the above killall command didn't work and I was forced to reboot.

    Extended hardware test showed nothing wrong.

    The only thing that comes to mind is that I accepted the Bluetooth update via Software update earlier - could this be it? I'm tempted to format and see if I still get the error afterwards. Will update here if it is the case.

    Otherwise, I'm at a loss - I have AppleCare but I am very close to just returning this piece of garbage. As wonderful as the hardware is, if I can't work on it due to lockups and freezes then it's no good to me!
    MacBook Pro 13inch, Mac OS X (10.6.1), MacBook Pro 13inch
  • oschrenk Calculating status...
    I also have this problem. Fortunately it doesn't happen during normal use though.

    It does happen when I log off and try to switch to another use. First I get the ble screen with the indicator, after a while I get the normal login screen, which responds to no mouseclick or keyboard pinput. I do have to wait 10 minutes or so so that I can login again. As I often don't have that time, I'm forced to do a hard reboot.

    Very annoying, as I do switch the user at least twice every day.
    MacBookPro 4,1, Mac OS X (10.6.1)
  • oschrenk Level 1 Level 1 (0 points)
    This user here connects it to Bluetooth:
    https://gist.github.com/raw/101311/77e3a8d835acfe2a8bd5b580dad1df2cc4f1eaa0/gist file1.txt

    The process is very important for keyboard and mouse (explaining why clicks movement and keyboard input did't work). It stands for Human Interface Device Daemon.

    Here is another thread, no solutions though:
    http://discussions.apple.com/thread.jspa?threadID=1384823&start=15&tstart=0

    Message was edited by: oschrenk
    Mac Book Pro 4,1, Mac OS X (10.6.1)
  • oschrenk Level 1 Level 1 (0 points)
    Found an intersting hint from Don Hall:

    Several times a week the keyboard and trackpad on my wife's MacBook Pro (early 2008) suddenly stop working. From looking at the logs I believe this is caused by the Human Interface Devices daemon (hidd) failing. I see error messages like: "/usr/libexec/hidd IOHIDEventQueueEnqueue: Error enqueuing memory. " Curiously enough, I found that with screen sharing turned on I could control the cursor and enter keystrokes from another machine (and someone watching the MacBook Pro could see the cursor move). This at least allows an orderly restart to be made, after which keyboard and trackpad functionality are restored.

    Original source:
    http://www.macintouch.com/readerreports/leopard/topic4569.html

    Does anybody have a second mac and this problem on one of them and can confirm this?

    Message was edited by: oschrenk
    Mac Book Pro 4,1, Mac OS X (10.6.1)
1 ... 3 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.