Skip navigation
This discussion is archived

Quark files show as unix executable files.

5284 Views 6 Replies Latest reply: Nov 3, 2009 5:54 AM by shabos RSS
shabos Calculating status...
Currently Being Moderated
Aug 6, 2009 10:42 AM
I have a strange issue. This is an all mac enviornment. The iMac's are running 10.4.11, and Quark express 6.0 One of the iMac's show the quark files as unix executable files. All of the other mac's can open the files without any issue.

On the iMac that has an issue, some of the folders show up as unix executable files as well. Also, there is a network share that is a log in item that should auto mount when the user logs in, it no longer mounts automatically. The only way to mount the share is by navigating through finder.
I was able to open one of the quark files by using open, then save the file using save as. this appended the file extension. I also enabled file extensions in finder, and manually appended the extension and they still would not associate with Quark. The file I did a save as does associate with Quark but it is the only one.

I repaired disk permissions and that did not help. Anyone have any ideas on this one?
MacBook, Mac OS X (10.5.7)
  • Herr Lazaro Calculating status...
    Currently Being Moderated
    Aug 11, 2009 8:22 AM (in response to shabos)
    This is due to wrong data within the launch services database. In this database, the Finder keeps the mapping between file-types and applications.

    You should download a tool like MainMenu (http://creativebe.com/mainmenu/) or Xsupport (http://www.xsupport.ch) and use it to clean your local caches and databases.
    (In MainMenu: Rebuild->Rebuild Lauchservices
    in Xsupport: Maintenance -> Reset ->Reset File Types Settings)

    After cleaning you should be able to re-associate the Xpress file with the right application simply by opening the file with Xpress
    Mac SE/30 (A/UX 3.0)
  • Herr Lazaro Level 1 Level 1 (45 points)
    Currently Being Moderated
    Aug 12, 2009 12:36 AM (in response to shabos)
    I also couldn't find the download link for xsupport on the link you provided.

    Looks like they have changed their business model. I just copied the URL out of the aboutbox of my copy of the Xsuppport toll but didn't crosscheck it.

    Does that give any indication on what the problem is?

    Not really, perhaps a corrupted or unreadable (by permission) .DS_Store file in the folder where your Xpress files reside, but then again that should affect other clients as well.
    Which leads to the question:
    When some clients have the correct mapping document <-> Quark Xpress and one (or more) other(s) don't, do you connect with different users to the server or are the users always the samr but the connection made from different machines?
    If youuse different users to connect, then the problem very like is on the server side (addess rights, etc). If the same user has different results on different machines, the problem's most likely a local one. In which case you coud try all of ManiMenu's clean and deep clean actions.
    Mac SE/30 (A/UX 3.0)
  • Mabel O\'Farrell Level 3 Level 3 (975 points)
    Currently Being Moderated
    Aug 12, 2009 6:57 AM (in response to shabos)
    I tried using main menu to clear the launch services,


    The most likely problem with the workstation -since it seems to affect only this workstation- is a directory problem with the disk. Run DiskUtility.app on it to check the disk. If problems turn up that can't be fixed by DU, try something with more 'muscle' like DiskWarrior.

    I turned on file extensions in Finder and did not see a qxd extension on these files.


    Login as the affected user. Open QE, create a new file, save it and see that the dialog box isn't 'hiding' the extension. Instruct the user to add the proper extension to the filename.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.