8 Replies Latest reply: Aug 28, 2009 11:33 AM by Ralph Johns (UK)
FlintP Level 1 Level 1 (0 points)
Hi all,

I have been trying to get screen sharing to work for about 4 hours now with 2 different people helping me.

Video / Audio and Theater works perfectly. Skype screen sharing works perfectly as well.

I have done these things:

- Disabled the router firewall after trying to do a whole load of DHCP and static IP stuff which didn't do anything but take my internet access away.
- Enabled UPnP
- Disabled WAN Ping Blocking
- Enabled screen sharing in Sharing ( System preferences )
- Changed iChat port to 443 ( in iChat preferences )
- Changed iChat bandwidth limit to 500 kbps
- Changed quicktime streaming to 1.5Mbps T1/Internet/LAN
- Enabled the Mac firewall to specifically allow iChat

I have had no luck.

I have a Belkin Modem Router N F5D8236-4 http://catalog.belkin.com/IWCatProductPage.process?Product_Id=459569

10.5.8 and a 2008 iMac.

Please someone help I have tried everything that I can imagine or have been suggested to do

iMac8,1, Mac OS X (10.5.8)
  • 1. Re: iChat Screen sharing!
    Alan Ogata Level 2 Level 2 (475 points)
    Checkout #3 here.
  • 2. Re: iChat Screen sharing!
    FlintP Level 1 Level 1 (0 points)
    Yes I've tried all that.

    Screen sharing is also enabled in iChat under the Video tab. When I click to share my screen or to share their screen it looks like it will work ( I get a message which takes up the screen saying screen sharing something ) then it just says that it failed.

    The 2 people who I tried to screen share with both have their screen share working perfectly and have verified their end.
  • 3. Re: iChat Screen sharing!
    FlintP Level 1 Level 1 (0 points)
    Ok I managed to fix this by doing the following:

    - Put my iMac on DMZ
    - Installed 10.5.8 Combo update even though I already had 10.5.8.

    Thanks anyway people!
  • 4. Re: iChat Screen sharing!
    Ralph Johns (UK) Level 9 Level 9 (67,490 points)
    Was Port Forwarding turned Off ?



    4:35 PM Saturday; August 15, 2009

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • 5. Re: iChat Screen sharing!
    FlintP Level 1 Level 1 (0 points)
    Yep I had opened all the iChat ports.

    In my case it was under Firewall and called Virtual Server.
  • 6. Re: iChat Screen sharing!
    Ralph Johns (UK) Level 9 Level 9 (67,490 points)
    I should have asked when UPnP was tried.



    7:33 PM Saturday; August 15, 2009

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • 7. Re: iChat Screen sharing!
    Ryan Burkholder Level 1 Level 1 (130 points)
    I have this problem with the exact same router. You found a work around but the problems still exists. The router's firewall kills the screen sharing functionality. I can share just fine directly through the cable modem and my wireless broadband but not through the Belkin. If you're using DHCP, a DMZ rule is not an ideal workaround. For other reasons as well.
  • 8. Re: iChat Screen sharing!
    Ralph Johns (UK) Level 9 Level 9 (67,490 points)
    If this device has a separate Firewall in addition to how you have opened ports it will be best if it is Off.

    UPnP is the best method for doing the Screen Sharing if the device has it at the version of firmware yours has.

    This is because the Screen Sharing is on a random port. This means you can not Port Forward for it.

    If DMZ is not allowing it I would look to the actions of the Firewall.



    7:33 PM Friday; August 28, 2009

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"