Previous 1 40 41 42 43 44 Next 656 Replies Latest reply: Aug 30, 2009 9:30 PM by pdxmeghan Go to original post
  • Tim Mayville Level 1 Level 1 (10 points)
    Going to 10.5 will not help you. I've been experiencing the same issues and after recently getting our MacBook back from having the WiFi card replaced we are still having the same problems.

    Starting to lose faith here, Apple.
  • Brian Lee2 Level 1 Level 1 (0 points)
    I found this solution searching on Google:

    http://www.syzdekistan.com/2008/10/06/macbook-pro-wireless-problems-solved-updat e-2/

    This guy tried everything including replacing the router, reinstalling the OS, replacing the Airport Express card, deleting and reinstalling network connections, deleting plist files, etc. It turned out it was due to a broken antenna wire (located in the LCD display assembly). He reports no problems with his wireless networking since the antenna replacement (at least 3 months).
  • BwBAlb Level 1 Level 1 (0 points)
    Thanks for looking and trying to help - but this solution has nothing to do with the problem most of us are facing. This gentlemen was having fluctuations in the airport meter and such - the problem we're facing is different.

    The airport meter doesn't move - and the Mac thinks that it is online. It's almost like it's connected to the wireless router but someone has disconnected the internet cable from the router, thus Safari / Firefox / etc is trying to surf but there is no data.

    My "solution" (for lack of a better word) is to turn airport off and then right back on, it reconnects to my network for anywhere from one minute to several and then I have to do it all over again.

    Hardwired - works fine... it's the software - Apple really really really should try to fix this or at the very least release a patch that uninstalls the update that caused all these problems.

    PS - When running Ubuntu on my MacBook I have ZERO problems with staying online - and no it isn't Ubuntu causing my problems because that was installed months after the problem surfaced.
  • BwBAlb Level 1 Level 1 (0 points)
    I don't know what possessed me to do so but I have been playing with router settings over the past few days to see if maybe something would fix this problem and behold, one of those things did.

    I can't explain it but I'm guessing that whatever changed in the upgrade that made this go wrong caused Airport to get confused using anything except 802.11g

    I had my router on b/g and I was still having problems - so I switched it to just 802.11g and I've been connected solid for a full two days with zero problems.

    so yeah - I think the solution is to "work with what the Macbook wants" and change the router to only use 802.11g. If anyone else has luck with this, let me know!
  • croyde Level 1 Level 1 (0 points)
    By thee Gods man, you have got it. I have been searching the net for an answer to this problem for months.

    I switched my Router to G only and I have not had a dropout since.

    Buy that man a drink, Cheers.
  • BwBAlb Level 1 Level 1 (0 points)
    It's such a simple thing - and I can't believe that it was the problem but I'm still doing fine since I made the change.

    The only problem I've encountered was that my Wii wouldn't work on the router in "g" only mode, but I had an older router sitting around so I hooked that up as well and use that for the Wii to connect to the net - I just made sure that it isn't in my preferred networks for my Mac so it doesn't try to connect to the "wrong" router!

    Glad it worked for you! I'm always up for a drink - I host a morning show on WEQX in Albany NY and Friday mornings it's all about beer in a segment called Beer School. Cheers!
  • croyde Level 1 Level 1 (0 points)
    Might have to be a bit of a wait for that drink mate as it's over a 6000 mile round trip.

    Cheers anyway and spread the word, about this and the beer. Ta.
  • questionsall Level 1 Level 1 (0 points)
    I've had the same problem. What's particularly annoying is that my Macbook connects (and holds the connection) fine on my Vista partition. I'd just given up for a few months with Mac OS, but am feeling rather compelled to figure this out (plus, I have a bit of unscheduled free-time right now). I'm going to try shifting my base station to 'g only' and see if that helps. However, this won't help me when I'm out.
  • Fearghal Kelly Level 1 Level 1 (125 points)
    Been searching for a solution to this too. Couldn't face phoning apple even though I have applecare as I'm sure they'd just blame cordless phone/baby monitor/distance/blah blah blah.

    Just seen your possible solution and given it a try...fingers crossed!
  • paulbmurphy Level 1 Level 1 (15 points)
    just switched to G on router - so far so good. Been looking for a solution for this for three months. Thanks.
  • gbraad Level 1 Level 1 (0 points)
    Has been resolved in a later update by Apple.
  • pdxmeghan Level 1 Level 1 (0 points)
    So I want to try this "G" thing, but there's nothing on my router. How does someone do this?
Previous 1 40 41 42 43 44 Next