5 Replies Latest reply: Nov 8, 2007 1:01 AM by Core
Core Level 1 (15 points)
MacBook is only a week old with all of the updates applied, including 10.4.10.

MacBook will boot up connected to the home network and I can use Safari to surf the internet just fine. After a period of about 5-10 minutes, the MacBook will no longer browse the internet even though the singal meter shows that I am still connected to my home network with 4 bars full.

Checking my router with another computer, I can see that the MacBook is no longer connected to the router even though the MacBook claims that it is. For another test, I've checked my router as soon as I turn on the MacBook and the signal quality coming from the MacBook hovers around 65-70% even when I place the MacBook right next to the router. My other PCs get around 85% rooms away.

Turning off Airport and then reenabling it results in the MacBook no longer being able to detect any wireless networks at all even though there are usually around three at my location that I can detect using the survey feature of the DD-WRT firmware. These other networks use different channels, so interference seems unlikely.

Linksys WRT54GSv4 with DD-WRT v23 SP2
G Only
Channel 1

Got my first kernel panic a day or two ago:

Thu Jun 21 23:59:26 2007
panic(cpu 0 caller 0x001A4A55): Unresolved kernel trap (CPU 0, Type 14=page fault), registers:
CR0: 0x8001003b, CR2: 0xb2a20233, CR3: 0x01ef2000, CR4: 0x000006e0
EAX: 0xb2a20203, EBX: 0x00000003, ECX: 0x3fb8bbc0, EDX: 0x0d162f80
CR2: 0xb2a20233, EBP: 0x15103bf8, ESI: 0x3fb82f80, EDI: 0x1367d2c8
EFL: 0x00010202, EIP: 0x00a02974, CS: 0x00000008, DS: 0x00000010

Backtrace, Format - Frame : Return Address (4 potential args on stack)
0x151039b8 : 0x128d08 (0x3cc0a4 0x151039dc 0x131de5 0x0)
0x151039f8 : 0x1a4a55 (0x3d24b8 0x0 0xe 0x3d1cdc)
0x15103b08 : 0x19aeb4 (0x15103b20 0x26c52c00 0x1 0x1)
0x15103bf8 : 0x9dbcc2 (0x137ab004 0x3fb82f80 0xd162f80 0xb2a20203)
0x15103dd8 : 0x9de059 (0x1367d2c8 0x0 0xf3d1000 0x6)
0x15103f08 : 0x39b3c3 (0x1367d000 0x3bb3200 0x1 0x3722dfc)
0x15103f58 : 0x39a595 (0x3bb3200 0x135eb4 0x0 0x3722dfc)
0x15103f88 : 0x39a2cb (0x3bc0140 0x0 0x8000 0xf0b)
0x15103fc8 : 0x19ad2c (0x3bc0140 0x0 0x19e0b5 0x3725d74) Backtrace terminated-invalid frame pointer 0x0
Kernel loadable modules in backtrace (with dependencies):
dependency: com.apple.iokit.IONetworkingFamily(1.5.1)@0x7a9000
dependency: com.apple.iokit.IOPCIFamily(2.2)@0x584000
dependency: com.apple.iokit.IO80211Family(160.2)@0x7bf000

Kernel version:
Darwin Kernel Version 8.10.1: Wed May 23 16:33:00 PDT 2007; root:xnu-792.22.5~1/RELEASE_I386


I have tried reformatting and reinstalling Mac OS X several times, but this problem seems like it is hardware or related to the 10.4.10 update because the problem persists after reinstalls. I will test the connection with 10.4.9, without updating to see if the problem is software soon.

Being a Windows guy, any help from some Mac Pros would be greatly appreciated!

Mac mini   Mac OS X (10.4.6)  
  • iRandy Level 1 (25 points)
    The only thing I have found to fix the problem is to reboot the router. A big drag for others on the network for sure.

    Nobody here can even tell you why the Macbook believes it is connected but it isn't. Not even the Apple Store or calling customer support, in my experience with this issue.

    The Macbook sits there with all the lines but they mean nothing because in reality it isn't even connected to the wireless router.

    Make sure your router has the latest firmware.
  • canvasd Level 1 (0 points)
    I have the 10.4.10 issue (I think) and rebooting the router hasn't helped... have tried that several times.

    I look forward to hearing if your 10.4.9 setup works!
  • MacCheetah3 Level 1 (0 points)
    It's today's cheap / sh**ty routers. My USR5461 for all reasonable arguments never gives me problems -- it's so extremely rare. However, this Netgear that I'm now using is a big piece of worthless junk. I have to reset it at least once every two days. Of course, I've never thought extremely high of Netgear, Linksys, or D-Link but eh... Especially not Linksys. I haven't had a problem with Belkin either but much less experience with them. So, one never knows.

    The only reason I'm using the Netgear is because I've been having XBOX Live issues and it is supposedly XBL compatible. Now I figured out that it's just Gears of War that's horribly programmed on the network ( multiplayer ) side. It's the only game I've had problems with and each update has made it worse and worse for even others that I play with. So, I should just switch back to my reliable USR.
  • tele_player Level 5 (5,380 points)
    Even if the routers are 'cheap / sh**ty', that's no excuse for the Mac to crash.

    For what it's worth, I've got a Linksys WRTSL54GS and WRT54GL here, both running OpenWrt, and they're working quite well with MacBook, MacBook Pro, PowerBook and Quad G5. Even with a 3 year old D-Link 624, I never had kernel panics in the Mac's airport kernel extension. I picked up the Linksys boxes a couple months ago, wanting the flexibility of Linux-based routers, and I'm pretty impressed with how well they're working.

    Quad G5, PB 15" 1.5Ghz,MacBook 2.0GhzCore2Duo   Mac OS X (10.4.8)   MacBookPro 2.33Ghz C2Duo/120G/2G RAM, Logic Pro 7.2.3, Focusrite Saffire...
  • Core Level 1 (15 points)
    Driver problem fixed with update.