Skip navigation
This discussion is archived

Slow internet connection via Airport Extreme

7481 Views 20 Replies Latest reply: Nov 23, 2007 3:15 PM by anotherDesiredAlias RSS
1 2 Previous Next
tlwyse Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 24, 2007 9:00 AM
This one's kicking me in the butt.

I've been troubleshooting a very slow internet connection issue and it has me stumped.

The players:
RoadRunner cable modem Toshiba PCX1000 (5 Mbps)
Airport Extreme base station

The symptoms:
Internet connection speed is <100 Kbps when connected via Airport Extreme (both wired and wireless). Speed checked using <a class="jive-link-external-small" href="http://">http://www.speedtest.net/

When I connect my MacBook Pro direct to cable modem, speed jumps to >4 Mbps.

This unit (Extreme base station) has worked for several months with no issues and nothing has changed recently AFAIK. Just in the last few days has this problem reared it's head.

Things I've tried:
* Updated firmware to 7.1.1. No improvement.
* Connected to base station both wired and wireless, no improvement.
* Since I had another Airport Extreme still in the box, I opened it, set it up and configured it similarly (nothing fancy, just an IP range that I've always used and gave the base station a new name). The new out-of-the-box unit performed similarly to the original unit which is to say SLOW.
* All computers on the network show the same issue but for testing, I shut the others down and used just my MacBook Pro.
* Connected DIRECT to the cable modem and get blazing speed.
* Pulled out an old Linksys Wireless-G that I'd been using prior to the Airport Extreme and I get BLAZING SPEED with that router.

Call me "out of ideas"

Later,
Terry
15" MacBook Pro, Mac OS X (10.4.10)
  • volavar Calculating status...
    Currently Being Moderated
    Jun 26, 2007 6:58 AM (in response to tlwyse)
    I am experiencing the same problem. I use a dual band configuration with two Airports ( "g" and "n" versions ). Firmware for the "n" device is 7.1.1

    Everything is working OK ( printer and attached hard disk ) but the connection speed is 40%, as compared to the wired connection via direct ethernet cable to the modem ( PPoE )

    volavar
    MacBook, Mac OS X (10.4.10)
  • Eric Jefferson Calculating status...
    Currently Being Moderated
    Jun 26, 2007 7:17 AM (in response to tlwyse)
    Also using a Toshiba though i have the PCX1100U model and I'm seeing much the same as you. A noticeable decrease in speed when connected wirelessly to the AEBS via 5ghz 802.11/n. When connected directly to my Linksys WRT54g router the speed increase is quite obvious as all internet activity is quite responsive, web pages load in a snap! Can't figure out what's causing the slowdown with the AEBS but somethings is just not right.
    MBP C2D 2.33Ghz, Mac OS X (10.4.9)
  • Eric Anderson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 26, 2007 9:44 PM (in response to tlwyse)
    I've scoped these forums for two hours now and this is the closest post I can find to match my issue. I am adding another wrinkle to this discussion though.

    I've been using my airport express router without issue for about 9 months. I have an Imac G3, an Imac G4 and up until early this week, an ibook G4 all connected to the internet via airport. I recently upgraded my laptop to the brand-spanking new black macbook with all the toys. Unfortunately, my internet connection via Wildblue satillite has been spotty at best, useless, at worst.

    Both the Imacs still connect solidly to the internet via the airport, but the macbook is ridiculously slow. Dial-up is faster. However, when I connect directly to the modem, the speeds are as fast as wildblue promises (100-150 KBps). I have spent hours on the phone with wildblue help and it hasn't.

    Here's the wrinkle though: Download speeds are as fast as I'm allowed to download based on my package (consistently 130-160 KBps). Surfing to sites however, many times I get an error message that my browser cannot find the specified server (apple, yahoo, etc.) I believe it is because the connection is so slow, the browser gives up. I have been switching between Safari and Firefox to see if one is outperforming the other. They are both equally slow.

    I can't remember an upgrade from apple that didn't perform better than the old one, but unfortunately, this is one of them.

    Help. I hate to give up on a machine that I longed for for so long.
    Thanks
    imac G3 500 10.3.9, ibook g4 1.33 10.3.9, Mac OS X (10.3.9)
  • Jakobjv1975 Calculating status...
    Currently Being Moderated
    Aug 28, 2007 3:34 AM (in response to tlwyse)
    Hi everyone

    I experienced the same thing. Found this solution: (Here is the link as well: http://www.macfixitforums.com/showthreaded.php?Cat=&Board=tiger&Number=745717&pa ge=0&view=collapsed&sb=5&o=31&vc=1)

    Added 4.2.2.1 and 4.2.2.2 to the "optional" DNS Servers box (and changed nothing else) and it was instantaneous. Blazing fast internet speed once again.

    System Preferences -> Network -> Click the 'Configure' button -> Click the TCP/IP tab -> Type 4.2.2.1 into the blank DNS Servers box, hit return and type 4.2.2.2 then click the 'Apply Now' button -> Happily surf the net once again

    It worked somewhat for me though I don't think I'm fully up to speed. Maybe some of my browser settings are slowing things down?

    Let me know if the fix works out for you - maybe you can help me with the settings

    Best

    Jakob
    MacBook Pro 2.4, Mac OS X (10.4.10), Still hold on to my old Titanium as well :)
  • Eric Anderson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 28, 2007 5:17 AM (in response to Jakobjv1975)
    Thanks for the link, Jakob.

    I tried it this morning and you're right on both accounts.

    1. It did speed things up greatly.
    2. I don't think I'm getting the speed I should be.

    I took my macbook to my dad's lynksis router on a cable connection and THAT was blazing fast. So I've determined that there is nothing wrong with the macbook. It must be on my Airport express.

    peace.
    e
    imac G3 500 10.3.9, ibook g4 1.33 10.3.9, Mac OS X (10.3.9)
  • Eric Anderson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 28, 2007 2:46 PM (in response to Eric Anderson)
    I think I spoke too soon. The speed boost I saw this morning was an anomaly.

    Back to where I started.

    e
    imac G3 500 10.3.9, ibook g4 1.33 10.3.9, Mac OS X (10.3.9)
  • Jakobjv1975 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2007 4:57 AM (in response to Eric Anderson)
    Hi Again

    Now I'm almost a happy camper. I can stream Youtube movies right away and surf the net at the same speed as on my Titanium. After solving the problem I have experienced extreme fast connection while surfing but the blaze speed don't last. But normal works for me as long as it don't mean SLOW.

    Heres what I did.

    a) Re-installed OS X (and saved previous system) with the dvd's that came with MacBook Pro. Problem remained!

    b) I changed the DNS settings as mentioned in this thread to 4.2.2.1 and 4.2.2.2 - nothing happened.

    c) Then I tried resetting the PRAM by restarting and holding down AltCommand+RP while booting and waited for another restart sound. No improvement. I even tried removing all cables including power, removing battery and holding down start button for 5 sec, inserting the battery, connecting power and restarted. Nothing!

    In case you are wondering why I mention all my failures the answer is that I can't say for sure it was alone the last thing that did the trick. But here it is. Finally


    1) I shut down my mac.
    2) Shut down my wireless Netgear 814Mr router by unplugging EVERY cable.
    3) Waited 1 minute!!!
    4) Plugged power cable
    5) Held down the little reset-button on the back for 20-30 secs using a pen.
    6) Plugged my network cable from wall socket to router. (And actually also a cable from wireless router to mac)
    7) Waited a minute!!!
    8) Booted MacBook Pro and selected the "new" network (renamed to default NETGEAR in my case)
    9) Opened Firefox which automatically launched page routerlogin.net to setup my wireless connection. I did nothing other than let the Wizard do the work. Just pressing OK.
    10) In Preferences I launched Network (where I always use Location: Automatic), pulled down the SHOW menu and selected Airport and then TCP/IP. In the optional DNS Servers field I wrote 4.2.2.1 (pushed enter) and wrote 4.2.2.2. Closed it.
    11) Reopened Firefox and had a party for the first few minutes until normality sat in. But I am now able to surf, download torrent with Transmission and watch Youtube movies without delay - all at the same time.

    I know it was a long message but at least I hope some of you get it solved with same magic/luck touch I used.

    good luck to you all

    Best

    Jakob
    MacBook Pro 2.4, Mac OS X (10.4.10), Still hold on to my old Titanium as well :)
  • dpedini Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2007 5:09 AM (in response to tlwyse)
    I'm having the same issues when I by pass the airport I get 9.5MB down 930K up when I plug in teh airport and go through the airport I get about 520K down and 940K up I'm loosing 9mb... this happen on Aug 8th I'm trying to see if there was some sort of upgrade that caused this.

    I ruun speedtest.net all the time and see the time when it happed now I need to know why this is slowing me down...

    Its both my mac's and the PC's

    DP
    MacMini, Mac OS X (10.4.10)
  • dpedini Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2007 5:17 AM (in response to dpedini)
    As you can see there is a marked difference. is there a firewall in the airport that is turned on by default or some type of NAT that is not working... any help will be great.

    8/29/2007 6:11 AM CDT 743 kb/s 954 kb/s 78 ms Dallas, TX ~
    8/29/2007 6:09 AM CDT 485 kb/s 950 kb/s 18 ms Dallas, TX ~
    8/9/2007 12:16 AM CDT 587 kb/s 960 kb/s 13 ms Dallas, TX ~
    8/8/2007 11:58 PM CDT 232 kb/s 907 kb/s 118 ms Denver, CO ~
    8/8/2007 11:57 PM CDT 519 kb/s 925 kb/s 13 ms Dallas, TX ~
    8/8/2007 11:56 PM CDT 498 kb/s 952 kb/s 14 ms Dallas, TX ~
    8/8/2007 11:36 PM CDT 9633 kb/s 957 kb/s 32 ms Dallas, TX ~
    8/8/2007 11:27 PM CDT 9753 kb/s 958 kb/s 58 ms Dallas, TX ~
    MacMini, Mac OS X (10.4.10)
  • Eric Anderson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 29, 2007 5:43 AM (in response to tlwyse)
    Hi again,

    After some searching yesterday, I found the dns servers for Wildblue. entered them in the tcp/ip window on the macbook and viola! speed. It is still fussy in the fact that there are periods of complete nothing, but they are much fewer and for shorter periods of time. I just can't believe that this isp doesn't install these dns numbers when you install their optimizer.

    I calling this good, as I only have another three weeks of this service until cable comes, but I do plan on routing the macbook wirelessly with the cable too, so I may be back!

    e
    imac G3 500 10.3.9, ibook g4 1.33 10.3.9, Mac OS X (10.3.9)
  • Jakobjv1975 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2007 6:07 AM (in response to Eric Anderson)
    Just for the record - I have experienced no difference between wireless and cable on this stinky matter. Before none of them worked - now they both do.
    On speedtest.net I got about 750 download speed then and now it is 8000. Upload speed was actually pretty high before and has maintained the 5000 kb/s.

    But the connection seem to work faster for continuous downloads/streaming 'cause the usual surfing around is a bit under normal I'd say. But not complaining

    Jakob
    MacBook Pro 2.4, Mac OS X (10.4.10), Still hold on to my old Titanium as well :)
  • sprintracer Calculating status...
    Currently Being Moderated
    Aug 29, 2007 10:35 AM (in response to Jakobjv1975)
    I hooked up my new APEBS on Monday. I'm having the same problem with slow internet speeds through Comcast. But, the LAN speeds seem to be okay. According to speedtest.net my results were about 9,500 to 13,200 kbps download and only 48 to 55 kbps upload.

    I have a MacBook Pro (Core 2 Duo), a Dell machine running XP,an HP C6180 AIO printer and a ReadyNas+ NAS. The XP machine, ReadyNAS, and HP printer are all wired to the three LAN ports on the APEBS. The only wireless client is the MacBook Pro. This is the exact same setup that I had with my previous router which was a Xyzel 802.11G MIMO. The cable modem is a Motorola Surfboard SB5120. The Xyzel was much faster than the APEBS for surfing (so far), but I can definitely tell a difference in speed across the LAN to the ReadyNAS and Printer using the APEBS.

    I use MAC filtering, WPA2, static Ip addresses for all the items on the LAN using DCHP, broadcasting turned off.

    I've been following along with this posting and I tried rebooting everything several times. I tried the DNS 4.2.2.1 thing which didn't help. I've checked software update to make sure everything is upto date.
    MacBook Pro, Mac OS X (10.4.10)
  • dpedini Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2007 11:05 AM (in response to sprintracer)
    Now the airport that I have is the new one with the GB ports. my old one with the 10/100 port was just fine..

    do all of you also have the new GB port versions? this is when my problem started I need to get a 10/100 verions and see if this goes away.. when I put my linksys or go diretly to the cable modem no problems it gets 9.5MB DN / 1MB up

    any feed back would be great

    DP
    MacMini, Mac OS X (10.4.10)
  • dpedini Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 30, 2007 8:32 PM (in response to tlwyse)
    Well I fixed the problem.. and was able to verify it

    8/30/2007 10:18 PM CDT 480 kb/s 951 kb/s 15 ms Set back to 100 Duplex
    8/30/2007 10:16 PM CDT 9767 kb/s 961 kb/s 18 ms Set to Auto
    8/30/2007 10:13 PM CDT 513 kb/s 952 kb/s 13 ms Set to 100MB Duplex

    as you can see 513kb/s with wan set to 100MB full Duplex then 9.7MB when set to auto, then back down to 480kb/s when set back to 100mb duplex

    what I did was go in to the airport utiliy setup. Then click the Internet icon ( the one between the Airport and Printers) there is a setting for Ethernet WAN Port set that to Automatic (Default) I had mind set to 100MB full Duplex.. eventhough the motororla cable modem has a 10/100 port on it i guess thte airport did not like me to set the speed set it to default and Boom its back to light speed. I hope this helps some one eles wiht this same problem. I would say this is solved.

    Thanks
    Dennis
    MacMini, Mac OS X (10.4.10)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.