Previous 1 2 3 4 Next 52 Replies Latest reply: Jul 14, 2007 7:54 PM by Gary Learned
Jay Contonio Level 1 Level 1 (5 points)
Why is it that when I send an email on my iPhone using my gmail account, that I get the same email I sent in my inbox? Only on the iPhone does this happen. On the gmail website I dont see this problem.

Macbook Pro, Mac OS X (10.4.10)
  • smithp Level 1 Level 1 (0 points)
    I have the same problem. If anyone finds anything else about this, let me know too. Thanks!
  • yellow pikmin Level 1 Level 1 (0 points)
    i'm having the exact same problem too!
  • Jay Contonio Level 1 Level 1 (5 points)
    This is very annoying since I mostly send mail on my phone and rarely check it. I might have to not use gmail for this.
  • AdamTheDog Level 2 Level 2 (230 points)
    This happens due to the way Gmail handles threads. When I had my Blackberry, it did the same thing. Apple will have to release an update to Mail that handles filtering emails from your own email address.

    MY Gmail problem is just as frustrating. Despite my settings that tell Gmail to POP download ONLY messages received after this point, the iPhone downloads ALL my mail...from the "All Mail" folder... That's a lot of mail, and I don't want it to happen that way.
  • Jay Contonio Level 1 Level 1 (5 points)
    That happened to me too. Not ALL my mail, but like 70 of the last ones...mostly email that I HAD SENT!

    So I went through and manually deleted from the iphone and I'm all good now. Just don't want my sent mail showing up in my inbox. DUH Apple...didn't you test this?
  • mudskip Level 1 Level 1 (5 points)
    Yes this is an issue i am seeing as well.
    Basically all new messages will be seen in your iPhone inbox for GMail...
    this includes
    *sent messages
    *messages that are filtered out of the GMail inbox

    This is really annoying, because i subscribe to some of those heavy volume email discussion groups that i keep out of my inbox with filters in GMail... but on the iPhone.. i see them all.

    If this was mac or PC, i would suggest using the excellent freePOPs program as a go between.
    http://www.freepops.org/en/

    for more email on the GMail FreePOPs module:
    http://www.freepops.org/en/viewplugin.php?plugin=gmail


    I suggest Mac engineers take a look at the GMail features for freePOPs and duplicate them in the iPhone Mail app, or just check out my list below...

    these are changes that really need to be made to make the iPhone mail experience a good one for GMail users

    *archive messages in gmail when they are deleted on iPhone [perhaps even change "Delete" text to "Archive" for GMail

    *ability to only download mail that is in the GMail inbox

    *ability to only download mail that is labeled with a specific label

    *if you are looking at only a specific GMail label, the option to choose from Delete, Archive, or Remove Label [instead of just Delete]. This would be a setting that could be set for that particular mail account.
    So if i have a Friends&Fam label, and i have that label set to sync as a Mail account on iPhone, i could set it to when i swipe my finger across to delete, a box comes up that says "Remove Label". This deletes the message from the iPhone, and removes the label on gmail

    *when a message is read on iPhone, GMail's copy of the message should be changed to reflect it


    ---
    While I would love to see these things addressed... i think in the meantime, I'm going to set up a new mail account somewhere. I will use it only for iPhone, and set gmail to forward certain messages to that iPhone address. Disadvantage here is, you have to archive or whatever those same messages once you log in to GMail.... hmm.

    MacBook Mac OS X (10.4.10)
  • Mike Ostman Level 1 Level 1 (25 points)
    Until Apple updates the Mail program on the iPhone to support filtering. This is going to be a problem.

    There is one way around it - but its not so desirable - Add a "Filter" to your gmail account. Indicate that emails sent from your gmail address should have an action of "Delete". This will surely stop them from showing up on your iPhone - but you will lose the ability to go back and look at the emails you sent.

    -Mike
  • Jay Contonio Level 1 Level 1 (5 points)
    BOOOOOOOOO

    Apple FIX THIS!
  • Mike Ostman Level 1 Level 1 (25 points)
    btw - I have this same issue with my IMAP connection to my exchange server. Messages I send from SMTP to the exchange server show up as unread in my IMAP inbox. 100 percent terrible. And thats one I'm not sure how to solve.
  • cramerphoto Level 1 Level 1 (0 points)
    just wanted to add my two cents. i'm having the exact same problem. pretty annoying.

    apple, please fix this.
  • Sleep doc Level 1 Level 1 (0 points)
    I had the same problem and tried this -- it solved the problem. I agree, it would be nice to be able to keep outgoing emails, but most internet based email systems don't store sent messages longer than a few weeks anyway.
  • Patrick Ng Level 1 Level 1 (0 points)
    I created a yahoo mail account and am forwarding my google mail there. It works great, especially with the push feature. I also set my gmail address as the reply-to address in the yahoo settings. I figure this is the best way until Apple offers full Gmail push email support
  • Ankush Narula Level 1 Level 1 (65 points)
    Yes - my Blackberry does the same thing also. Personally - I don't see a problem with this functionality.

    When you're logged into the GMail interface, GMail automatically saves your outbound messages in the Sent folder. When you receive subsequent replies, they arrive in the Inbox and there is an automatic conversation thread presented in the Inbox.

    When using POP3/SMTP - how is GMail supposed to present a threaded conversation if your outbound messages did not originate from the GMail user interface? My guess is that the GMail SMTP server automatically sends a copy of all outbound messages to the originating GMail account. This might be a way of guaranteeing that all mail conversations will be threaded with all inbound and outbound messages in that thread.

    I don't have my iPhone in front of me, but I think you can disable this function from the iPhone under Settings > Mail > youraccount@gmail.com
  • sobiloff Level 1 Level 1 (0 points)
    It looks like setting up a filter on Gmail to delete all messages from yourself is the best way to go at this time. It's working well for me so far.
Previous 1 2 3 4 Next