Previous 1 2 3 4 Next 52 Replies Latest reply: Jul 14, 2007 7:54 PM by Gary Learned Go to original post
  • AymR Level 2 Level 2 (360 points)
    Forgive me for asking the obvious, but did you turn off the "Always CC Myself" function in Settings > Mail (at the bottom of the screen) on the iPhone?

    I'm getting duplicates of everything I send to my POP account, but it's intentional because I have this setting checked.

    I don't have GMAIL, so if there's something unique to that I apologize.

    Aym
  • Carl James Level 1 Level 1 (10 points)
    I am getting this too, It is so annoying. I already know what I said in my sent message, I do not have to read it again.
  • MiguelYanez Level 1 Level 1 (20 points)
    It is NOT an iPhone flaw... it's GMAIL, that is its default behaviour for pop connections, I agree, it's a little annoying but DO NOT blame the iPhone for it, it is GMail...

    It happens to me too using Mail.app on my Mac.
  • Black Belt Level 1 Level 1 (90 points)
    It is normal behavior for GMAIL POP mail. I use Outlook and it works that way.
  • cderalow Level 2 Level 2 (290 points)
    This is indeed a feature of gmail.

    For instance, if you use outlook or mail to check your email regularly. Login to Gmail though an internet browser, and send an email to someone. Watch your sent email showup in your inbox seconds later in outlook/mail.

    This is the reason I set my default email send account to my .mac account, regardless of the messages origin.

    MacBook Pro   Mac OS X (10.4.8)  
  • Jeremy.k Level 1 Level 1 (5 points)
    This is the same way I found to fix the GMail issues. Nothing changes for people sending you mail, and if you set Gmail to leave forwarded messages in your Inbox, your desktop mail client will download them normally using POP.
  • pberk Level 2 Level 2 (285 points)
    Because the DEFAULT setting is to CC yourself on every email you send from the iPhone!

    From the user manual:

    "Set whether iPhone sends you a copy of every message you send
    m From the Home screen choose Settings > Mail, then turn Always Cc Myself on or off. "
  • Jay Contonio Level 1 Level 1 (5 points)
    No. Obviously you haven't read any of the prior posts. This is not why this is happening. It's gmail's thread issue. Hopefully Apple will adjust or Google can add imap or something.
  • R J S Level 1 Level 1 (70 points)
    hiya, i fixed this problem on my iphone by setting the "Use Recent Mode" to OFF in the advanced preferences of the email settings. I also have gmail set to archive when removed from inbox set in the gmail.com settings (though i don't know if this makes a difference). i have tested this with two accounts and it fixes both accounts.

    regards
    ross
  • setec Level 1 Level 1 (30 points)
    I had the same thing where it was always filling my inbox.

    I deleted the built in Gmail account on the iphone. Then I made sure that pop3 access in my gmail account (via your PC or Mac browser) was turned off, then back on for email from this date forward.

    Then I added the my Gmail account manually. When adding an account on the iPhone, use OTHER, then POP

    Name: Your name:
    Address: username@gmail.com
    Description: whatever you want

    Incoming Mail Server
    Host name: pop.gmail.com
    User Name: username@gmail.com
    Password: password

    Outgoing Mail Server (SMTP)

    Host Name: smtp.gmail.com
    User Name: username@gmail.com
    Password: password

    Now it doesn't auto fill my inbox and I can delete messages out of the inbox fine.

    I still have the SENT mail issue, but that is a Gmail issue.
  • R J S Level 1 Level 1 (70 points)
    nevermind, it looked like it was working. but it started happening again...so i guess i suck...
  • sgrizzle Level 1 Level 1 (60 points)
    Turning off "use recent mode" fixed the problem for me.
  • Scott Shuchart Level 1 Level 1 (130 points)
    It seems that Recent Mode is working intermittently - some hours I get sent-mail copies, some hours I don't. Other two people I know with iPhones are having the exact same experience.
  • Scott Shuchart Level 1 Level 1 (130 points)
    It seems that Recent Mode is working intermittently - with recent mode turned off, some hours I get sent-mail copies, some hours I don't. Other two people I know with iPhones are having the exact same experience.
  • bodhiness Level 1 Level 1 (10 points)
    Here's what I did to fix mine -- so far!!

    I may have found a fix...

    Go to GMail ON YOUR COMPUTER.

    Go the settings (for mail).
    Go to Forwarding/Pop
    Disable forwarding
    Enable POP for mail that arrives from now on
    When messages are accessed with Pop select one of the following:
    archive Gmail's copy OR
    delete Gmail's copy

    (if you mark leave it in the in-box, it will keep returning)

    The archive Gmail's copy creates a new archive that is :iphone which is different from my IPhone folder label of the same name. So far none of my saved messages (in the other folders have been lost).

    Try it!!

    A very techie newbie!!!!