3 Replies Latest reply: Jul 1, 2007 9:31 AM by Jose M
J. Charles Holt1 Level 1 Level 1 (140 points)
I have a LinkSys router and at first, I was able to login to my network and use my WiFi just fin with my iPhone. But then it switched to EDGE and I have been unable to get back onto it, although I can use any network which is unsecured.

I tried everything I've seen offered as solutions with no luck: Resetting the router. Changing the password setting on the iPhone to ASCII/HEX. Turning WiFi on the phone off and on again. The only thing I haven't tried is a software restore on the iPhone, but most people seem to acknowledge that this hasn't fixed their problem.

Do I need a trip to the Genius Bar?

G5 1.6 GHz, Mac OS X (10.4)
  • nautical Level 1 Level 1 (10 points)
    i am having the same issue! the iphone shows that it connects, but never pulls an IP from the router. i've taken all the same steps you have.
    i may end up calling apple, since the nearest store is over an hour away. if you stop in and find a fix, can you please post it?
  • nautical Level 1 Level 1 (10 points)
    quick update: upon reading some other posts in this forum, i found a solution for the problem i was having.
    if your network is WEP secured AND your password is 10 characters, you can change the network security to HEX/ASCII in the iphone network settings, then place a $ in front of your password.
    it worked for me and several others on this board
  • Jose M Level 4 Level 4 (1,010 points)
    When you go into Settings, then to Wi-fi. Does your network show up?
    1. If your home secured network shows up in wifi menu then select that network and it should prompt for password.
    2. If it shows up and you are running off A DHCP network, try clicking Renew Lease.

    Also What Security protocol are you using on your wireless router?

    If that does not work for you can also try going into Settings, click on General, Click on Reset, then reset network settings. then try setting up again. (Would only recommend this if you have not tried already.)