14 Replies Latest reply: Jul 6, 2007 3:22 PM by ArchEnemy75
Netgear Rouetr - same issue Level 1 (0 points)
Any ideas why and potential fixes? I has to put a "$" sign in front of my WEP password to get my MAC to logon to the network, so I'm sure there is some trick I'm missing.


G5, iPhone
  • Netgear Rouetr - same issue Level 1 (0 points)
    Posted: Jul 1, 2007 7:38 PM

    I copied this from another post and this worked for me.

    After speaking with specialist and getting password protected Wi-Fi to work:

    1. Since my 10 digit WEP code only has numbers 0-9 and letters A-F, the iPhone sees it as a HEX code, not a standard WEP code. Thus, when entering it in the iPhone, you must go to the ASCII/HEX option, and put the $ symbol in, which tells it that your WEP key is really a HEX key.

    You can access the HEX input option under seurity.

    So, when joining networks in the future that are locked, 10 digit, and only numerals 0-9 and letter a-f, you can choose HEX and add the $ sign. (Some people report this working without adding the $ sign).

    2. If you appear to be connected with a signal after entering your passcode, but still cannot access the internet, you go back to Wi-Fi options and tell the iPhone to "Forget this Network". Then you re-access it and start the input over.

    3. Longer passwords or passwords with strange characters should be tried under both WEP and ASCII/HEX. Again, before each try, choose "Forget this Network" and start over.

    4. A good test to make sure that your iPhone really does work on your home internet is to go into your router and turn your passcode off. Then, on the iPhone, choose "Forget this Network", and start over. iPhone will fly and you'll see it work (unless your phone is defective - and this is not likely.) If you don't know how to do this, (turn off router password) call your service provider. They will walk you through it, and it is really easy to do (maybe 4 steps... you just need the providers name and password and you access the option on menu... very simple. It is also simple to turn it back on when done with your test).

    5. Once you know your iPhone works, you can play around with the different passcode options if you want to keep the network password protected. Again, remember the "Forget this Network" option between each try. Otherwise, you will appear connected with signal strength but really won't be able to access the internet.


    A. A Fios network specialist told me that the more encryption you have, the longer the internet takes - on everything: computers, devices, etc. 8 or 13 digits are ideal, and more than enough protection. And your internet will be faster.

    B. All this password confusion should be standardized, but different providers choose different formats, hence the confusion. Although iPhone is very capable and is advanced technology, they could only support so many formats, hence our need to do some "tweaking" for unconventional formats. Eventually these providers should standardize in the future. (Same problems can exist for people connecting Wii's and PS3's wirelessly to protected home networks. Standardization would fix this).

    C. Although my iPhone is working quickly and effortlessly now on my home Wi-Fi network, it did go a little faster when the WEP was turned off on the router (and so did my laptop), so I guess the network guy was right.

    D. You don't need to "Restore Your iPhone" in iTunes to get this all to work. Although some people have mentioned that a "soft reset" of iPhone has helped. To do this, hold down the button on the top of iPhone while you hold down the "Home" button.

    E. If your iPhone works in open networks, or at home with your passcode off in the router, then your iPhone works fine on Wi-Fi. If the above solution does not work for you at home with WEP security turned on in your router, then the problem is an encryption one. Your options are to keep your home network passcode off, or to call your service provider and try different types of passcode encryption until you find the right one.

    F. If you bought your own router and are not leasing it from your network provider, you can visit their website and try updating the firmware on your router or seeing what other options are available for passcode encryption and try those.

    G. If you have MAC Authorization or Identification enabled in your router settings, you will need to manually enter your iPhone's MAC address into your router settings. This address can be found on the iPhone's "About" Menu option, under "Settings". This type of layer of security is really unneccessary and pain. Most people do not have it enabled, but if you do, entering the iPhone's MAC address enable you to get on. (But I suggest you turn this off if it is on.)
  • Rraggedy Level 1 (0 points)
    **** it all to ****!!!!!

    This is Apple!!! It's supposed to be easy! If wanted to learn computer crap, I woulda majored in Computer science not cinema production!

    BTW, can you tell none of these solutions worked for me?
  • ccesalias Level 1 (0 points)
    I have a Netgear Wireless Router also, tried all the above suggestions. The iPhone finds my network and indicates whether or not a password is required (I've tried both ways) but nothing. And I've done a soft reset between different attempts. Nothing seems to work.

    My ISP uses automatic DNS assignments so I'm not able to identify what that would be.
  • Netgear Rouetr - same issue Level 1 (0 points)
    This is what I did and it worked...

    In your iPhone go to the WEP or ASCII/HEX option. Click on the ASCII/HEX option. Now put the dollar $ symbol in and the your password.

    Let me know if that works for you.

    Take care
  • ccesalias Level 1 (0 points)
    No that didn't work... I've been trouble shooting & reading other's ideas... First I've been doing a "soft reset" with each iteration. Then I read that someone suspected the iPhone's MAC address to be faulty. I had already disabled the WEP 48 bit encryption so I turned "Wireless Card Access Encryption" off also, reset the phone again and got a connection for the FIRST time.

    Knowing that I could get a WI-FI connection, I turned off the phone, added the WEP 48 bit encryption back in the Netgear set-up... reset the phone, turned it back on. I tried the $ in the ASCII/HEX option but it didn't work so I kept the ASCII/HEX option, re-entered the pass key without the $ (can't remember if I reset the phone this time). I got a good connection for the SECOND time and have my closed network back too.

    FYI, I do notice that the signal is weaker than my laptop's and it does revert to EDGE at times.

    Hope this helps!
  • mposh123 Level 1 (0 points)
    if nothing works, but you have an ip address, it could be due to DNS issues:

  • ccesalias Level 1 (0 points)
    As I said in my last post... this is how I got my iPhone to establish a Wi-Fi connection. That was 6 hours ago & I continue to be online.

    BTW, the MAC address of the device is fine. I just couldn't get a Wi-Fi connection with the "Wireless Card Access Encryption" enabled in my Netgear set-up.

    All is well. Love the iPhone!!
  • ccesalias Level 1 (0 points)
    have you made any progress?
  • Black Belt Level 1 (90 points)
    WEP is an insecure encryption. It can be cracked in a minute, literally. You really want to use WPA.
  • ccesalias Level 1 (0 points)
    Is that also true of the 48 bit encryption option of WEP?
  • AymR Level 2 (360 points)
    Have you checked that your 802.11n router is set up to work with 802.11g wireless? Unfortunately, the iPhone only supports 802.11b/g.

  • ccesalias Level 1 (0 points)
    Is that also true of the 48 bit encryption option of WEP?

    Were you able to configure the Netgear router with the MAC iPhone adress added to the setup for restricting wireless access?

    I couldn't get that set-up to work.

    I don't have an 802.11n capable router.
  • Matthew Collorafice Level 1 (5 points)
    Does anyone knoe the DNS for roadrunner Los Angeles?
  • ArchEnemy75 Level 1 (0 points)
    Any ideas why and potential fixes? I has to put a
    "$" sign in front of my WEP password to get my MAC to
    logon to the network, so I'm sure there is some trick
    I'm missing.



    Try this…. Click on your Settings icon, then click on the Wi-Fi icon, then click the blue circle for the network you want to enter your WEP key for, then click on the “WEP Password” in the security window, then switch it to WEP hex or ASCII. You should sync right up.

    Basic recap, change the login from “WEP Password” to “WEP hex or ASCII”.