11 Replies Latest reply: Jul 6, 2007 3:29 PM by AymR
victo019 Level 1 Level 1 (0 points)
My iphone does not show my network at all, but it shows all of my neighbors networks. My laptop works fine on the network. I have a D-Link wireless router. I was wondering if someone could help me with this or point me in the right direction? I am pretty computer literate, but this network stuff is kicking my butt. Any help would be greatly appreciated. Thanks in advance.

Gateway, Windows XP
  • AymR Level 2 Level 2 (360 points)
    A couple things to check:

    Is your router a/g compatible (as opposed to just n). If not, your it needs to be set that way or your iPhone won't work with it.

    Is your router broadcasting its name? If not, you should still be able to connect by selecting "other..." and entering its name.

    Does your laptop CURRENTLY work? I have had incidents where joining a network with my iPhone seems to kick the wireless off, at least for a time. Rebooting the router might help.

    Hope that helps you!
    Aym
  • victo019 Level 1 Level 1 (0 points)
    Man I'm not sure. I have a D-Link wireless router. Not sure how to tell if it is compatible. Anytime I turn my laptop on it connects to my network automatically. When I go to other on the iphone and type in my network name it says "network not found". I tried rebooting the router and nothing happens.
  • victo019 Level 1 Level 1 (0 points)
    Oh and thanks for replying!!! Anything is helpful at this point.
  • AymR Level 2 Level 2 (360 points)
    What's your D-Link model number? Let's look it up on the web.

    Aym
  • victo019 Level 1 Level 1 (0 points)
    I am not at home now but, I am pretty sure it is a WBR-2310.
  • victo019 Level 1 Level 1 (0 points)
    Can anyone help with this????????/
  • bassman67 Level 1 Level 1 (0 points)
    I've been having a similar problem with my iPhone. Mine will show that my network exists, it just can't connect to it. I have a D-Link DI-624 router with Verizon Fios internet. It will show my network on my iPhone, with the full airport-style icon, but when I select Safari on my phone it'll automatically switch back to the Edge network. I've used it at an Apple Store using their wireless network, so I know that the wireless card in the phone is good, I just don't know how to make it pick up my network. Could it possibly be an incompatibility between the AT&T phone and the Verizon internet?

    MacBook Pro   Mac OS X (10.4.10)  
  • Wireless Pains Level 1 Level 1 (0 points)
    I have been having a similar issue. My iPhone shows that I am connected to my network but does not show the wifi symbol and continues to access Edge instead of using the network. My router is a NetGear and my internet access is cable, I have look at the FAQs and the User manual but there is no trouble shooting for wifi. Any help would be appreciated.
  • Woodman56 Level 1 Level 1 (0 points)
    previous discussion groups have said that iPhone doesn't always recognize the correct DNS number......you have to find your ISP's DNS number and enter it manually.....I have the same problem on Verizon network and this did not work.....
  • victo019 Level 1 Level 1 (0 points)
    Call 1-888-MYIPHONE and ask for tier 2 support. They helped me today. Tier 1 was useless.
  • AymR Level 2 Level 2 (360 points)
    Sorry - this got lost in my list of posts.

    It's not what I thought it might be (that your router was a different type of wireless than your iPhone).

    Here's a few things that might help -
    How to put in a password HEX key:
    http://www.macrumors.com/iphone/2007/06/30/unable-to-access-password-wifi-networ ks/

    and here's a fix someone's been posting a lot on these boards that seems to help people:

    You may have an incorrect password. iPhone does not show password errors, it will look like you are connected via wi-fi(fan icon displays) but once you try to surf the web it will switch over to edge.
    This fix has worked for a lot of people.
    1.) unplug router for AT LEAST 10 minutes
    2.) reset network settings on iPhone [go to SETTINGS, then to GENERAL, then to NETWORK... then hit RESET NETWORK SETTINGS]
    3.) power down iPhone [hold sleep/wake button 8 secs, then slide slider to off]
    4.) turn on router [wait about 5 minutes for it to fully cycle up]
    5.) Go to settings - WiFi - choose your network - when the password screen comes up, switch to Hex/ AscII, then enter password [no $] press enter. (note - may be caps sensitive)

    Hope one of those helps!

    Aym