5 Replies Latest reply: Jul 6, 2007 2:53 AM by Rick Van Vliet
Nick Brook Level 1 Level 1 (0 points)
I'm trying to set up Azureus or transmission but I cannot open the ports successfully.
The setup is: ADSL router -> gigabit wired switch -> macbook pro
Upnp is enabled on the router. I spent a long time on IRC trying to solve the problem with some azureus support guys, but we couldn't figure it out. I have set up a manual port forward in the router to my mb. I set the correct port in azureus (/transmission), set an exception in the firewall, but a port test still doesn't work. If I disabled the firewall on the router or my mac, it doesn't work. It doesn't work as an administrator or restricted user. It isn't any settings in Azureus or transmission as I haven't changed the defaults. If I enable upnp in azureus, it works but is slower than it should be, and it should work without it. I'm pretty sure it isn't anything to do with the router as a windows PC set up in exactly the same way with a different IP and port works. I believe this is something on the mac that is blocking the connections, but as I've only had this mac 2 days and I've not installed much, I don't see what it can be.

EDIT: I could be mistaken, but web downloads seem very slow too. I should get around 400kb/s, I actually get about 20-50 on most downloads it seems.

I've pretty exhaustively tested this now and its getting quite frustrating. I can post Azureus's upnp logs if anyone wants to see them.

MBP 15" 2.4ghz Mac OS X (10.4.10)

  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    Nick-
    First check DNS settings. You say that web DL's are slow...you may have old or inaccurate DNS servers in your router's settings or in the Mac's Network Prefs (AppleMenu>SystemPreferences>Network>Configuration)

    I am not an azureus-person. I won't understand the logs, though someone might.
    Port forwarding is fine, but this may be a two-way port problem (outbound port might be hosed).
    Try a different peer-sharing software.
    Reboot router.
    Restart mac.

    There are some ideas.
  • Nick Brook Level 1 Level 1 (0 points)
    Thanks for the help.
    I use openDNS, so it shouldn't be slow.
    I've tried transmission as well as Azureus. I've also used limewire which says the connection is 'turbo-charged' even when I disable upnp, so that's no help really.
    Done the last two steps.

    Here's the upnp log for anyone who can understand it. I have no idea what 169.254.155.79 is (near the bottom)

    [15:54:07] group = /239.255.255.250:0/fw0:fw0-/169.254.155.79: started
    [15:54:07] group = /239.255.255.250:0/en0:en0-/192.168.1.6: started
    [15:54:07] ignoring loopback address /127.0.0.1, interface lo0
    [15:54:07] ignoring IPv6 address /fe80:0:0:0:0:0:0:1%1, interface lo0
    [15:54:07] ignoring loopback address /0:0:0:0:0:0:0:1%0, interface lo0
    [15:54:07] Mapping request: Incoming Peer Data Port (UDP/56456), enabled = true
    [15:54:07] Mapping request: UDP Tracker Client Port (UDP/56456), enabled = true
    [15:54:07] Mapping request: Incoming Peer Data Port (TCP/56456), enabled = true
    [15:54:07] Mapping request: Incoming Peer Data Port (TCP/8080), enabled = false
    [15:54:07] Mapping request: TCP Tracker Port (TCP/6969), enabled = false
    [15:54:07] Mapping request: TCP SSL Tracker Port (TCP/7000), enabled = false
    [15:54:07] Mapping request: UDP Tracker Port (UDP/6969), enabled = false
    [15:54:07] Mapping request: Distributed DB (UDP/56456), enabled = true
    [15:54:07] Device 'http://192.168.1.1:80/DeviceDescription.xml' is ok: discover=0,found=0,readok=0,read_bad=0,map_ok=0,mapbad=0
    [15:54:07] UPnP: root discovered: usn=uuid:11111111-%04x-c0a8-101001349b0e9::upnp:rootdevice, location=http://192.168.1.1:80/DeviceDescription.xml, ni=en0,local=/192.168.1.6
    [15:54:07] Downloading: http://192.168.1.1:80/DeviceDescription.xml
    [15:54:08] Relative URL base is http://192.168.1.1:80
    [15:54:08] ZyXEL Prestige 660HW-T1 Internet Sharing Gateway
    [15:54:08] urn:schemas-upnp-org:service:Layer3Forwarding:1:desc=http://192.168.1.1:80/L3Fw d.xml, control=http://192.168.1.1:80/UD/?0
    [15:54:08] ZyXEL Prestige 660HW-T1 Internet Sharing Gateway
    [15:54:08] urn:schemas-upnp-org:service:WANCommonInterfaceConfig:1:desc=http://192.168.1.1 :80/WanCommonIfc1.xml, control=http://192.168.1.1:80/UD/?1
    [15:54:08] ZyXEL Prestige 660HW-T1 Internet Sharing Gateway *
    [15:54:08] urn:schemas-upnp-org:service:WANDSLLinkConfig:1:desc=http://192.168.1.1:80/WanD slLink.xml, control=http://192.168.1.1:80/UD/?2
    [15:54:08] urn:schemas-upnp-org:service:WANIPConnection:1:desc=http://192.168.1.1:80/WanIp Conn.xml, control=http://192.168.1.1:80/UD/?3
    [15:54:08] ZyXEL Prestige 660HW-T1 Internet Sharing Gateway
    [15:54:08] urn:schemas-upnp-org:service:LANHostConfigManagement:1:desc=http://192.168.1.1: 80/LanHostCfgMgmt.xml, control=http://192.168.1.1:80/UD/?4
    [15:54:08] Found WANIPConnection
    [15:54:08] Downloading: http://192.168.1.1:80/WanIpConn.xml
    [15:54:08] UPnP: Mapping 'Incoming Peer Data Port (UDP/56456)' established
    [15:54:08] UPnP: Mapping 'Incoming Peer Data Port (UDP/56456)' established
    [15:54:08] Mapping UDP Tracker Client Port (UDP/56456) already established
    [15:54:08] UPnP: Mapping 'Incoming Peer Data Port (TCP/56456)' established
    [15:54:08] UPnP: Mapping 'Incoming Peer Data Port (TCP/56456)' established
    [15:54:08] Mapping Distributed DB (UDP/56456) already established
    [15:54:22] Device 'http://169.254.155.79:8008/RootDevice.xml' is ok: discover=0,found=0,readok=0,read_bad=0,map_ok=0,mapbad=0
    [15:54:22] UPnP: root discovered: usn=uuid:89bccb25-4b13-af9e-e5ab-94be0185a62b::upnp:rootdevice, location=http://169.254.155.79:8008/RootDevice.xml, ni=fw0,local=/169.254.155.79
    [15:54:22] Downloading: http://169.254.155.79:8008/RootDevice.xml
  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    So you've checked teh DNS setings on both the router and the Mac.
    And you're saying Limewire & transmission both work, or both fail?

    169.254.155.79 indicates a device attached to your Firewire
    (see the first line? fw0...)
    that IP address indicates that this device can't find a DHCP server.
    May or may not have anything to do with your azureus issue.
    Are you trying Internet Sharing?
    Can you disable the network over firewire?
  • Nick Brook Level 1 Level 1 (0 points)
    I apologise greatly for wasting everyone's time.

    In my router, I have a port forwarding section in the firewall - but also in the NAT settings. While I had setup the firewall correctly, I hadn't set the NAT. This blocked connections without using upnp, but it worked when using it. As for the speed, I'll have to keep an eye on it and see if I think it is actually a problem.

    Thanks very much for your support, and sorry again. The moral of this story is - don't think you're above reading the instructions
  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    You didn't waste everyone's time.

    There is an acronym that has survived on the 'net for a few years. And take this with a good-natured wink.
    Read
    The
    Fine
    Manual
    (or RTFM)

    Have fun, thanks for your update.