1 4 5 6 7 8 Previous Next 110 Replies Latest reply: Nov 17, 2009 11:36 AM by woof1912 Go to original post
  • 75. Re: MacBook Pro USB port problem...
    Plunjer Level 1 Level 1 (0 points)
    Ok I figured something out here ! I have had this 'left USB port' issue with my MBP recently, and it only happened after trying to use a SUB-Serial converter in the left USB port with Windows (Bootcamp).
    I got an error message saying that there was a malfunction with the device, and subsequently, the Windows Device Manager said that "No drivers were installed for this device". After seeing that the port sends power to devices but would not read them, and reading of some issues with Leopard and hardware, I decided to re-install OS X 10.4 Tiger. That did the trick, and the drive is reading devices normally again.
    Leopard has apparently had quite a few issues with onboard hardware, and has had a few firmware upgrades, but this UBS port issue could well be software (driver) oriented. Those of you who have Tiger, could try a clean re-install after backing up all you settings and info, try the left port, then upgrading to Leopard again. If you only have Leopard, then perhaps try a clean re-install of Leopard before further upgrading to the latest version.
    See what happens.
  • 76. Re: MacBook Pro USB port problem...
    Plunjer Level 1 Level 1 (0 points)
    Just to update my previous post, including correcting a spelling error (USB, not SUB), the problem of the left USB port not reading was solved by:
    Backing up the main drive in Time Machine, doing a clean re-install of OS X 10.4 Tiger, and checking the left USB port again.
    Once this worked, and it did, I re-installed OS X 10.5 Tiger and updated it to the most current version (10.5.4). Finally I restored the hard drive from Time Machine (last backup performed) by starting up from the Leopard Install DVD, and selecting the Restore using Time Machine selection in the "Utilities" menu.
  • 77. Re: MacBook Pro USB port problem...
    Nathan Jones Level 1 Level 1 (45 points)
    Wow, Plunjer did you reinstall Tiger 10.4 (and upgrade to 10.4.11) or Leopard 10.5 (and upgrade to 10.5.4)?

    Basically, I believe this problem cropped up way back around 10.4.9 and 10.4.10 .... I believe that Apple released an update which decreased power to the USB ports -- maybe even to specifications -- and the first thing that happened was that I had numerous clients lose the contents of their USB drives... I had a rash of all-out drive failures, color calibrators would not connect, my small cell phone would no longer charge, etc.

    The newer updates fixed the all-out failures (I think) but left the underpowered devices. I now suspect Apple was trying to get a lower-powered specification, underdid it, and then brought it back to specs (maybe) but it basically killed many peoples' ability to hook up external drives without external power. I can't believe that peoples' jump-flash drives weren't connecting! Those are low-powered devices!

    Eventually, I found that I could use a USB hub creatively but even that didn't always work.

    Alas, I don't think Apple thinks this is a real problem... they probably took things to "specification" and are like "look, it's to spec, these other companies are at fault"... pretty ridiculous argument. People do the same thing with law, science, nutrition, etc. People just made up those specifications at some point ... it was probably a conservative decision that was part-economic, part-practical, part-safety, part-functional. And I'm SURE there are numerous other specifications that Apple does not tightly adhere to. In this case, we were better off when they didn't...
  • 78. Re: MacBook Pro USB port problem...
    Nathan Jones Level 1 Level 1 (45 points)
    Excellent observation.

    I suspected the problem was introduced around 10.4.9/10.4.10 and they were released March 2007 and June 2007 respectively.
  • 79. Re: MacBook Pro USB port problem...
    Peter Wang1 Level 1 Level 1 (10 points)
    For what it's worth, I have also experienced some intermittent issues w/the left USB port. My impression is that it is a low power issue. For example, the Gigaware optical mouse I use with scroll wheel suddenly was unable to move the cursor around the screen. However, it still was able to right/left click and the scroll wheel was still operable. I plugged in my Apple Pro Mouse and it refused to work. Both mice worked fine in the right USB port.

    I did a PMU reset and that resolved the issue at least for now. I imagine due to the length of this thread that perhaps many of you have tried a reset, however, since no one specifically stated it, I thought others may want to give it a go....worked for me at least.

    Good luck!
  • 80. Re: MacBook Pro USB port problem...
    Jason Chatham Level 1 Level 1 (0 points)
    I too share the issue...

    I tried plugging in my M-Audio Radium 61 Keyboard into the left USB port and it would not work with Logic Mainstage or Reason programs. It would drop the signal and most of the time not work at all. The keyboard draws its power from the USB, so I know there is a big issue with this port.

    Apple needs to wake up!
  • 81. Re: MacBook Pro USB port problem...
    BigboiJ Level 1 Level 1 (0 points)
    the PMU/SMC reset fixed it!

    MacBook, MacBook Pro

    1. If the computer is on, turn it off.
    2. Disconnect the AC Adapter and remove the computer's battery.
    3. Press and hold down the power button for 5 seconds and then release the button.
    4. Reconnect the battery and AC Adapter.
    5. Press the Power button to restart the computer.
  • 82. Re: MacBook Pro USB port problem...
    mc625569 Level 1 Level 1 (0 points)
    Same issue:

    Ive worked on a lot of USB ports both PC and mac that have this issue, always laptops since power is more scarce on those. Right port on my MBP wont run anything that required substantial power, including pretty much ANY external HD.

    I've seen problems like this a lot in all types of laptops, its not uncommon, but since we pay more for apple products, we do expect more.

    I won't shy away from bashing apple. This is my first mac, and seeing that I now know Im NOT paying a premium for improved support, accountability, and moreover, solutions to the problem, I cant say im lining up to get another apple.

    If I want bad support and manufacturers passing the buck to 3rd party hardware, Ill get a PC.

    This happens with ANY hardware the requires power, namely External drives. Last night it started happening with a USB microphone, and a USB mouse.

    Not acceptable.
  • 83. Re: MacBook Pro USB port problem...
    fanetin Level 1 Level 1 (0 points)
    I do have that problem as well. Left USB random interrupts. I have a 7 port USB powered HUB with 2 x external HDs, another HD with Time Machine, a printer, the ipod,... well I changed to the right USB port and will see what happens...
    cheers

    St.
  • 84. Re: MacBook Pro USB port problem...
    storzey Level 1 Level 1 (0 points)
    I have the same repeatedly stated problem with my left usb port. This is extremely annoying because my new DJ mixer requires a usb port for each channel, but one does not work.

    If I get a high speed usb dock with say 4 extra usb ports and connect it to my (working) right usb port will this work? That way I could connect both usb leads from my DJ mixer to my working right port.
  • 85. Re: MacBook Pro USB port problem...
    DonWorth Level 1 Level 1 (0 points)
    I have the same problem with the left ports on my MBP 17". I have had my mouse and external keyboard go dead on me, and my HP Scanjet 8300 works about half the time (although that could be also related to HP's junky software). I'm tired of playing musical chairs with my USB devices.

    Assuming the right port is good, why wouldn't it work to plug a powered USB hub into that and plug everything into the hub and just abandon the left USB ports on the MBP? Or am I misunderstanding how USB ports work?

    Don
  • 86. Re: MacBook Pro USB port problem...
    BEIGE Level 1 Level 1 (5 points)
    I just googled this problem since I just got my FIFTH MacBook Pro repair (four motherboards and a new machine) due to the NVidia glitches and now this. ******* ****, Apple. What a mess. Now for my sixth motherboard. Do I get a hat or something when I reach ten?
  • 87. Re: MacBook Pro USB port problem...
    snazawa Level 1 Level 1 (0 points)
    Just read the solution about the SMC reset, and so far that has solved the problem on my MBP too. I would suggest trying that first.
  • 88. Re: MacBook Pro USB port problem...
    Binwooke Level 1 Level 1 (0 points)
    I tried the PMU/SMC reset and it had no effect on my 15" MBP. I guess a trip to the Genius Bar is in order.
  • 89. Re: MacBook Pro USB port problem...
    nicktumi Level 1 Level 1 (0 points)
    Same issue here. Had a external usb powered hd hooked up to the left usb port. until today it is not working at all. it powers the hd but does not mount.
1 4 5 6 7 8 Previous Next