4 Replies Latest reply: Jul 15, 2007 11:31 AM by David Gimeno Gost
Juventus Level 1 (0 points)
It has been recently that whenever I click a link within an email body, I get the following message :
Mail was unable to open the URL mail “http://www.xxxx.com”. No associated application could be found.

However Safari is set as my default browser

What am I missing?

MIni, Mac OS X (10.4.7)
  • David Gimeno Gost Level 7 (20,775 points)
    This could be a Launch Services issue. The following article describes how to manually reset Launch Services — the notes at the bottom of the article also provide information about the side effects of deleting each of the files involved:

    Resetting Launch Services

    If you prefer using a cache cleaning utility instead of following the manual procedure described in the previous article, take a look at this other article for general troubleshooting and cache-cleaning procedures. Actually, you should also verify/repair the startup disk (not just permissions), as described there:

    Resolving Disk, Permission, and Cache Corruption

    The most appropriate utility for this particular problem probably is Tiger Cache Cleaner, but you may also want to consider other utilities, such as OnyX, or Cache Out X, which are free. Whatever utility you choose, be sure to read this first:

    Side effects of System cache cleaning

    As an example, this is how you should proceed with OnyX:

    1. Quit all applications.
    2. Launch OnyX and enter your administrator password.
    3. Go to Maintenance > Reset and check LaunchServices database.
    4. Un-check any other pre-checked options.
    5. Click the Execute button.
    6. Restart the computer.

    BTW, if you’re running Mac OS X 10.4 (Tiger), as your profile indicates, it would have been more appropriate to discuss this in the Mail & Address Book - Tiger forum. If the discussion applies to both Mail 1.x and Mail 2.x, it doesn’t really matter, but it’s difficult to know that in advance.
  • Juventus Level 1 (0 points)
    Thanks David!
    The Tiger Cache cleaner worked
    The manual deletion of cache did not!

    But now I have restored it!
  • Juventus Level 1 (0 points)
    David was very helpful!
  • David Gimeno Gost Level 7 (20,775 points)
    You’re welcome, but if this was a Launch Services issue, the manual procedure should have worked as well. Actually, what I’ve seen sometimes happen is the opposite, i.e. the manual procedure fixed what a cache cleaning utility didn’t, which makes me believe you did something wrong. Anyway, glad to know the problem is fixed now.